<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
    <meta http-equiv="content-type" content="text/html; charset=UTF-8" />
    <meta name="description" content="Software Development News" />
    <title>Continuous testing in a fast-paced agile and DevOps world - SD Times</title>
    <meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">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</script>
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <link rel="pingback" href="http://sdtimes.com/xmlrpc.php" />
    
<script type='text/javascript'>
var ct_ajaxurl = 'http://sdtimes.com/wp-admin/admin-ajax.php';
 var ct_info_flag=false;
var ct_set_cookies_flag=true;
 </script>

<!-- This site is optimized with the Yoast SEO plugin v4.6 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Continuous testing goes beyond automation to enable a continuous delivery software process"/>
<meta name="news_keywords" content="agile, ca technologies, cd, continuous delivery, continuous integration, continuous testing, developers, devops, hpe, mobile labs, parasoft, rogue wave, software development, techexcel, tricentis, software, programming, programmers, coders" />
<meta name="original-source" content="http://sdtimes.com/continuous-testing-fast-paced-agile-devops-world/" />
<meta name="robots" content="noodp"/>
<link rel="canonical" href="http://sdtimes.com/continuous-testing-fast-paced-agile-devops-world/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Continuous testing in a fast-paced agile and DevOps world - SD Times" />
<meta property="og:description" content="Continuous testing goes beyond automation to enable a continuous delivery software process" />
<meta property="og:url" content="http://sdtimes.com/continuous-testing-fast-paced-agile-devops-world/" />
<meta property="og:site_name" content="SD Times" />
<meta property="article:publisher" content="https://www.facebook.com/SDTimesBZ" />
<meta property="article:tag" content="agile" />
<meta property="article:tag" content="CA Technologies" />
<meta property="article:tag" content="CD" />
<meta property="article:tag" content="continuous delivery" />
<meta property="article:tag" content="continuous integration" />
<meta property="article:tag" content="continuous testing" />
<meta property="article:tag" content="developers" />
<meta property="article:tag" content="DevOps" />
<meta property="article:tag" content="HPE" />
<meta property="article:tag" content="Mobile Labs" />
<meta property="article:tag" content="Parasoft" />
<meta property="article:tag" content="Rogue Wave" />
<meta property="article:tag" content="software development" />
<meta property="article:tag" content="TechExcel" />
<meta property="article:tag" content="Tricentis" />
<meta property="article:section" content="Buyers Guide" />
<meta property="article:published_time" content="2017-04-24T09:00:00-04:00" />
<meta property="article:modified_time" content="2017-04-24T10:47:43-04:00" />
<meta property="og:updated_time" content="2017-04-24T10:47:43-04:00" />
<meta property="og:image" content="http://sdtimes.com/wp-content/uploads/2017/04/BGtest.jpg" />
<meta property="og:image:width" content="660" />
<meta property="og:image:height" content="371" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Continuous testing goes beyond automation to enable a continuous delivery software process" />
<meta name="twitter:title" content="Continuous testing in a fast-paced agile and DevOps world - SD Times" />
<meta name="twitter:site" content="@sdtimes" />
<meta name="twitter:image" content="http://sdtimes.com/wp-content/uploads/2017/04/BGtest.jpg" />
<meta name="twitter:creator" content="@chriscatdoza" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SD Times &raquo; Feed" href="http://sdtimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="SD Times &raquo; Comments Feed" href="http://sdtimes.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="SD Times &raquo; Continuous testing in a fast-paced agile and DevOps world Comments Feed" href="http://sdtimes.com/continuous-testing-fast-paced-agile-devops-world/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/sdtimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ff_interstitial_css-css'  href='http://sdtimes.com/wp-content/mu-plugins/sdtimes/interstitial-ads/css/style.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='sdtimes-lesscss-css'  href='http://sdtimes.com/wp-content/themes/sdtimes2014/css/bootstrap.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='http://fonts.googleapis.com/css?family=Source+Sans+Pro%3A300%2C400%2C600%2C700%2C600italic%7CLato%3A400%2C700%7CBitter%3A400%2C700&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-fonts-css'  href='http://sdtimes.com/wp-content/themes/sdtimes2014/fonts/font-awesome-4.0.3/css/font-awesome.min.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='mr_social_sharing-css'  href='http://sdtimes.com/wp-content/plugins/social-sharing-toolkit/style_2.1.2.css?ver=4.7.3' type='text/css' media='all' />
<script type='text/javascript' src='http://sdtimes.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-content/mu-plugins/sdtimes/interstitial-ads/js/kkcountdown.dev.js?ver=3.0'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-content/mu-plugins/sdtimes/interstitial-ads/js/interstitial-ads.js?ver=3.0'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-content/themes/sdtimes2014/js/menu-hover.js?ver=4.7.3'></script>
<link rel='https://api.w.org/' href='http://sdtimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://sdtimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://sdtimes.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.3" />
<link rel='shortlink' href='http://sdtimes.com/?p=24622' />
<link rel="alternate" type="application/json+oembed" href="http://sdtimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fsdtimes.com%2Fcontinuous-testing-fast-paced-agile-devops-world%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://sdtimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fsdtimes.com%2Fcontinuous-testing-fast-paced-agile-devops-world%2F&#038;format=xml" />
<!-- Start of Async HubSpot Analytics Code -->
    <script type="text/javascript">
        (function(d,s,i,r) {
            if (d.getElementById(i)){return;}
            var n=d.createElement(s),e=d.getElementsByTagName(s)[0];
            n.id=i;n.src='//js.hs-analytics.net/analytics/'+(Math.ceil(new Date()/r)*r)+'/369936.js';
            e.parentNode.insertBefore(n, e);
        })(document,"script","hs-analytics",300000);
    </script>
<!-- End of Async HubSpot Analytics Code --><!-- Begin Google Analytics -->
    <script type="text/javascript">

        var _gaq = _gaq || [];
        _gaq.push(['_setAccount', 'UA-846073-1']);
        _gaq.push(['_trackPageview']);

        (function () {
            var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
            ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
            var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
        })();

	</script>
	<!-- END Google Analytics --><meta http-equiv="refresh" content="900" /><script type="text/javascript" src="http://www.queryly.com/js/queryly.js"></script>
<script type="text/javascript">
   queryly.QuerylyKey = 'af2d91c2c83847f8';
   queryly.layout.topMargin = -8;
   queryly.layout.rightMargin = -74;

   queryly.QuerylyCallback = function (a, b) {
       queryly.jquery('#queryly_suggest').css('opacity', '0.3');
   }
</script>
	</head>
<body class="post-template-default single single-post postid-24622 single-format-standard">

<div class="visible-sm visible-md" id="sm-top-banner-wrapper"></div>
<div class="row dmbs-top-menu visible-xs">
        <nav class="navbar" role="navigation">
            <div class="-container-">
				<div class="navbar-header navbar-inverse">
				    <div class="navbar-logo">
                        <a href="http://sdtimes.com/"><img src="/wp-content/uploads/2014/06/Logo_SDTimes_Mobile.png"></a>
                    </div>
                    <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-1-collapse">
				        <span class="sr-only">Toggle navigation</span>
				        <span class="icon-bar"></span>
				        <span class="icon-bar"></span>
				        <span class="icon-bar"></span>
				    </button>
				</div>
				<div class="collapse navbar-collapse navbar-1-collapse"><ul id="menu-main-desktop" class="nav navbar-nav"><li id="menu-item-5222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5222 dropdown"><a title="Features" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Features <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5789" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5789"><a title="In-Depth" href="http://sdtimes.com/category/in-depth/">In-Depth</a></li>
	<li id="menu-item-5371" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5371"><a title="Buyer&#039;s Guide" href="http://sdtimes.com/category/buyers-guide/">Buyer&#8217;s Guide</a></li>
	<li id="menu-item-19071" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19071"><a title="SD Times 100" href="http://sdtimes.com/sd-times-100/sd-times-100-blazing-their-own-trail/">SD Times 100</a></li>
	<li id="menu-item-5372" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5372"><a title="Special Report" href="http://sdtimes.com/category/special-report/">Special Report</a></li>
	<li id="menu-item-9652" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9652"><a title="Industry Spotlight" href="http://sdtimes.com/category/industry-spotlight/">Industry Spotlight</a></li>
</ul>
</li>
<li id="menu-item-5039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5039 dropdown"><a title="SD Times Magazine" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">SD Times Magazine <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5161" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5161"><a title="Subscribe" href="http://resources.sdtimes.com/sdtimes-subscription">Subscribe</a></li>
	<li id="menu-item-5392" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5392"><a title="Download Issue" href="http://resources.sdtimes.com/download-latest-issue">Download Issue</a></li>
	<li id="menu-item-7272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7272"><a title="Back Issues" href="http://sdtimes.com/back-issues/">Back Issues</a></li>
	<li id="menu-item-5397" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5397"><a title="Working with the Editors" href="http://sdtimes.com/sd-times-magazine/working-with-the-editors/">Working with the Editors</a></li>
	<li id="menu-item-5414" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5414"><a title="Guest View Guidelines" href="http://sdtimes.com/sd-times-magazine/guest-view-guidelines/">Guest View Guidelines</a></li>
	<li id="menu-item-5430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5430"><a title="SD Times 100 Guide" href="http://sdtimes.com/sd-times-100/">SD Times 100 Guide</a></li>
	<li id="menu-item-5415" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5415"><a title="Advertise" href="http://sdtimes.com/sd-times-magazine/advertise/">Advertise</a></li>
</ul>
</li>
<li id="menu-item-5389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5389 dropdown"><a title="Learning Center" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Learning Center <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5701" class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5701"><a title="White Papers" href="http://sdtimes.com/sections/white-papers/">White Papers</a></li>
	<li id="menu-item-5704" class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5704"><a title="Webinars" href="http://sdtimes.com/sections/webinars/">Webinars</a></li>
	<li id="menu-item-5703" class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5703"><a title="Industry Profiles" href="http://sdtimes.com/sections/industry-profiles/">Industry Profiles</a></li>
</ul>
</li>
<li id="menu-item-5387" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5387 dropdown"><a title="Events" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Events <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5223" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5223"><a title="AnDevCon" target="_blank" href="http://www.andevcon.com/"><span class="glyphicon _blank"></span>&nbsp;AnDevCon</a></li>
	<li id="menu-item-11999" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11999"><a title="InterDrone" target="_blank" href="http://www.interdrone.com/"><span class="glyphicon _blank"></span>&nbsp;InterDrone</a></li>
	<li id="menu-item-5227" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5227"><a title="SPTechCon" target="_blank" href="http://www.sptechcon.com/"><span class="glyphicon _blank"></span>&nbsp;SPTechCon</a></li>
</ul>
</li>
<li id="menu-item-24360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24360"><a title="Dev Ops" href="/tag/devops/">Dev Ops</a></li>
</ul></div>			</div>
        </nav>
    </div>

<div class="container dmbs-container">
    <div class="adWrap">
        <div class="adWrapCenter">
            <div class="innerAdWrapCenter">
                <div class="fl">
                    			<div class="banner_ad gutter_ad_left">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/Gutter_left', [300, 1050], 'div-gpt-ad-1455057831195-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/Gutter_left -->
<div id='div-gpt-ad-1455057831195-0' style='height:1050px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1455057831195-0'); });
</script>
</div>				</div>
			</div>
			                </div>
                <div class="fr">
                    			<div class="banner_ad gutter_ad_right">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/Gutter_Right', [300, 1050], 'div-gpt-ad-1455057942067-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/Gutter_Right -->
<div id='div-gpt-ad-1455057942067-0' style='height:1050px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1455057942067-0'); });
</script>
</div>				</div>
			</div>
			                </div>
            </div>
        </div>
    </div>
    <div class="row dmbs-header hidden-xs">

        <div class="col-md-3 col-sm-4 dmbs-header-img">
            <a href="http://sdtimes.com/"><img src="http://sdtimes.com/wp-content/uploads/2014/05/LOGO_SDTimes.png" height="76" width="233" alt="" /></a>
        </div>

        <div class="col-md-9 col-sm-8 dmbs-header-text">
            <div class="top-ad leader-board">
				<div class="banner_ad top_leaderboard">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
 googletag.cmd.push(function() {
  googletag.defineSlot('/67541884/Leaderboard_Top_1', [728, 90], 'div-gpt-ad-1466026021929-0').addService(googletag.pubads());
  googletag.pubads().enableSingleRequest();
  googletag.enableServices();
 });
</script>

<!-- /67541884/Leaderboard_Top_1 -->
<div id='div-gpt-ad-1466026021929-0' style='height:90px; width:728px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026021929-0'); });
</script>
</div>				</div>
			</div>
			</div>        </div>

    </div>

    <div class="row nav-content hidden-xs">
        <div class="trending-box">
    <img src="/wp-content/themes/sdtimes2014/img/7-trending.png" />
    <ul><li><a href="http://sdtimes.com/continuous-testing-fast-paced-agile-devops-world/">Continuous testing in a fast-paced agile and DevOps world</a></li><li><a href="http://sdtimes.com/overcoming-agile-barriers-testers/">Guest View: Overcoming agile barriers for testers</a></li><li><a href="http://sdtimes.com/owasp-adds-unprotected-apis-insufficient-attack-protection-top-ten-2017-release/">OWASP adds unprotected APIs, insufficient attack protection to Top Ten 2017 release</a></li><li><a href="http://sdtimes.com/amazon-web-services-releases-codestar-x-ray/">Amazon Web Services releases CodeStar and X-Ray</a></li><li><a href="http://sdtimes.com/dockercon-docker-announces-two-new-collaborative-open-source-container-projects/">DockerCon: Docker announces two new collaborative open-source container projects</a></li><li><a href="http://sdtimes.com/software-architects-can-control-future-software-architecture/">How software architects can control the future of software architecture</a></li><li><a href="http://sdtimes.com/facebook-announces-react-fiber-react-vr-relay-modern-litho/">Facebook announces React Fiber, React VR, Relay Modern, and Litho</a></li></ul></div>        <div id="nav-grouping-1" class="col-sm-10 padless">
            

    <div class="row dmbs-top-menu hidden-xs">
        <nav class="navbar" role="navigation">
            <div class="-container-">
                <div class="collapse navbar-collapse navbar-1-collapse"><ul id="menu-main-desktop-1" class="nav navbar-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5222 dropdown"><a title="Features" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Features <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5789"><a title="In-Depth" href="http://sdtimes.com/category/in-depth/">In-Depth</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5371"><a title="Buyer&#039;s Guide" href="http://sdtimes.com/category/buyers-guide/">Buyer&#8217;s Guide</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19071"><a title="SD Times 100" href="http://sdtimes.com/sd-times-100/sd-times-100-blazing-their-own-trail/">SD Times 100</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5372"><a title="Special Report" href="http://sdtimes.com/category/special-report/">Special Report</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9652"><a title="Industry Spotlight" href="http://sdtimes.com/category/industry-spotlight/">Industry Spotlight</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5039 dropdown"><a title="SD Times Magazine" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">SD Times Magazine <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5161"><a title="Subscribe" href="http://resources.sdtimes.com/sdtimes-subscription">Subscribe</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5392"><a title="Download Issue" href="http://resources.sdtimes.com/download-latest-issue">Download Issue</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7272"><a title="Back Issues" href="http://sdtimes.com/back-issues/">Back Issues</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5397"><a title="Working with the Editors" href="http://sdtimes.com/sd-times-magazine/working-with-the-editors/">Working with the Editors</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5414"><a title="Guest View Guidelines" href="http://sdtimes.com/sd-times-magazine/guest-view-guidelines/">Guest View Guidelines</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5430"><a title="SD Times 100 Guide" href="http://sdtimes.com/sd-times-100/">SD Times 100 Guide</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5415"><a title="Advertise" href="http://sdtimes.com/sd-times-magazine/advertise/">Advertise</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5389 dropdown"><a title="Learning Center" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Learning Center <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5701"><a title="White Papers" href="http://sdtimes.com/sections/white-papers/">White Papers</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5704"><a title="Webinars" href="http://sdtimes.com/sections/webinars/">Webinars</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5703"><a title="Industry Profiles" href="http://sdtimes.com/sections/industry-profiles/">Industry Profiles</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5387 dropdown"><a title="Events" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Events <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5223"><a title="AnDevCon" target="_blank" href="http://www.andevcon.com/"><span class="glyphicon _blank"></span>&nbsp;AnDevCon</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11999"><a title="InterDrone" target="_blank" href="http://www.interdrone.com/"><span class="glyphicon _blank"></span>&nbsp;InterDrone</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5227"><a title="SPTechCon" target="_blank" href="http://www.sptechcon.com/"><span class="glyphicon _blank"></span>&nbsp;SPTechCon</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24360"><a title="Dev Ops" href="/tag/devops/">Dev Ops</a></li>
</ul></div>            </div>
        </nav>
    </div>

            <div class="ticker">
	<div>
		<span>Tue. Apr 25</span> - &nbsp;
	</div>
	<div class="news">
		<div><a href="http://sdtimes.com/continuous-testing-fast-paced-agile-devops-world/" rel="bookmark" title="Permalink to Continuous testing in a fast-paced agile and DevOps world">Continuous testing in a fast-paced agile and DevOps world</a></div><div><a href="http://sdtimes.com/linux-foundation-announces-new-iot-edge-computing-project-edgex-foundry/" rel="bookmark" title="Permalink to The Linux Foundation announces a new IoT edge computing project: EdgeX Foundry">The Linux Foundation announces a new IoT edge computing project:&hellip;</a></div><div><a href="http://sdtimes.com/apples-livephotoskit-js-lyrebirds-voice-imitation-algorithm-augmenta-studio-sd-times/" rel="bookmark" title="Permalink to Apple’s LivePhotosKit JS, Lyrebird’s voice imitation algorithm, and Augmenta Studio — SD Times news digest: April 24, 2017">Apple’s LivePhotosKit JS, Lyrebird’s voice imitation algorithm, and Augmenta Studio&hellip;</a></div><div><a href="http://sdtimes.com/guide-continuous-testing-tools/" rel="bookmark" title="Permalink to A guide to continuous testing tools">A guide to continuous testing tools</a></div><div><a href="http://sdtimes.com/makes-continuous-testing-solution-stand/" rel="bookmark" title="Permalink to What makes your continuous testing solution stand out?">What makes your continuous testing solution stand out?</a></div>	</div>
</div>
<script type="text/javascript">
(function ($) {

	var fade = 1000;
	var restart_pause = 2000;
	var pause = 6000;
	function fadingScroller($el) {
		$el.animate({'opacity': 0}, fade);
		$el.hide('slow', function () {
			$el.parent().append($el);
			$el.show();
			$el.animate({'opacity': 1}, restart_pause);
			setTimeout(function ($el) {
				return function () {
					fadingScroller($($el.selector));
				};
			}($el), pause);
		});
	}
	fadingScroller($('.ticker div div:first'));
})(jQuery);
</script>        </div>
        <div id="nav-grouping-2" class="col-sm-10 hidden-xs padless">
            <div class="social">
	<ul>
		<li><a class="fa fa-facebook" href="https://www.facebook.com/SDTimesBZ"></a></li>
		<li><a class="fa fa-twitter" href="http://www.twitter.com/sdtimes"></a></li>
	</ul>
</div>            <div id="top-search-form">
	<form role="search" method="get" id="searchform" class="searchform" action="http://sdtimes.com/">
		<div>
			<div class="col-md-9 col-sm-10 padless"><input type="text" class="queryly" value="" name="s" id="s"><script type="text/javascript">queryly.QuerylyBind();</script></div>
			<div class="col-md-3 col-sm-2 padless search-point"><input type="submit" id="searchsubmit" value="Search"></div>
			<div class="clearfix"></div>
		</div>
	</form>
</div>        </div>
    </div>


<!-- start content container -->
<div class="row dmbs-content">

		
	<div class="col-md-8 dmbs-main col-xs-12 col-sm-7 hnews hentry item">

			
						<div class="post-24622 post type-post status-publish format-standard has-post-thumbnail hentry category-buyers-guide category-latest-news tag-agile tag-ca-technologies tag-cd tag-continuous-delivery tag-continuous-integration tag-continuous-testing tag-developers tag-devops tag-hpe tag-mobile-labs tag-parasoft tag-rogue-wave tag-software-development tag-techexcel tag-tricentis">

							<h1 class="page-header">Continuous testing in a fast-paced agile and DevOps world</h1>

								<div class="postmeta">
			<span class="categories"><a href="http://sdtimes.com/category/buyers-guide/" rel="category tag">Buyers Guide</a></span><span class="categories"><a href="http://sdtimes.com/category/latest-news/" rel="category tag">Latest News</a></span>
			<div class="published">Published: <span class="updated">April 24th, 2017</span></div>
			- <span class="author-bio"><a href="http://sdtimes.com/author/christina-mulligan/" title="Posts by Christina Cardoza" rel="author">Christina Cardoza</a></span>
				</div>

							<div>
								<div class="row">
									<div class="col-md-3">
										<div class="social"><!-- filled dynamically --></div>
										<div class="tags">
																							<h3>Article Tags</h3>
												<p>
												<a href="http://sdtimes.com/tag/agile/" rel="tag">agile</a>, <a href="http://sdtimes.com/tag/ca-technologies/" rel="tag">CA Technologies</a>, <a href="http://sdtimes.com/tag/cd/" rel="tag">CD</a>, <a href="http://sdtimes.com/tag/continuous-delivery/" rel="tag">continuous delivery</a>, <a href="http://sdtimes.com/tag/continuous-integration/" rel="tag">continuous integration</a>, <a href="http://sdtimes.com/tag/continuous-testing/" rel="tag">continuous testing</a>, <a href="http://sdtimes.com/tag/developers/" rel="tag">developers</a>, <a href="http://sdtimes.com/tag/devops/" rel="tag">DevOps</a>, <a href="http://sdtimes.com/tag/hpe/" rel="tag">HPE</a>, <a href="http://sdtimes.com/tag/mobile-labs/" rel="tag">Mobile Labs</a>, <a href="http://sdtimes.com/tag/parasoft/" rel="tag">Parasoft</a>, <a href="http://sdtimes.com/tag/rogue-wave/" rel="tag">Rogue Wave</a>, <a href="http://sdtimes.com/tag/software-development/" rel="tag">software development</a>, <a href="http://sdtimes.com/tag/techexcel/" rel="tag">TechExcel</a>, <a href="http://sdtimes.com/tag/tricentis/" rel="tag">Tricentis</a>												</p>
																					</div>

										<div>
																					</div>
									</div>
									<div class="col-md-9 postContent">
																					<img width="490" height="275" src="http://sdtimes.com/wp-content/uploads/2017/04/BGtest.jpg" class="attachment-post-content-thumb size-post-content-thumb wp-post-image" alt="" /><div class="caption"></div>																				<p><span style="font-weight: 400;">In a world where businesses not only have to become software companies to compete, but deliver higher quality software to market faster, what does this mean for testing? Businesses and software teams have become so concerned with developing and delivering in an agile fashion, they have had to stop and rethink their entire testing process. </span></p>
<p><span style="font-weight: 400;">This is because traditional or legacy testing tools and processes don’t comply with speed, according to Aruna Ravichandran, vice president of DevOps product and solutions marketing at CA Technologies. To compete in a world where high-quality app experiences are the expectation, testing needs to be efficient and effective, and that requires a continuous testing approach, according to Ravichandran.  </span></p>
<p><span style="font-weight: 400;">“Testing needs to be as fast and as dynamic as our agile development processes, otherwise we are going to have delays in developing and shipping it to operations,” said Wolfgang Platz, founder and chief product officer of Tricentis. </span></p>
<p><span style="font-weight: 400;">Platz explained agile has always been thought of as a development initiative from the beginning, which was too narrow. While it accelerated the speed of development and brought value to customers faster, agile development needed to take operations into consideration. “All of a sudden we weren’t talking about agile anymore, but talking about DevOps,” said Platz. But as soon as people started to pursue a DevOps agenda, they realized there was an ugly stepchild in the middle that needed to be taken care of, which is testing. </span></p>
<p><span style="font-weight: 400;">“In many ways, testing is the final frontier of DevOps and continuous delivery. To release the high-quality code that enables businesses to stay ahead of their competition faster, organizations must adopt next-generation testing practices that enable them to test early, often, automatically and continuously,” said Ravichandran.</span></p>
<p>However, according to Marc Brown, product portfolio strategist for Parasoft, continuous testing should actually be a prerequisite for continuous delivery and continuous integration, and continuous delivery should be a prerequisite for people who want to get to DevOps. “You have to think of it as a set of building blocks where at the core you have organizations that want to have more flexibility and have adopted agile, they then have to adopt continuous testing to ensure what they are developing can be tested on an ongoing basis,” he said</p>
<p><span style="font-weight: 400;">But this fast-paced way of working creates many challenges for testers, according to Jason Hammon, director of product management at TechExcel. Hammon explained testers now have to struggle with the lack of time and need to respond as quickly as plans change. In an agile world, testers no longer have the luxury of a clear roadmap on what they are going to test, time to prepare the tests, and then time to execute on the testing. </span></p>
<p>But if teams are able to implement a good continuous testing strategy with the proper tools to support that strategy and scale, it will lessen the pain, according to Rod Cope, chief technology officer at Rogue Wave. With continuous testing, Cope says teams get the benefit of always having code in a good state. They no longer have to write code, test it, and then wait to find issues, stop the presses and go back and fix things. Instead, they are able to constantly take pieces of the solution and constantly test, instead of waiting for a big-bang delivery and testing phase.</p>
<p><span style="font-weight: 400;">“You can get much more done much more quickly with better quality, better security and less rework so you are getting more bang for your buck out of your development team,” said Cope. “You clearly can&#8217;t take a year anymore to get a product out the door; you have to be much more agile, and continuous testing is absolutely mandatory in today’s world. You really can&#8217;t afford to have problems in the field. You have to get it right the first time, and you have to do it very quickly.&#8221;</span></p>
<p><b>The resurgence of testing</b><br />
<span style="font-weight: 400;">For so long testing was an afterthought, but today the mantra ‘test early and test often’ is drilled into the heads of developers and testers. This is largely due to the increased speed of delivery and the push to adopt agile and DevOps, according to HPE’s Emo.</span></p>
<p><span style="font-weight: 400;">Even the smallest releases can have a large impact on the end user experience, and if an application delivery isn’t what it was expected to be, that response can spread around the market very fast, Emo explained. It is now more important than ever to put testing techniques in place throughout the entire life cycle so testing does not become a bottleneck, and teams can keep up with continuous quality.</span></p>
<p><span style="font-weight: 400;">The acceleration of development is a correlation of the consumer expectation. People expect the first version of something to work very well and be very obvious to use. They want their solutions to be simple to understand, but do way more things, according to Mobile Labs’ McFall. That demand for quality is driving the demand for testing. “You have to be developing all the time to keep up with the timeline demands, and the only way to meet the quality demands is to be testing it constantly,” he said.</span></p>
<p><span style="font-weight: 400;">McFall also explains the concept that software is eating the world is also having a huge impact on testing. Today, everything has to become software in some way, shape or form. The digital transformation is adding more complexity to the testing world because devices are starting to take many different forms, provide more capabilities, and interconnect between features and functions.</span></p>
<p><span style="font-weight: 400;">This software complexity is not only turning up the dial on speed, but also changing the ways to deliver. Because of this, more teams are starting to move to a software architecture that is extremely agile such as service-oriented architecture or microservice architecture, according to Emo. “This is great from an  architectural and developer agility perspective, but it gives you a lot more to manage, and a lot more dependencies,” she said. In addition, the software is being deployed across a multitude of operating systems, mobile environments, mobile devices, and Internet of Things devices, Emo added.</span></p>
<p><span style="font-weight: 400;">To deal with this, teams need to be continuously testing. McFall explains it doesn’t always have to be test everything all the time, but something should always be being tested, whether it is unit tests, interoperability, or white box/gray box testing. “Teams need to be able to anticipate problems, and that means feedback loops need to be automated and process loops need to be automated to be able to keep up,” he sad. </span></p>
<p><b>Automation: The key to continuous testing</b><br />
<span style="font-weight: 400;">One way continuous testing can help pick up the pace of testing is with automation. Agile and continuous testing have a tremendous amount of potential value to add to organizations, but if they aren’t fully automated it can be very taxing on the organization and create a lot of overhead, according to Parasoft’s Brown.  </span></p>
<p><span style="font-weight: 400;">Tricentis’ Platz explains automation allows teams to test at the speed of agile and DevOps; reduce the time and effort it takes to obtain realistic and accurate test results; minimize test maintenance; and reduce false positives. </span></p>
<p><span style="font-weight: 400;">In order to successfully deploy test automation, teams need to have a good understanding of what test automation is, how it can be leveraged, and where it is going to be most successful based on the type of product, according to TechExcel’s Hammon. </span></p>
<p><span style="font-weight: 400;">This requires connecting a number of tools together within the overall software development chain, Brown explained. “Automation tools need to be very easily integrated with the continuous testing tools to really power the continuous testing process,” he said. Brown adds organizations need to adopt tools that enable service virtualization to support automation. “It is the easiest way to create test environments on demand without the effort. The process and vision of continuous testing needs to be completely coupled with the technologies and automation to realize the value, otherwise it is going to create a lot of overhead for teams,” Brown added.</span></p>
<p><span style="font-weight: 400;">In addition, test teams should be comfortable with developer assets to write test cases in the form of automated scripts, according to Kelly Emo, director of life-cycle and quality product marketing at Hewlett Packard Enterprise (HPE). “They need to be comfortable with IDEs, programming languages and application models.  Whether Java, C#, Java script or other, they have to be comfortable working at the code level to create the most effective and reusable automation assets,” she said. </span></p>
<p><span style="font-weight: 400;">However, businesses should note that continuous testing is not just another buzzword for test automation. According to Dan McFall, president of Mobile Labs, automation is just a piece of the continuous testing puzzle, and it doesn’t mean that every test is going to be automated or even continuously tested. “You have to design the process and figure out where things are going to go, and then you figure out which technologies are going to come fit in and be in support of that,” he said. </span></p>
<p><span style="font-weight: 400;">In addition, automation doesn’t just apply to testing. Automation can be applied to data transfer, data flows, deployment, builds, and build management, according to McFall. </span></p>
<p><span style="font-weight: 400;">According to Rogue Wave’s Cope, in an ideal world everything would be fully automated, but realistically that is difficult unless you invest early on in the codebase, design and architecture. Cope adds at least on the UI side teams are always going to have to have some manual check and review in place if not heavy testing with every release. This is because things as simple as fonts and colors are hard to automatically test. </span></p>
<p><span style="font-weight: 400;">In addition, it requires a complex infrastructure to set up application servers, web servers, databases and configure all the different moving parts to be deployed in an isolated environment and run all the tests. However, more teams have been moving to containerization to make it easier to get environments up and running quickly, automate the process, and automate all the testing around it, Cope explained. </span></p>
<p><b>Other pieces of the puzzle</b><br />
<span style="font-weight: 400;">On top of automation, there are a multitude of other key strategies and tools necessary for a continuous testing workflow. “The continuous testing journey is a change. You can’t just jump into things, you need to take care of several other things first,” said Tricentis’ Platz. </span></p>
<p><span style="font-weight: 400;">For instance, Tricentis provides a continuous testing maturity model where customers can assess where they are today, and come up with a plan on how to get to the most mature stage. </span></p>
<p><span style="font-weight: 400;">“While we’ve all heard about organizations that were ‘built to last,’ the truth is, the only way an organization can survive and thrive today is to make sure they are ‘built to change,’” said CA’s Ravichandran.</span></p>
<p>Parasoft’s Brown says organizations need to invest in their developers, testers and release managers, and train them on what it means to be continuously testing. Then, you must train them on the environment and on the tools so they realize the value of what they invest in versus buying a product, not seeing its full potential, and becoming shelfware. “Training is probably the biggest element outside of the necessary tools and technologies needed to really power this, and make sure customers are successful at their continuous testing endeavors,” he said.</p>
<p>That requires a lot of communication, according to TechExcel’s Hammon. Teams need to understand why they are moving in a certain direction and choosing specific tools.</p>
<p><span style="font-weight: 400;">Communication is also a good skill QA engineers should have. That way, if an issue comes up, they can easily explain to the developer what happened and why it needs to be fixed. “They could also communicate with people that may be on the marketing or product management side to fully understand the initial goal of the feature to make sure they are really able to provide test cases that verify and validate the feature is actually implemented correctly,” Hammon said.</span></p>
<p>In addition, communication means taking into account customer feedback so teams can integrate that into the functionality of their system and make sure they are testing the right things. Having a good feedback loop in place gives teams the ability to see the overall health of the solution and provide early warning into issues, according to Mobile Labs’ McFall. “Without metrics or a good strategy, teams will be lost on whether or not they are actually delivering what the customer is expecting. If you don’t have a clear destination, just because you are going fast doesn’t mean you are going to the right place.”</p>
<p><span style="font-weight: 400;">HPE’s Emo explains there will always be some defects that leak out into production, but if you have that closed feedback loop and communication and an incident is found in production, it can get back to the agile team fast and they can quickly fix the problem. </span></p>
<p><span style="font-weight: 400;">CA’s Ravichandran adds to have a successful continuous testing strategy, teams need integrated solutions that enable “1) test environment simulation, 2) automatic test case creation, even from requirements, 3) on demand test data management, 4) always available SaaS-based performance testing, 5) open source integrations with tools like JMeter, Jenkins, Selenium, Appium, and 6) automated application performance monitoring and post-production performance testing to achieve continuous feedback.”</span></p>
<p><b>Who is responsible for testing? </b><br />
<span style="font-weight: 400;">Agile development requires cross-platform teams. This means that not only are teams made up of QA engineers, developers, and project managers, but the responsibilities are shared amongst the team members. Because of this, CA’s Ravichandran says testing and quality is everyone’s job.</span></p>
<p><span style="font-weight: 400;">“Continuous testing makes testing activities part of everyone’s role…from the business analysts, to the developers, to the performance engineer, to the operations manager… all are responsible to make sure the end users have a fantastic experience with their software,” Ravichandran said. </span></p>
<p><span style="font-weight: 400;">While this may be true, TechExcel’s Hammon believes QA and testing teams should still lead the charge. “It is great to have developers do unit tests on what they are checking in, but you still want to make sure the overall work of the individual developer when put together with the rest of the solution isn’t resulting in additional problems. You still need someone to make sure the overall product is what it was initially intended to be,” he said. </span></p>
<p>According to HPE’s Emo, testers have a mindset and specialty for solving functional, regression, performance and security issues that developers don’t have. But the testers should make sure they are still a part of the agile team, and participate side by side with development. This requires new skills such as the ability to understand the fundamentals of software development. “Understand agile processes and be able to understand good software design patterns and architecture. This way [the QA team] can focus on how to test in a way that will surface issues related to the fundamental way the application is constructed. Performance engineers should have strong skills in the performance characteristics of different application types, architectures and patterns. [And] security engineers should have strong skills on application layer security vulnerabilities,” she said.</p>
<p>Some businesses come up with a test Center of Excellence (CoE). Traditionally CoEs provide a large test team that delivers test as a service to the development team, but this provides distinct disadvantages, according to Tricentis’ Platz. Platz explains in a traditional CoE, communication isn’t as connected as it should be, causing testers to be informed late about changes.</p>
<p><span style="font-weight: 400;">CA’s Ravichandran recommends that CoEs become Centers of Enablement. This allows teams to collaborate in an environment where developers are integrated into testing from the beginning. “When testing is conducted earlier, the entire team is focused on quality, and a culture of “getting code done right the first time” saves time and reduces the number of iterations teams need to perform for a particular code,” Ravichandran said. </span></p>
<p>&nbsp;</p>

				<div class="mr_social_sharing_wrapper">
				<!-- Social Sharing Toolkit v2.2 --></div>
										
										<div class="row padless share-after-content">
	<div class="col-md-6 col-sm-12">
				<div class="">
			<div class="col-md-12 col-sm-6 padless" style="height:9px">
				<span style="display: inline-block; width: 90px; height: 21px; overflow: hidden;"><div class="fb-like" data-href="http://sdtimes.com/continuous-testing-fast-paced-agile-devops-world/" data-send="false" data-layout="button_count" data-width="90" data-show-faces="false"></div></span>			</div>
			<div class="col-md-12 col-sm-6 padless" style="white-space:nowrap">
				<span><a class="mr_social_share_facebook" href="//www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fsdtimes.com%2Fcontinuous-testing-fast-paced-agile-devops-world%2F&amp;t=Continuous+testing+in+a+fast-paced+agile+and+DevOps+world" class="mr_social_sharing_popup_link"><img src="/images/social-icons/facebook-button.png" class="nopin" alt="Share on Facebook" title="Share on Facebook"/></a></span> <span><a class="mr_social_share_twitter" href="https://twitter.com/share?url=http%3A%2F%2Fsdtimes.com%2Fcontinuous-testing-fast-paced-agile-devops-world%2F&amp;text=Continuous+testing+in+a+fast-paced+agile+and+DevOps+world" class="mr_social_sharing_popup_link"><img src="/images/social-icons/tweet-button.png" class="nopin" alt="Share on Twitter" title="Share on Twitter"/></a></span> <span><a class="mr_social_share_email" href="mailto:?subject=Continuous testing in a fast-paced agile and DevOps world&amp;body=http://sdtimes.com/continuous-testing-fast-paced-agile-devops-world/" target="_blank"><img src="/images/social-icons/email-button.png" class="nopin" alt="Share via email" title="Share via email"/></a></span>
			</div>
		</div>
			</div>
	<div class="col-md-6 col-sm-12 subscribe-form">
		<h4 class="col-md-12 col-sm-6 padless"><a href="http://resources.sdtimes.com/sdtimes-subscription?__hstc=54983092.b1c3fc9f788d79895403cd04467299f2.1402689135055.1402689135055.1404158676313.2&__hssc=54983092.2.1404218565731&__hsfp=2368551689">Subscribe to SDTimes</a></h4>
		<!--<div id="subscribe-hubspot-form-wrapper" class="col-sm-6">
			<form role="search" method="get" id="subscribe-hubspot-form" class="subscribeform" action="">
				<div>
					<div class="col-md-7 col-sm-7 padless"><input type="text" value="" name="email" id="email"></div>
					<div class="col-md-5 col-sm-3 padless search-point"><input type="submit" id="subscribesubmit" value="Subscribe"></div>
					<div class="clearfix"></div>
				</div>
			</form>
		</div>-->
	</div>
	<div class="clearfix"></div>
</div><div class="authorarea">
	<img src="http://sdtimes.com/wp-content/uploads/2014/07/MULLIGANChristina_blog-copy.jpg" />	<h3>About Christina Cardoza</h3>
	<div class="authorinfo">
		Christina Cardoza, formerly known as Christina Mulligan, is the Online &amp; Social Media Editor of SD Times. She covers agile, DevOps, AI, and drones. Follow her on twitter at <a href="https://twitter.com/chriscatdoza">@chriscatdoza</a>!	</div>
	<a class="author-link" href="http://sdtimes.com/author/christina-mulligan/" rel="author">View all posts by Christina Cardoza</a>
	<div class="clearfix"></div>
</div>									</div>									<script type="text/javascript">

jQuery('#slider-header img').attr('width', '100%').attr('height', 'auto');



jQuery('.postContent img').each(function () {
	var img = jQuery(this).attr('src');

	if(checkForImage(img) == true) {
		jQuery(this).removeAttr('width').removeAttr('height');
	}
});

function checkForImage(url) {
    return(url.match(/\.(jpeg|jpg|gif|png)$/) != null);
}
</script>										<div class="padless related-posts">
		<h2>Related Articles</h2>
	
		<div class="col-md-3">
							<img width="150" height="88" src="http://sdtimes.com/wp-content/uploads/2017/04/download.png" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" />						<h3 class="title">
				<a href="http://sdtimes.com/linux-foundation-announces-new-iot-edge-computing-project-edgex-foundry/" title="Permalink to The Linux Foundation announces a new IoT edge computing project: EdgeX Foundry" rel="bookmark">The Linux Foundation announces a new IoT edge computing project: EdgeX Foundry</a>
			</h3>
		</div>

		<div class="col-md-3">
							<img width="150" height="87" src="http://sdtimes.com/wp-content/uploads/2017/04/screen_shot_2017-04-24_at_11.44.34_am_720.png" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" />						<h3 class="title">
				<a href="http://sdtimes.com/apples-livephotoskit-js-lyrebirds-voice-imitation-algorithm-augmenta-studio-sd-times/" title="Permalink to Apple’s LivePhotosKit JS, Lyrebird’s voice imitation algorithm, and Augmenta Studio — SD Times news digest: April 24, 2017" rel="bookmark">Apple’s LivePhotosKit JS, Lyrebird’s voice imitation algorithm, and Augmenta Studio — SD Times news digest: April 24, 2017</a>
			</h3>
		</div>

		<div class="col-md-3">
							<img width="150" height="125" src="http://sdtimes.com/wp-content/uploads/2017/04/checklist-150938_960_720.png" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" />						<h3 class="title">
				<a href="http://sdtimes.com/guide-continuous-testing-tools/" title="Permalink to A guide to continuous testing tools" rel="bookmark">A guide to continuous testing tools</a>
			</h3>
		</div>

		<div class="col-md-3">
							<img width="150" height="100" src="http://sdtimes.com/wp-content/uploads/2017/04/pexels-photo-1.jpg" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" />						<h3 class="title">
				<a href="http://sdtimes.com/makes-continuous-testing-solution-stand/" title="Permalink to What makes your continuous testing solution stand out?" rel="bookmark">What makes your continuous testing solution stand out?</a>
			</h3>
		</div>
	</div>
								</div>
							</div>

							    <div class="clear"></div>
    <div class="dmbs-comments">
    <a name="comments"></a>
            <h4 id="comments">3 Comments</h4>
            <ul class="commentlist">
                                                            </ul>
            <div class="well">	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/continuous-testing-fast-paced-agile-devops-world/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://sdtimes.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='24622' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><input type="hidden" id="ct_checkjs_ffeabd223de0d4eacb9a3e6e53e5448d" name="ct_checkjs" value="0" /><script type="text/javascript">setTimeout(function(){    var ct_input_name = 'ct_checkjs_ffeabd223de0d4eacb9a3e6e53e5448d';    if (document.getElementById(ct_input_name) !== null) {        var ct_input_value = document.getElementById(ct_input_name).value;        document.getElementById(ct_input_name).value = document.getElementById(ct_input_name).value.replace(ct_input_value, '447687307');     }}, 1000);</script>			</form>
			</div><!-- #respond -->
	</div>
        </div>

						</div>

												
   </div>

          <div class="col-md-4 dmbs-right col-xs-12 hidden-xs col-sm-5 padless">
        			<div class="banner_ad medrec_1_ad">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/med_rec_1', [300, 250], 'div-gpt-ad-1466026216582-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/med_rec_1 -->
<div id='div-gpt-ad-1466026216582-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026216582-0'); }); 
</script>
</div>				</div>
			</div>
			<aside id="foo_widget-2" class="widget widget_foo_widget"></aside>			<div class="banner_ad medrec_2_ad">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/med_rec_2', [300, 250], 'div-gpt-ad-1466026338843-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/med_rec_2 -->
<div id='div-gpt-ad-1466026338843-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026338843-0'); });
</script>
</div>				</div>
			</div>
			<aside id="trending-stories-widget-2" class="widget trending-stories-widget"><h3></h3><div style="text-align:center; margin: 0 auto;">
<div style="width:300px; text-align:center; margin: 0 auto;">

	<div id="trending">

		<div class="trendinghead">
			<h2><strong>The 7</strong> Trending Stories</h2>
		</div>
				<div class="feeds">
			<ul>
												<div class="thm">
					<a href="http://sdtimes.com/continuous-testing-fast-paced-agile-devops-world/"><img width="300" height="169" src="http://sdtimes.com/wp-content/uploads/2017/04/BGtest.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" /></a>
				</div>
				<li class="trend-first">
					<span>1</span>
					<div style="min-height:25px;">
						<a href="http://sdtimes.com/continuous-testing-fast-paced-agile-devops-world/">
							Continuous testing in a fast-paced agile and DevOps world						</a>
					</div>
				</li>
												<li>
					<span>2</span>
						<img width="89" height="50" src="http://sdtimes.com/wp-content/uploads/2017/04/chainlink-690503_960_720.jpg" class="attachment-trending-small size-trending-small wp-post-image" alt="" />					<div style="min-height:25px;">
						<a href="http://sdtimes.com/overcoming-agile-barriers-testers/">
							Guest View: Overcoming agile barriers for testers						</a>
					</div>
				</li>
												<li>
					<span>3</span>
						<img width="98" height="50" src="http://sdtimes.com/wp-content/uploads/2017/04/Screen-Shot-2017-04-12-at-12.42.55-PM.png" class="attachment-trending-small size-trending-small wp-post-image" alt="" />					<div style="min-height:25px;">
						<a href="http://sdtimes.com/owasp-adds-unprotected-apis-insufficient-attack-protection-top-ten-2017-release/">
							OWASP adds unprotected APIs, insufficient attack protection to Top Ten 2017 release						</a>
					</div>
				</li>
												<li>
					<span>4</span>
						<img width="100" height="50" src="http://sdtimes.com/wp-content/uploads/2017/04/AWS-CodeStar-02-ConsoleProjectStart.png" class="attachment-trending-small size-trending-small wp-post-image" alt="" />					<div style="min-height:25px;">
						<a href="http://sdtimes.com/amazon-web-services-releases-codestar-x-ray/">
							Amazon Web Services releases CodeStar and X-Ray						</a>
					</div>
				</li>
												<li>
					<span>5</span>
						<img width="100" height="48" src="http://sdtimes.com/wp-content/uploads/2017/04/dockercon2017-e1485104983289.png" class="attachment-trending-small size-trending-small wp-post-image" alt="" />					<div style="min-height:25px;">
						<a href="http://sdtimes.com/dockercon-docker-announces-two-new-collaborative-open-source-container-projects/">
							DockerCon: Docker announces two new collaborative open-source container projects						</a>
					</div>
				</li>
												<li>
					<span>6</span>
						<img width="67" height="50" src="http://sdtimes.com/wp-content/uploads/2017/04/C8khvNoW0AEHp8c.jpg" class="attachment-trending-small size-trending-small wp-post-image" alt="" />					<div style="min-height:25px;">
						<a href="http://sdtimes.com/software-architects-can-control-future-software-architecture/">
							How software architects can control the future of software architecture						</a>
					</div>
				</li>
												<li>
					<span>7</span>
						<img width="90" height="50" src="http://sdtimes.com/wp-content/uploads/2017/04/Screen-Shot-2017-04-19-at-11.40.29-AM.png" class="attachment-trending-small size-trending-small wp-post-image" alt="" />					<div style="min-height:25px;">
						<a href="http://sdtimes.com/facebook-announces-react-fiber-react-vr-relay-modern-litho/">
							Facebook announces React Fiber, React VR, Relay Modern, and Litho						</a>
					</div>
				</li>
							</ul>
		</div>

	</div>

</div>
</div></aside>			<div class="banner_ad medrec_3_ad">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/Med_Rec_3', [300, 250], 'div-gpt-ad-1466026398056-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/Med_Rec_3 -->
<div id='div-gpt-ad-1466026398056-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026398056-0'); });
</script>
</div>				</div>
			</div>
						<div class="banner_ad medrec_4_ad">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/Med_Rec_4', [300, 250], 'div-gpt-ad-1466026534122-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/Med_Rec_4 -->
<div id='div-gpt-ad-1466026534122-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026534122-0'); });
</script>
</div>				</div>
			</div>
						<div class="banner_ad medrec_5_ad">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
  googletag.defineSlot('/67541884/med_rec_5', [300, 250], 'div-gpt-ad-1466026594130-0').addService(googletag.pubads());
  googletag.pubads().enableSingleRequest();
  googletag.enableServices();
 });
</script>

<!-- /67541884/med_rec_5 -->
<div id='div-gpt-ad-1466026594130-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026594130-0'); }); 
</script>
</div>				</div>
			</div>
						<div class="banner_ad medrec_6_ad">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/med_rec_6', [300, 250], 'div-gpt-ad-1466026679557-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/med_rec_6 -->
<div id='div-gpt-ad-1466026679557-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026679557-0'); });
</script>
</div>				</div>
			</div>
			    </div>

   <div class="col-md-12 col-sm-12 padless">
   		<div class="col-md-12 padless banner_ad bottom-leaderboard">
   						<div class="banner_ad bottom_leaderboard">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/leader_1_bottom', [728, 90], 'div-gpt-ad-1466028372866-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/leader_1_bottom -->
<div id='div-gpt-ad-1466028372866-0' style='height:90px; width:728px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466028372866-0'); });
</script>
</div>				</div>
			</div>
			   		</div>
   </div>

   <div class="col-md-12 col-sm-12 padless">
      <div class="col-md-12 padless banner_ad bottom-leaderboard">
        			<div class="banner_ad bottom_leaderboard_2">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/leader_2_bottom', [728, 90], 'div-gpt-ad-1466028474085-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/leader_2_bottom -->
<div id='div-gpt-ad-1466028474085-0' style='height:90px; width:728px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466028474085-0'); });
</script>
</div>				</div>
			</div>
			      </div>
   </div>

</div>
<!-- end content container -->

    <div class="dmbs-footer">
        
        	<div class="dmbs-footer-menu">
			<nav class="navbar navbar-inverse full-footer" role="navigation">
				<div class="container">
					<div class="navbar-header">
						<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-2-collapse">
							<span class="sr-only">Toggle navigation</span>
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
						</button>
					</div>
					<div class="row padless">
						<div class="col-md-4 col-sm-4">
							<aside id="nav_menu-3" class="widget widget_nav_menu"><h3>SD Times</h3><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-5041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5041"><a title="_blank" href="http://www.bzmedia.com/aboutus.html">About Us</a></li>
<li id="menu-item-5418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5418"><a title="_blank" href="http://www.bzmedia.com/contactus.html">Contact Us</a></li>
<li id="menu-item-5419" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5419"><a href="http://sdtimes.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-5045" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5045"><a href="http://sdtimes.com/site-map/">Site Map</a></li>
<li id="menu-item-5047" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5047"><a href="http://sdtimes.com/sd-times-magazine/advertise/">Advertise</a></li>
<li id="menu-item-5160" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5160"><a href="http://resources.sdtimes.com/sdtimes-subscription">Subscribe</a></li>
<li id="menu-item-12091" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12091"><a target="_blank" href="http://jobs.sdtimes.com/home/index.cfm?site_id=21912">Job Board</a></li>
</ul></div></aside>						</div>
						<div class="col-md-4">
							<aside id="text-2" class="widget widget_text"><h3>Follow @SDTimes</h3>			<div class="textwidget"><a class="twitter-timeline" href="https://twitter.com/sdtimes" data-widget-id="472430906574004224">Tweets by @sdtimes</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div>
		</aside>						</div>
						<div class="col-md-4">
							<aside id="sdtimes-subscribe-widget-2" class="widget sdtimes-subscribe-widget"><h3></h3><div style="text-align:center; margin: 0 auto;">
	<div style="text-align:center; margin: 0 auto;">

		<div id="subscribe">

			
			<div class="title">Subscribe to SD Times</div>
			<div class="sdtimessubscribe">
				<div class="left">
					<a href="http://resources.sdtimes.com/download-latest-issue" target="_blank"><img width="180" height="244" src="http://sdtimes.com/wp-content/uploads/2017/04/cov336.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" /></a>				</div>
				<div class="left links">
					<a href="http://resources.sdtimes.com/download-latest-issue" target="_blank">Download Current Issue <span>&#x25b6;</span></a>					<br />
					<a href="http://sdtimes.com/back-issues/" target="_blank">Download Back Issues <span>&#x25b6;</span></a>				</div>
				<div class="clear"></div>
				<div class="smallertext">
					<span>Subscribe to SD Times print magazine</span>
					<br />
					<p>Ready for your SD Times magazine? It's just a few clicks away!</p>				</div>

				<p><a class="button" href="http://resources.sdtimes.com/sdtimes-subscription">Subscribe</a></p>
			</div>

		</div>

	</div>
</div></aside>						</div>
					</div>
				</div>
			</nav>
			<div class="footer-credit">
				<div class="col-md-2 copyright">&copy; 2017 BZ Media LLC.</div>
				<div class="col-md-8 min-footer-menu">
					<aside id="nav_menu-2" class="widget widget_nav_menu"><div class="menu-footer-mini-menu-container"><ul id="menu-footer-mini-menu" class="menu"><li id="menu-item-6911" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6911"><a href="http://resources.sdtimes.com/sdtimes-subscription">Subscribe</a></li>
<li id="menu-item-5064" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5064"><a target="_blank" href="http://www.bzmedia.com/contactus.html#new_tab">Contact Us</a></li>
<li id="menu-item-5065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5065"><a href="http://sdtimes.com/site-map/">Site Map</a></li>
<li id="menu-item-5066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5066"><a href="http://sdtimes.com/privacy-policy/">Privacy Policy</a></li>
</ul></div></aside>				</div>
				<div class="col-md-2"><div class="social">
	<ul>
		<li><a class="fa fa-facebook" href="https://www.facebook.com/SDTimesBZ"></a></li>
		<li><a class="fa fa-twitter" href="http://www.twitter.com/sdtimes"></a></li>
	</ul>
</div></div>
				<div class="clearfix"></div>
			</div>
	</div>
    </div>

</div>
<!-- end main container -->

<script async type='text/javascript' src='http://sdtimes.com/wp-content/plugins/cleantalk-spam-protect/inc/cleantalk_nocache.js?random=5.61'></script>
<script type="text/javascript">function ctSetCookie(c_name, value, def_value) {    document.cookie = c_name + "=" + escape(value) + "; path=/";}ctSetCookie("ct_checkjs", "447687307", "0");</script><script type="text/javascript">
	jQuery('a[title="_blank"]').each(
			function(i) {
				jQuery(this).attr('target', '_blank');
				jQuery(this).attr('title', jQuery(this).text());
			}
		);
</script> <div style="width:100%;text-align:center; font-size:11px; clear:both"><a target="_blank" title="Insert HTML Snippet Wordpress Plugin" href="http://xyzscripts.com/wordpress-plugins/insert-html-snippet/">HTML Snippets</a> Powered By : <a target="_blank" title="PHP Scripts & Wordpress Plugins" href="http://www.xyzscripts.com" >XYZScripts.com</a></div>	<script type="text/javascript">var switchTo5x=true;</script>
	<script type="text/javascript" src="http://w.sharethis.com/button/buttons.js"></script>
	<script type="text/javascript">stLight.options({publisher: "ur-84fe4080-bc54-11f3-8dd8-4c4036217b0c", doNotHash: false, doNotCopy: false, hashAddressBar: false});</script><script type='text/javascript' src='http://sdtimes.com/wp-content/themes/sdtimes2014/js/fusionfarm-bootstrap-responsive.js?ver=1.0'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-content/themes/devdmbootstrap3/js/bootstrap.js?ver=1.40'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=2.9.8'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-content/plugins/social-sharing-toolkit/script_2.1.2.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-includes/js/comment-reply.min.js?ver=4.7.3'></script>
<!-- Clicky Web Analytics - https://clicky.com, WordPress Plugin by Yoast - https://yoast.com/wordpress/plugins/clicky/ --><script type='text/javascript'>
	function clicky_gc(name) {
		var ca = document.cookie.split(';');
		for (var i in ca) {
			if (ca[i].indexOf(name + '=') != -1) {
				return decodeURIComponent(ca[i].split('=')[1]);
			}
		}
		return '';
	}
	var username_check = clicky_gc('comment_author_6c445563c161f4fa086dd6ff78194eb2');
	if (username_check) var clicky_custom_session = {username: username_check};
</script>
<script type="text/javascript">
		var clicky = { log : function () { return true;	}, goal: function () { return true;	} };
	var clicky_site_id = 100754890;
	(function () {
		var s = document.createElement('script');s.type = 'text/javascript';s.async = true;s.src = '//static.getclicky.com/js';
		( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild(s);
	})();
</script>
<noscript><p><img alt="Clicky" width="1" height="1" src="//in.getclicky.com/100754890ns.gif" /></p></noscript>

				<div class="mr_social_sharing_wrapper">
				<!-- Social Sharing Toolkit v2.2 --><div class="mr_social_sharing_top"><a class="mr_social_share_facebook" href="//www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fsdtimes.com%2Fcontinuous-testing-fast-paced-agile-devops-world%2F&amp;t=Continuous+testing+in+a+fast-paced+agile+and+DevOps+world" class="mr_social_sharing_popup_link"><img src="/images/social-icons/facebook.png" class="nopin" alt="Share on Facebook" title="Share on Facebook"/></a></div><div class="mr_social_sharing_top"><a class="mr_social_share_twitter" href="https://twitter.com/share?url=http%3A%2F%2Fsdtimes.com%2Fcontinuous-testing-fast-paced-agile-devops-world%2F&amp;text=Continuous+testing+in+a+fast-paced+agile+and+DevOps+world" class="mr_social_sharing_popup_link"><img src="/images/social-icons/twitter.png" class="nopin" alt="Share on Twitter" title="Share on Twitter"/></a></div><div class="mr_social_sharing_top"><a class="mr_social_share_googleplus" href="//plusone.google.com/_/+1/confirm?hl=en&amp;url=http%3A%2F%2Fsdtimes.com%2Fcontinuous-testing-fast-paced-agile-devops-world%2F&amp;title=Continuous+testing+in+a+fast-paced+agile+and+DevOps+world" class="mr_social_sharing_popup_link"><img src="/images/social-icons/googleplus.png" class="nopin" alt="+1" title="+1"/></a></div><div class="mr_social_sharing_top"><a class="mr_social_share_linkedin" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fsdtimes.com%2Fcontinuous-testing-fast-paced-agile-devops-world%2F&amp;title=Continuous+testing+in+a+fast-paced+agile+and+DevOps+world" class="mr_social_sharing_popup_link"><img src="/images/social-icons/linkedin.png" class="nopin" alt="Share on LinkedIn" title="Share on LinkedIn"/></a></div><div class="mr_social_sharing_top"><a class="mr_social_share_email" href="mailto:?subject=Continuous testing in a fast-paced agile and DevOps world&amp;body=http://sdtimes.com/continuous-testing-fast-paced-agile-devops-world/" target="_blank"><img src="/images/social-icons/email.png" class="nopin" alt="Share via email" title="Share via email"/></a></div><span class="mr_social_sharing"><a rel="nofollow" class="linksalpha_button linksalpha_link" href="//www.linksalpha.com/social/mobile" data-url="http://sdtimes.com/continuous-testing-fast-paced-agile-devops-world/" data-text="Continuous testing in a fast-paced agile and DevOps world" data-desc="In a world where businesses not only have to become software companies to compete, but deliver higher quality software to market faster, what does this mean for testing? Businesses and software teams have become so concerned with developing and delivering in an agile fashion, they have had to stop" data-image="http://sdtimes.com/wp-content/uploads/2017/04/BGtest.jpg" data-button="icon_medium">
					<img src="//www.linksalpha.com/images/social_share_icon_medium.png" alt="Share" class="linksalpha_image" />
					</a><script type="text/javascript" src="//www.linksalpha.com/scripts/loader_iconbox.js?v=2.3"></script></span></div>		<script type="text/javascript">
			jQuery(window).ready(function() {
				jQuery('span.mr_social_sharing > a > img').attr('src', '/images/social-icons/share.png');
				social_sidebar = jQuery('.hentry .social');
				social_elem = jQuery('.mr_social_sharing');
				social_share_wrapper = jQuery('.mr_social_sharing_wrapper');
				social_sidebar.append(social_share_wrapper);
				social_sidebar.prepend(social_elem);
			});
		</script>
	<!-- START Fusionfarm/Hubspot API -- subscription popup -->
<!-- PLACE THIS IN THE <head> OF EVERY PAGE THAT YOU WANT THE POPUP -->
<link rel="stylesheet" href="/hubspot-api/Fusionfarm/colorbox/example1/colorbox.css">
<script type="text/javascript" src="/hubspot-api/Fusionfarm/sdtimes-offer-popup.js.php"></script>
<script type="text/javascript">

(function($) {
    $(document).ready(function(){

        var base_url = 'http://sdtimes.com';  // without trailing /

        //Fusionfarm.test.init('xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'); // Test by adding cookie value of hubspotutk
        /* SET THE FULL URL TO THE MAIN SERVERSIDE SCRIPT /hubspot-api/Fusionfarm/get-subscription.php */
        Fusionfarm.base_url = base_url;
        Fusionfarm.Hubspot.API.get_subscript_url = base_url + '/hubspot-api/Fusionfarm/get-subscription.php';
        Fusionfarm.Hubspot.API.get_offerdeclined_url = base_url + '/hubspot-api/Fusionfarm/declined-offer.php';
        Fusionfarm.setup_events();
    });
})(jQuery);



function downloadJSAtOnload() {
var element = document.createElement("script");
element.src = "/hubspot-api/Fusionfarm/colorbox/jquery.colorbox.js";
document.body.appendChild(element);
}
if (window.addEventListener)
window.addEventListener("load", downloadJSAtOnload, false);
else if (window.attachEvent)
window.attachEvent("onload", downloadJSAtOnload);
else window.onload = downloadJSAtOnload;


</script>
<!-- END Fusionfarm/Hubspot API -- subscription popup --><script async type='text/javascript' src='http://sdtimes.com/wp-content/plugins/cleantalk-spam-protect/inc/cleantalk_nocache.js?random=5.61'></script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"237c3e91d7","applicationID":"12810909","transactionName":"YlJQMhQDWkEDBxcPXFsYcwUSC1tcTRcKCFRZUg==","queueTime":0,"applicationTime":788,"atts":"ThVTRFwZSU8=","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>