<!DOCTYPE html>
<html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" >
<head>
    <meta http-equiv="content-type" content="text/html; charset=UTF-8" />
    <meta name="description" content="Software Development News" />
    <title>SD Times Open-Source Project of the Week: spark-inequality-impact - SD Times</title>
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <link rel="pingback" href="https://sdtimes.com/xmlrpc.php" />
    
<!-- This site is optimized with the Yoast SEO plugin v13.4.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="LinkedIn open sourced spark-inequality-impact, an Apache Spark library that can be used by other organizations in any domain where measuring and reducing inequality, or avoiding unintended inequality consequences may be desirable."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://sdtimes.com/open-source/sd-times-open-source-project-of-the-week-spark-inequality-impact/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="SD Times Open-Source Project of the Week: spark-inequality-impact - SD Times" />
<meta property="og:description" content="LinkedIn open sourced spark-inequality-impact, an Apache Spark library that can be used by other organizations in any domain where measuring and reducing inequality, or avoiding unintended inequality consequences may be desirable." />
<meta property="og:url" content="https://sdtimes.com/open-source/sd-times-open-source-project-of-the-week-spark-inequality-impact/" />
<meta property="og:site_name" content="SD Times" />
<meta property="article:publisher" content="https://www.facebook.com/SDTimesD2" />
<meta property="article:tag" content="A/B testing" />
<meta property="article:tag" content="Apache Spark" />
<meta property="article:tag" content="open source" />
<meta property="article:section" content="Latest News" />
<meta property="article:published_time" content="2020-05-29T13:21:16+00:00" />
<meta property="article:modified_time" content="2020-05-29T12:27:26+00:00" />
<meta property="og:updated_time" content="2020-05-29T12:27:26+00:00" />
<meta property="og:image" content="https://sdtimes.com/wp-content/uploads/2020/05/project-every-member.png" />
<meta property="og:image:secure_url" content="https://sdtimes.com/wp-content/uploads/2020/05/project-every-member.png" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="675" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="LinkedIn open sourced spark-inequality-impact, an Apache Spark library that can be used by other organizations in any domain where measuring and reducing inequality, or avoiding unintended inequality consequences may be desirable." />
<meta name="twitter:title" content="SD Times Open-Source Project of the Week: spark-inequality-impact - SD Times" />
<meta name="twitter:site" content="@sdtimes" />
<meta name="twitter:image" content="https://sdtimes.com/wp-content/uploads/2020/05/project-every-member.png" />
<meta name="twitter:creator" content="@sdtimes" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://sdtimes.com/#organization","name":"SD Times","url":"https://sdtimes.com/","sameAs":["https://www.facebook.com/SDTimesD2","https://twitter.com/sdtimes"],"logo":{"@type":"ImageObject","@id":"https://sdtimes.com/#logo","inLanguage":"en-US","url":"https://sdtimes.com/wp-content/uploads/2014/05/deafaultlogo.png","width":225,"height":90,"caption":"SD Times"},"image":{"@id":"https://sdtimes.com/#logo"}},{"@type":"WebSite","@id":"https://sdtimes.com/#website","url":"https://sdtimes.com/","name":"SD Times","inLanguage":"en-US","description":"Software Development News","publisher":{"@id":"https://sdtimes.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://sdtimes.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://sdtimes.com/open-source/sd-times-open-source-project-of-the-week-spark-inequality-impact/#primaryimage","inLanguage":"en-US","url":"https://sdtimes.com/wp-content/uploads/2020/05/project-every-member.png","width":900,"height":675},{"@type":"WebPage","@id":"https://sdtimes.com/open-source/sd-times-open-source-project-of-the-week-spark-inequality-impact/#webpage","url":"https://sdtimes.com/open-source/sd-times-open-source-project-of-the-week-spark-inequality-impact/","name":"SD Times Open-Source Project of the Week: spark-inequality-impact - SD Times","isPartOf":{"@id":"https://sdtimes.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://sdtimes.com/open-source/sd-times-open-source-project-of-the-week-spark-inequality-impact/#primaryimage"},"datePublished":"2020-05-29T13:21:16+00:00","dateModified":"2020-05-29T12:27:26+00:00","description":"LinkedIn open sourced spark-inequality-impact, an Apache Spark library that can be used by other organizations in any domain where measuring and reducing inequality, or avoiding unintended inequality consequences may be desirable.","potentialAction":[{"@type":"ReadAction","target":["https://sdtimes.com/open-source/sd-times-open-source-project-of-the-week-spark-inequality-impact/"]}]},{"@type":"Article","@id":"https://sdtimes.com/open-source/sd-times-open-source-project-of-the-week-spark-inequality-impact/#article","isPartOf":{"@id":"https://sdtimes.com/open-source/sd-times-open-source-project-of-the-week-spark-inequality-impact/#webpage"},"author":{"@id":"https://sdtimes.com/#/schema/person/0ccf41924f263cbae6638a4df0210f42"},"headline":"SD Times Open-Source Project of the Week: spark-inequality-impact","datePublished":"2020-05-29T13:21:16+00:00","dateModified":"2020-05-29T12:27:26+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://sdtimes.com/open-source/sd-times-open-source-project-of-the-week-spark-inequality-impact/#webpage"},"publisher":{"@id":"https://sdtimes.com/#organization"},"image":{"@id":"https://sdtimes.com/open-source/sd-times-open-source-project-of-the-week-spark-inequality-impact/#primaryimage"},"keywords":"A/B testing,Apache Spark,open source","articleSection":"Latest News,SD Times Editors Blog","inLanguage":"en-US"},{"@type":["Person"],"@id":"https://sdtimes.com/#/schema/person/0ccf41924f263cbae6638a4df0210f42","name":"Jakub Lewkowicz","image":{"@type":"ImageObject","@id":"https://sdtimes.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/fec6c7c06cf379ac99029d9c59940dab?s=96&d=mm&r=g","caption":"Jakub Lewkowicz"},"description":"Jakub Lewkowicz is a multimedia journalist who loves all things tech. Polish-born and Long Island-bred, he is an Online and Social Media Editor for SD Times. He is also a Carnegie Hall pianist and music producer.","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SD Times &raquo; Feed" href="https://sdtimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="SD Times &raquo; Comments Feed" href="https://sdtimes.com/comments/feed/" />
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-M8DVS3N');</script>
<!-- End Google Tag Manager -->		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/sdtimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://sdtimes.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='sdtimes-lesscss-css'  href='https://sdtimes.com/wp-content/themes/sdtimes2014/css/sdtimes.css?20200529&#038;ver=5.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Source+Sans+Pro%3A300%2C400%2C600%2C700%2C600italic%7CLato%3A400%2C700%7CBitter%3A400%2C700&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-fonts-css'  href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css?ver=5.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='lity-css-css'  href='//cdnjs.cloudflare.com/ajax/libs/lity/2.3.1/lity.min.css?ver=2.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://sdtimes.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=5.2.6' type='text/css' media='all' />
<script type='text/javascript' src='https://sdtimes.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/themes/sdtimes2014/js/sd-jq-onload.js?20180625b&#038;ver=5.2.6'></script>
<script type='text/javascript' src='https://s7.addthis.com/js/300/addthis_widget.js?ver=5.2.6#pubid=wp-4417f7f776d9c2ffd08ba9868d73e669'></script>
<link rel='https://api.w.org/' href='https://sdtimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://sdtimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://sdtimes.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.6" />
<link rel='shortlink' href='https://sdtimes.com/?p=40121' />
<link rel="alternate" type="application/json+oembed" href="https://sdtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsdtimes.com%2Fopen-source%2Fsd-times-open-source-project-of-the-week-spark-inequality-impact%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://sdtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsdtimes.com%2Fopen-source%2Fsd-times-open-source-project-of-the-week-spark-inequality-impact%2F&#038;format=xml" />
<script async src="https://js.convertflow.co/production/websites/7166.js"></script><!-- Start of HubSpot Embed Code -->
<script type="text/javascript" id="hs-script-loader" async defer src="//js.hs-scripts.com/3475429.js"></script>
<!-- End of HubSpot Embed Code --><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-846073-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-846073-1');
</script><meta http-equiv="refresh" content="500" /><script type="text/javascript" src="//www.queryly.com/js/queryly.js"></script>
<script type="text/javascript">
	queryly.QuerylyKey = "af2d91c2c83847f8";
	//queryly.layout.topMargin = -8;
	//queryly.layout.rightMargin = -74;
	queryly.layout.opacity = 1;

	queryly.QuerylyCallback = function (a, b) {
		queryly.jquery("#s").css('opacity', 1);
		queryly.jquery('#queryly_suggest').css('opacity', 1);
	}
</script>
	<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"ui_atversion":300}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = [{"responsiveshare":{"numPreferredServices":3,"counts":"none","size":"20px","style":"responsive","shareCountThreshold":0,"services":"twitter,email,addthis","elements":".addthis_inline_share_toolbox_xdry","id":"responsiveshare"}}]; } else { window.addthis_layers_tools.push({"responsiveshare":{"numPreferredServices":3,"counts":"none","size":"20px","style":"responsive","shareCountThreshold":0,"services":"twitter,email,addthis","elements":".addthis_inline_share_toolbox_xdry","id":"responsiveshare"}});  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"WordPress","anonymous_profile_id":"wp-4417f7f776d9c2ffd08ba9868d73e669","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script><!-- Clicky Web Analytics - https://clicky.com, WordPress Plugin by Yoast - https://yoast.com/wordpress/plugins/clicky/ --><script type='text/javascript'>
	function clicky_gc(name) {
		var ca = document.cookie.split(';');
		for (var i in ca) {
			if (ca[i].indexOf(name + '=') != -1) {
				return decodeURIComponent(ca[i].split('=')[1]);
			}
		}
		return '';
	}
	var username_check = clicky_gc('"comment_author_1ea0be0111e3c4a55d44c1d0fc560697"');
	if (username_check) var clicky_custom_session = {username: username_check};
</script>
<script>
	
	var clicky_site_ids = clicky_site_ids || [];
	clicky_site_ids.push("100754890");
</script>
<script async src="//static.getclicky.com/js"></script><link rel="icon" href="https://sdtimes.com/wp-content/uploads/2019/06/bnGl7Am3_400x400-50x50.jpeg" sizes="32x32" />
<link rel="icon" href="https://sdtimes.com/wp-content/uploads/2019/06/bnGl7Am3_400x400-300x300.jpeg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://sdtimes.com/wp-content/uploads/2019/06/bnGl7Am3_400x400-180x180.jpeg" />
<meta name="msapplication-TileImage" content="https://sdtimes.com/wp-content/uploads/2019/06/bnGl7Am3_400x400-300x300.jpeg" />
</head>
<body class="post-template-default single single-post postid-40121 single-format-standard">

<div class="visible-sm visible-md" id="sm-top-banner-wrapper"></div>
<div class="container dmbs-mobile-menu">
<div class="row hidden-md hidden-lg">
    <nav class="navbar" role="navigation">
        <div class="-container-">
            <div class="navbar-header navbar-inverse">
                <div class="navbar-logo">
                    <a href="https://sdtimes.com/"><img src="/images/sdtimes-logo-mobile.png"></a>
                </div>
                <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-1-collapse">
                    <span class="sr-only">Toggle navigation</span>
                    <span class="icon-bar"></span>
                    <span class="icon-bar"></span>
                    <span class="icon-bar"></span>
                </button>
            </div>
            <div class="collapse navbar-collapse navbar-1-collapse"><ul id="menu-main-desktop" class="nav navbar-nav"><li id="menu-item-29495" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29495"><a title="ITOps Times" href="https://www.itopstimes.com/">ITOps Times</a></li>
<li id="menu-item-5222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5222 dropdown"><a title="Features" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Features <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5789" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5789"><a title="In-Depth" href="https://sdtimes.com/category/in-depth/">In-Depth</a></li>
	<li id="menu-item-5371" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5371"><a title="Buyer&#039;s Guide" href="https://sdtimes.com/category/buyers-guide/">Buyer&#8217;s Guide</a></li>
	<li id="menu-item-5372" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5372"><a title="Special Report" href="https://sdtimes.com/category/special-report/">Special Report</a></li>
	<li id="menu-item-35738" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35738"><a title="SD Times 100" href="https://sdtimes.com/sd-times-100/sd-times-100-2019-birds-of-a-feather/">SD Times 100</a></li>
	<li id="menu-item-35005" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35005"><a title="Deeper Look" href="https://sdtimes.com/category/deeper-look/">Deeper Look</a></li>
	<li id="menu-item-9652" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9652"><a title="Industry Spotlight" href="https://sdtimes.com/category/industry-spotlight/">Industry Spotlight</a></li>
</ul>
</li>
<li id="menu-item-5039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5039 dropdown"><a title="Subscribe" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Subscribe <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5161" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5161"><a title="Subscribe to SD Times" href="https://sdtimes.com/subscribe-to-sd-times-magazine/">Subscribe to SD Times</a></li>
	<li id="menu-item-5392" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5392"><a title="Read The Latest Issue" href="https://sdtimes.com/sd-times-may-2020/">Read The Latest Issue</a></li>
	<li id="menu-item-7272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7272"><a title="Back Issues" href="https://sdtimes.com/back-issues/">Back Issues</a></li>
	<li id="menu-item-5397" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5397"><a title="Working with the Editors" href="https://sdtimes.com/sd-times-magazine/working-with-the-editors/">Working with the Editors</a></li>
	<li id="menu-item-5430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5430"><a title="SD Times 100 Guide" href="https://sdtimes.com/sd-times-100/">SD Times 100 Guide</a></li>
	<li id="menu-item-5415" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5415"><a title="Advertise" target="_blank" href="https://d2emerge.convertflowpages.com/advertisesdtimes#new_tab">Advertise</a></li>
	<li id="menu-item-5414" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5414"><a title="Guest View Guidelines" href="https://sdtimes.com/sd-times-magazine/guest-view-guidelines/">Guest View Guidelines</a></li>
	<li id="menu-item-31167" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31167"><a title="Cancel My Subscription" href="https://sdtimes.com/subscriptionupdate/">Cancel My Subscription</a></li>
</ul>
</li>
<li id="menu-item-5389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5389 dropdown"><a title="Learning Center" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Learning Center <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5701" class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5701"><a title="White Papers" href="https://sdtimes.com/sections/white-papers/">White Papers</a></li>
	<li id="menu-item-5704" class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5704"><a title="Webinars" href="https://sdtimes.com/sections/webinars/">Webinars</a></li>
	<li id="menu-item-35006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35006"><a title="Continuous Testing" href="https://sdtimes.com/category/deeper-look/">Continuous Testing</a></li>
</ul>
</li>
<li id="menu-item-37635" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37635"><a title="Podcasts" href="http://whatthedev.buzzsprout.com/673192">Podcasts</a></li>
<li id="menu-item-40030" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-40030 dropdown"><a title="Events" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Events <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-40029" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40029"><a title="Value Stream DevCon" href="https://events.sdtimes.com/valuestreamdevcon">Value Stream DevCon</a></li>
</ul>
</li>
</ul></div><div class="mobile-topic-nav"><ul id="menu-topic-navigation" class=""><li id="menu-item-28529" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28529"><a title="API" href="/tag/apis/">API</a></li>
<li id="menu-item-28531" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28531"><a title="Agile" href="/tag/agile/">Agile</a></li>
<li id="menu-item-28532" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28532"><a title="Containers" href="/tag/containers/">Containers</a></li>
<li id="menu-item-28534" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28534"><a title="Data" href="/tag/data/">Data</a></li>
<li id="menu-item-28535" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28535"><a title="DevOps" href="/tag/devops/">DevOps</a></li>
<li id="menu-item-28536" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28536"><a title="DevSecOps" href="/tag/devsecops/">DevSecOps</a></li>
<li id="menu-item-28538" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28538"><a title="Low Code" href="/tag/low-code/">Low Code</a></li>
<li id="menu-item-33219" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33219"><a title="Microservices" href="/tag/microservices">Microservices</a></li>
<li id="menu-item-28530" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28530"><a title="Monitor" href="/tag/apm/">Monitor</a></li>
<li id="menu-item-28541" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28541"><a title="Security" href="/tag/security/">Security</a></li>
<li id="menu-item-33221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33221"><a title="Serverless" href="/tag/serverless">Serverless</a></li>
<li id="menu-item-28542" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28542"><a title="Test" href="/tag/test/">Test</a></li>
<li id="menu-item-33220" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33220"><a title="Value Stream" href="/tag/value-stream-management">Value Stream</a></li>
</ul></div>        </div>
    </nav>
</div>
</div><div class="container dmbs-container">
    <div class="row sd-top-ad">
        <div class="col-xs-12">
            			<div class="banner_ad top_mobile_leaderboard">
							</div>
			            			<div class="banner_ad top_leaderboard">
				<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
 googletag.cmd.push(function() {
  googletag.defineSlot('/67541884/Leaderboard_Top_1', [[970,250],[970,90],[728, 90]], 'div-gpt-ad-1466026021929-0').addService(googletag.pubads());
  googletag.pubads().enableSingleRequest();
  googletag.enableServices();
 });
</script>

<!-- /67541884/Leaderboard_Top_1 -->
<div id='div-gpt-ad-1466026021929-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026021929-0'); });
</script>
</div>			</div>
			        </div>
    </div>

    <div class="row sd-header">
        <div class="col-md-12">
            <div class="row dmbs-header hidden-xs hidden-sm">

                <div class="dmbs-header-img">
                    <a href="https://sdtimes.com/"><img src="https://sdtimes.com/wp-content/uploads/2014/05/LOGO_SDTimes.png" height="59" width="180" alt="" /></a>
                </div>

                <div class="dmbs-header-text">
                    <div class="row">
                        <div id="nav-grouping-1" class="col-md-8">
                            

    <div class="row dmbs-top-menu">
        <nav class="navbar" role="navigation">
            <div class="-container-">
                <div class="collapse navbar-collapse navbar-1-collapse"><ul id="menu-main-desktop-1" class="nav navbar-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29495"><a title="ITOps Times" href="https://www.itopstimes.com/">ITOps Times</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5222 dropdown"><a title="Features" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Features <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5789"><a title="In-Depth" href="https://sdtimes.com/category/in-depth/">In-Depth</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5371"><a title="Buyer&#039;s Guide" href="https://sdtimes.com/category/buyers-guide/">Buyer&#8217;s Guide</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5372"><a title="Special Report" href="https://sdtimes.com/category/special-report/">Special Report</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35738"><a title="SD Times 100" href="https://sdtimes.com/sd-times-100/sd-times-100-2019-birds-of-a-feather/">SD Times 100</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35005"><a title="Deeper Look" href="https://sdtimes.com/category/deeper-look/">Deeper Look</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9652"><a title="Industry Spotlight" href="https://sdtimes.com/category/industry-spotlight/">Industry Spotlight</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5039 dropdown"><a title="Subscribe" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Subscribe <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5161"><a title="Subscribe to SD Times" href="https://sdtimes.com/subscribe-to-sd-times-magazine/">Subscribe to SD Times</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5392"><a title="Read The Latest Issue" href="https://sdtimes.com/sd-times-may-2020/">Read The Latest Issue</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7272"><a title="Back Issues" href="https://sdtimes.com/back-issues/">Back Issues</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5397"><a title="Working with the Editors" href="https://sdtimes.com/sd-times-magazine/working-with-the-editors/">Working with the Editors</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5430"><a title="SD Times 100 Guide" href="https://sdtimes.com/sd-times-100/">SD Times 100 Guide</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5415"><a title="Advertise" target="_blank" href="https://d2emerge.convertflowpages.com/advertisesdtimes#new_tab">Advertise</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5414"><a title="Guest View Guidelines" href="https://sdtimes.com/sd-times-magazine/guest-view-guidelines/">Guest View Guidelines</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31167"><a title="Cancel My Subscription" href="https://sdtimes.com/subscriptionupdate/">Cancel My Subscription</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5389 dropdown"><a title="Learning Center" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Learning Center <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5701"><a title="White Papers" href="https://sdtimes.com/sections/white-papers/">White Papers</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5704"><a title="Webinars" href="https://sdtimes.com/sections/webinars/">Webinars</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35006"><a title="Continuous Testing" href="https://sdtimes.com/category/deeper-look/">Continuous Testing</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37635"><a title="Podcasts" href="http://whatthedev.buzzsprout.com/673192">Podcasts</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-40030 dropdown"><a title="Events" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Events <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40029"><a title="Value Stream DevCon" href="https://events.sdtimes.com/valuestreamdevcon">Value Stream DevCon</a></li>
</ul>
</li>
</ul></div>            </div>
        </nav>
    </div>

                        </div>
                        <div id="nav-grouping-2" class="col-md-4 hidden-xs">
                            <div class="social">
	<ul>
		<li><a class="fa fa-facebook" href="https://www.facebook.com/SDTimesD2"></a></li>
		<li><a class="fa fa-twitter" href="http://www.twitter.com/sdtimes"></a></li>
	</ul>
</div>                            <div id="top-search-form">
	<form role="search" method="get" id="searchform" class="searchform" action="https://sdtimes.com/">
		<input type="text" class="queryly" value="" name="s" id="s"><script type="text/javascript">queryly.QuerylyBind();</script>
		<button type="submit" id="searchsubmit">
            <i class="fa fa-search" aria-hidden="true"></i>
            Search
        </button>
	</form>
</div>                        </div>
                    </div>
                </div>

            </div>

            <div class="row topic-nav hidden-xs hidden-sm">
                <div class="col-xs-12">
                    <div class="collapse navbar-collapse navbar-1-collapse"><ul id="menu-topic-navigation-1" class="nav navbar-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28529"><a title="API" href="/tag/apis/">API</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28531"><a title="Agile" href="/tag/agile/">Agile</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28532"><a title="Containers" href="/tag/containers/">Containers</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28534"><a title="Data" href="/tag/data/">Data</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28535"><a title="DevOps" href="/tag/devops/">DevOps</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28536"><a title="DevSecOps" href="/tag/devsecops/">DevSecOps</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28538"><a title="Low Code" href="/tag/low-code/">Low Code</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33219"><a title="Microservices" href="/tag/microservices">Microservices</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28530"><a title="Monitor" href="/tag/apm/">Monitor</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28541"><a title="Security" href="/tag/security/">Security</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33221"><a title="Serverless" href="/tag/serverless">Serverless</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28542"><a title="Test" href="/tag/test/">Test</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33220"><a title="Value Stream" href="/tag/value-stream-management">Value Stream</a></li>
</ul></div>                </div>
            </div>
        </div>
    </div>

<!-- start content container -->
<div class="row dmbs-content">

    
    <article class="col-md-8 col-sm-6 col-xs-12 hnews hentry item dmbs-main post-40121 post type-post status-publish format-standard has-post-thumbnail category-latest-news category-sd-times-editors-blog tag-ab-testing tag-apache-spark tag-open-source">

      <div>

          <div class="row">
              <h1 class="col-xs-12 page-header">SD Times Open-Source Project of the Week: spark-inequality-impact</h1>
          </div>

          <div class="row">
              <div class="postmeta">
    <span class="categories"><a href="https://sdtimes.com/category/latest-news/" rel="category tag">Latest News</a></span><span class="categories"><a href="https://sdtimes.com/category/sd-times-editors-blog/" rel="category tag">SD Times Editors Blog</a></span>
    <div class="published">Published: <span class="updated">May 29th, 2020</span></div>
        - <span class="author-bio"><a href="https://sdtimes.com/author/jakub-lewkowicz/" title="Posts by Jakub Lewkowicz" class="author url fn" rel="author">Jakub Lewkowicz</a></span>
    </div>
              <div class="postsocial">
    <!-- Created with a shortcode from an AddThis plugin --><div class="addthis_inline_share_toolbox_xdry addthis_tool"></div><!-- End of short code snippet --></div>
          </div>

          <div class="row">
              <div class="col-xs-12 postContent">
                  <div class="sd-post-top-html"></div><img width="490" height="368" src="https://sdtimes.com/wp-content/uploads/2020/05/project-every-member-490x368.png" class="alignright size-medium wp-post-image" alt="" srcset="https://sdtimes.com/wp-content/uploads/2020/05/project-every-member-490x368.png 490w, https://sdtimes.com/wp-content/uploads/2020/05/project-every-member-150x113.png 150w, https://sdtimes.com/wp-content/uploads/2020/05/project-every-member-300x225.png 300w, https://sdtimes.com/wp-content/uploads/2020/05/project-every-member-768x576.png 768w, https://sdtimes.com/wp-content/uploads/2020/05/project-every-member-107x80.png 107w, https://sdtimes.com/wp-content/uploads/2020/05/project-every-member-400x300.png 400w, https://sdtimes.com/wp-content/uploads/2020/05/project-every-member-240x180.png 240w, https://sdtimes.com/wp-content/uploads/2020/05/project-every-member-67x50.png 67w, https://sdtimes.com/wp-content/uploads/2020/05/project-every-member.png 900w" sizes="(max-width: 490px) 100vw, 490px" /><div class="at-above-post addthis_tool" data-url="https://sdtimes.com/open-source/sd-times-open-source-project-of-the-week-spark-inequality-impact/"></div><p><span style="font-weight: 400;">LinkedIn is sharing its &#8220;<a href="https://blog.linkedin.com/2020/may/26/helping-every-company-build-more-inclusive-products">Project Every Member</a>&#8221; initiative with the open sourcing of spark-inequality-impact, an Apache Spark library that can be used by other organizations in any domain where measuring and reducing inequality, or avoiding unintended inequality consequences may be desirable.  </span></p>
<p><span style="font-weight: 400;">“This work is furthering our commitment to closing the network gap and making sure everyone has a fair shot at finding and accessing opportunities, regardless of their background or connections,” LinkedIn wrote in a </span><a href="https://engineering.linkedin.com/blog/2020/bringing-project-every-member-to-life"><span style="font-weight: 400;">blog post</span></a>.</p>
<p>LinkedIn announced last month that it would be building<span style="font-weight: 400;"> inclusive products through A/B testing in the initiative called Project Every Member. </span></p>
<p><span style="font-weight: 400;">LinkedIn stated that any change on its platform is subjected to a series of testing and analysis processes to ensure that it achieves intended product goals and business objectives through A/B testing. The best way to go about it is to start by giving a preview of the change or feature to a few members for a limited time, and then measure the results. </span></p>
<p><span style="font-weight: 400;">The Atkinson index is then used to determine which end of the distribution contributed most to the observed inequality and allows developers to encode other information about the population being measured into the analysis to overcome any shortcomings that A/B testing has. </span></p>
<p><span style="font-weight: 400;">LinkedIn decided to implement Atkinson index computations using Apache Spark due to scalability considerations with respect to the size of the data over which to compute inequality, for example, the number of individuals who are part of specific A/B tests and the number of times inequality needs to be computed. </span></p>
<p><span style="font-weight: 400;">While inequality metrics can already be computed on R and Python, they typically require users to fit all the data in memory within a single machine. </span></p>
<p><span style="font-weight: 400;">“We are releasing a package that leverages the fact that the Atkinson index can be decomposed as a sum, which means the data does not to be held in memory all at once. We then use it as part of a larger pipeline that applies it to many A/B tests at once,” LinkedIn wrote. </span></p>
<p><span style="font-weight: 400;">The code is available on GitHub</span><a href="https://github.com/linkedin/spark-inequality-impact"><span style="font-weight: 400;"> here</span></a>.</p>
<!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://sdtimes.com/open-source/sd-times-open-source-project-of-the-week-spark-inequality-impact/"></div><!-- AddThis Share Buttons generic via filter on the_content --><div class="sd-post-bottom-html"><script>
if (window.convertflow == undefined) {
var script = document.createElement('script'); 
script.async = true;
script.src = "https://js.convertflow.co/production/websites/7166.js"; 
document.body.appendChild(script); 
};
</script>
<div class="cf-cta-snippet cta43230" website-id="7166" cta-id="43230"></div></div>              </div>
          </div>

          <div class="row wp-link-pages">
                        </div>

          <div class="row">
              <div class="col-xs-12 tags">
                                        <h3>Article Tags</h3>
                      <p>
                      <a href="https://sdtimes.com/tag/ab-testing/" rel="tag">A/B testing</a>, <a href="https://sdtimes.com/tag/apache-spark/" rel="tag">Apache Spark</a>, <a href="https://sdtimes.com/tag/open-source/" rel="tag">open source</a>                      </p>
                                </div>
          </div>

          <div class="row share-after-content">
              <div class="postsubscribe">
    <h4><a href="http://resources.sdtimes.com/sdtimes-subscription?__hstc=54983092.b1c3fc9f788d79895403cd04467299f2.1402689135055.1402689135055.1404158676313.2&__hssc=54983092.2.1404218565731&__hsfp=2368551689">Subscribe to SDTimes</a></h4>
</div>              <div class="postsocial">
    <!-- Created with a shortcode from an AddThis plugin --><div class="addthis_inline_share_toolbox_xdry addthis_tool"></div><!-- End of short code snippet --></div>
          </div>

          <div class="row">
              <div class="col-xs-12">
                                  <div class="authorarea">
                    <div class="authorimg">
                    <img src="https://sdtimes.com/wp-content/uploads/2019/04/Screen-Shot-2019-04-16-at-12.23.52-PM-1-150x131.png">                    </div>
                    <div class="authortext">
                        <h3>About Jakub Lewkowicz</h3>
                        <p class="authorinfo">
                            Jakub Lewkowicz is a multimedia journalist who loves all things tech. Polish-born and Long Island-bred, he is an Online and Social Media Editor for SD Times. He is also a Carnegie Hall pianist and music producer.                        </p>
                        <a class="author-link" href="https://sdtimes.com/author/jakub-lewkowicz/" rel="author">View all posts by Jakub Lewkowicz</a>
                    </div>
                </div>
                              </div>
          </div>

          <div class="row">
              <div class="col-xs-12">
                  <div id="custom-post-smart-cta">
                      <iframe allowfullscreen allow="fullscreen" style="border:none;width:100%;height:500px;" src="//e.issuu.com/embed.html?d=sdt035-may2020&doAutoflipPages=true&hideIssuuLogo=true&hideShareButton=true&u=d2emerge"></iframe>                  </div>
              </div>
          </div>
      </div>
    </article>

    <div class="col-md-4 col-sm-6 col-xs-12 hidden-xs dmbs-right">
    <aside id="trending-stories-widget-2" class="widget trending-stories-widget"><!-- From cache --><div id="trending">
    <div class="trendinghead">
        <h2>Trending Stories</h2>
    </div>
    <div class="feeds">
        <ul>
                                <li>
                        <span>1</span>
                        <div>
                            <a href="http://sdtimes.com/softwaredev/the-developers-dilemma-choosing-between-go-and-rust/">The developer’s dilemma: Choosing between Go and Rust</a>
                        </div>
                    </li>
                                                    <li>
                        <span>2</span>
                        <div>
                            <a href="http://sdtimes.com/apis/securing-microservices-the-api-gateway-authentication-and-authorization/">Securing Microservices: The API gateway, authentication and authorization</a>
                        </div>
                    </li>
                                                    <li>
                        <span>3</span>
                        <div>
                            <a href="http://sdtimes.com/java/google-cloud-functions-adds-support-for-java-11/">Google Cloud Functions adds support for Java 11</a>
                        </div>
                    </li>
                                                    <li>
                        <span>4</span>
                        <div>
                            <a href="http://sdtimes.com/softwaredev/report-rust-is-the-most-beloved-programming-language-for-five-years-running/">Report: Rust is the most beloved programming language for five years running</a>
                        </div>
                    </li>
                                        </ul>
    </div>
</div>
</aside>			<div class="banner_ad medrec_1_ad">
				<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/med_rec_1', [[300,600],[300, 250]], 'div-gpt-ad-1466026216582-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/med_rec_1 -->
<div id='div-gpt-ad-1466026216582-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026216582-0'); }); 
</script>
</div>			</div>
			<aside id="foo_widget-2" class="widget widget_foo_widget"></aside>			<div class="banner_ad medrec_2_ad">
				<script>
if (window.convertflow == undefined) {
var script = document.createElement('script'); 
script.async = true;
script.src = "https://js.convertflow.co/production/websites/7166.js"; 
document.body.appendChild(script); 
};
</script>
<div class="cf-cta-snippet cta42952" website-id="7166" cta-id="42952"></div>			</div>
						<div class="banner_ad medrec_3_ad">
				<script>
if (window.convertflow == undefined) {
var script = document.createElement('script'); 
script.async = true;
script.src = "https://js.convertflow.co/production/websites/7166.js"; 
document.body.appendChild(script); 
};
</script>
<div class="cf-cta-snippet cta48026" website-id="7166" cta-id="48026"></div>			</div>
						<div class="banner_ad medrec_4_ad">
							</div>
						<div class="banner_ad medrec_5_ad">
				<script type='text/javascript'>
  googletag.cmd.push(function() {
  googletag.defineSlot('/67541884/med_rec_5', [300, 250], 'div-gpt-ad-1466026594130-0').addService(googletag.pubads());
  googletag.pubads().enableSingleRequest();
  googletag.enableServices();
 });
</script>

<!-- /67541884/med_rec_5 -->
<div id='div-gpt-ad-1466026594130-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026594130-0'); }); 
</script>
</div>			</div>
						<div class="banner_ad medrec_6_ad">
				<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/med_rec_6', [300, 250], 'div-gpt-ad-1466026679557-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/med_rec_6 -->
<div id='div-gpt-ad-1466026679557-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026679557-0'); });
</script>
</div>			</div>
			</div>

          	<div class="col-xs-12 related-posts">
		<div class="row headerbox">
			<h2 class="col-md-12">Related Articles</h2>
		</div>

		<div class="row">
							<div class="col-md-6 col-xs-12 related-post-item">
					<div class="row">
						<div class="col-xs-6">
															<img width="150" height="100" src="https://sdtimes.com/wp-content/uploads/2019/01/artificial-intelligence-3382507_640-2-150x100.jpg" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" srcset="https://sdtimes.com/wp-content/uploads/2019/01/artificial-intelligence-3382507_640-2-150x100.jpg 150w, https://sdtimes.com/wp-content/uploads/2019/01/artificial-intelligence-3382507_640-2-300x200.jpg 300w, https://sdtimes.com/wp-content/uploads/2019/01/artificial-intelligence-3382507_640-2-490x326.jpg 490w, https://sdtimes.com/wp-content/uploads/2019/01/artificial-intelligence-3382507_640-2-120x80.jpg 120w, https://sdtimes.com/wp-content/uploads/2019/01/artificial-intelligence-3382507_640-2-400x266.jpg 400w, https://sdtimes.com/wp-content/uploads/2019/01/artificial-intelligence-3382507_640-2-270x180.jpg 270w, https://sdtimes.com/wp-content/uploads/2019/01/artificial-intelligence-3382507_640-2-75x50.jpg 75w, https://sdtimes.com/wp-content/uploads/2019/01/artificial-intelligence-3382507_640-2.jpg 640w" sizes="(max-width: 150px) 100vw, 150px" />													</div>
						<div class="col-xs-6">
							<h3 class="title">
								<a href="https://sdtimes.com/softwaredev/sd-times-news-digest-erwin-data-intelligence-suite-update-red-hat-supports-quarkus-and-gatsbys-round-of-funding-for-modern-development/" title="Permalink to SD Times news digest: erwin Data Intelligence Suite update, Red Hat supports Quarkus, and Gatsby’s round of funding for modern development" rel="bookmark">SD Times news digest: erwin Data Intelligence Suite update, Red Hat supports Quarkus, and Gatsby’s round of funding for modern development</a>
							</h3>
						</div>
					</div>
				</div>
							<div class="col-md-6 col-xs-12 related-post-item">
					<div class="row">
						<div class="col-xs-6">
															<img width="150" height="91" src="https://sdtimes.com/wp-content/uploads/2020/05/528c8ef8781496acec11c68be5766778-150x91.png" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="source code for GW-BASIC on GitHub" srcset="https://sdtimes.com/wp-content/uploads/2020/05/528c8ef8781496acec11c68be5766778-150x91.png 150w, https://sdtimes.com/wp-content/uploads/2020/05/528c8ef8781496acec11c68be5766778-300x182.png 300w, https://sdtimes.com/wp-content/uploads/2020/05/528c8ef8781496acec11c68be5766778-768x467.png 768w, https://sdtimes.com/wp-content/uploads/2020/05/528c8ef8781496acec11c68be5766778-490x298.png 490w, https://sdtimes.com/wp-content/uploads/2020/05/528c8ef8781496acec11c68be5766778-132x80.png 132w, https://sdtimes.com/wp-content/uploads/2020/05/528c8ef8781496acec11c68be5766778-400x243.png 400w, https://sdtimes.com/wp-content/uploads/2020/05/528c8ef8781496acec11c68be5766778-296x180.png 296w, https://sdtimes.com/wp-content/uploads/2020/05/528c8ef8781496acec11c68be5766778-82x50.png 82w, https://sdtimes.com/wp-content/uploads/2020/05/528c8ef8781496acec11c68be5766778.png 974w" sizes="(max-width: 150px) 100vw, 150px" />													</div>
						<div class="col-xs-6">
							<h3 class="title">
								<a href="https://sdtimes.com/msft/microsoft-open-sources-gw-basic-code/" title="Permalink to Microsoft open sources GW-BASIC code" rel="bookmark">Microsoft open sources GW-BASIC code</a>
							</h3>
						</div>
					</div>
				</div>
							<div class="col-md-6 col-xs-12 related-post-item">
					<div class="row">
						<div class="col-xs-6">
															<img width="150" height="83" src="https://sdtimes.com/wp-content/uploads/2020/05/cdpaiarch3-150x83.jpg" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" srcset="https://sdtimes.com/wp-content/uploads/2020/05/cdpaiarch3-150x83.jpg 150w, https://sdtimes.com/wp-content/uploads/2020/05/cdpaiarch3-300x166.jpg 300w, https://sdtimes.com/wp-content/uploads/2020/05/cdpaiarch3-490x271.jpg 490w, https://sdtimes.com/wp-content/uploads/2020/05/cdpaiarch3-145x80.jpg 145w, https://sdtimes.com/wp-content/uploads/2020/05/cdpaiarch3-400x221.jpg 400w, https://sdtimes.com/wp-content/uploads/2020/05/cdpaiarch3-320x177.jpg 320w, https://sdtimes.com/wp-content/uploads/2020/05/cdpaiarch3-91x50.jpg 91w, https://sdtimes.com/wp-content/uploads/2020/05/cdpaiarch3.jpg 672w" sizes="(max-width: 150px) 100vw, 150px" />													</div>
						<div class="col-xs-6">
							<h3 class="title">
								<a href="https://sdtimes.com/open-source/sd-times-open-source-project-of-the-week-code-defect-ai/" title="Permalink to SD Times Open-Source Project of the Week: Code Defect AI" rel="bookmark">SD Times Open-Source Project of the Week: Code Defect AI</a>
							</h3>
						</div>
					</div>
				</div>
							<div class="col-md-6 col-xs-12 related-post-item">
					<div class="row">
						<div class="col-xs-6">
															<img width="150" height="99" src="https://sdtimes.com/wp-content/uploads/2017/07/map-455769_640.jpg" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" />													</div>
						<div class="col-xs-6">
							<h3 class="title">
								<a href="https://sdtimes.com/softwaredev/sd-times-news-digest-java-client-roadmap-updates-xscode-and-redis-partnership-and-venafi-acquires-jetstack-for-digital-transformation/" title="Permalink to SD Times news digest: Java Client roadmap updates, Xs:code and Redis’ partnership, and Venafi acquires Jetstack for digital transformation" rel="bookmark">SD Times news digest: Java Client roadmap updates, Xs:code and Redis’ partnership, and Venafi acquires Jetstack for digital transformation</a>
							</h3>
						</div>
					</div>
				</div>
					</div>
	</div>

      
            


    <div class="col-xs-12">
        			<div class="banner_ad bottom_leaderboard">
				<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/leader_1_bottom', [728, 90], 'div-gpt-ad-1466028372866-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/leader_1_bottom -->
<div id='div-gpt-ad-1466028372866-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466028372866-0'); });
</script>
</div>			</div>
			    </div>

    <div class="col-xs-12">
        			<div class="banner_ad bottom_leaderboard_2">
				<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/leader_2_bottom', [728, 90], 'div-gpt-ad-1466028474085-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/leader_2_bottom -->
<div id='div-gpt-ad-1466028474085-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466028474085-0'); });
</script>
</div>			</div>
			    </div>

</div>

<!-- end content container -->

    <div class="row sd-footer">
            <div class="col-xs-12 col-md-4">
        <div class="footer-interior">
            <aside id="nav_menu-3" class="widget widget_nav_menu"><h3>SD Times</h3><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-5041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5041"><a title="_blank" href="https://d2emerge.com/">About Us</a></li>
<li id="menu-item-5418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5418"><a title="_blank" href="https://d2emerge.com/about/">Contact Us</a></li>
<li id="menu-item-5419" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5419"><a href="https://sdtimes.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-5045" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5045"><a href="https://sdtimes.com/site-map/">Site Map</a></li>
<li id="menu-item-5047" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5047"><a target="_blank" rel="noopener noreferrer" href="https://d2emerge.convertflowpages.com/advertisesdtimes#new_tab">Advertise</a></li>
<li id="menu-item-5160" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5160"><a href="https://sdtimes.com/subscribe-to-sd-times-magazine/">Subscribe</a></li>
<li id="menu-item-31166" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31166"><a href="https://sdtimes.com/subscriptionupdate/">Manage My Preferences</a></li>
</ul></div></aside>        </div>
    </div>
    <div class="col-xs-12 col-md-4">
        <div class="footer-interior">
            <aside id="sdtimes-subscribe-widget-2" class="widget sdtimes-subscribe-widget"><div id="subscribe">

    
    <h3 class="title">Subscribe to SD Times</h3>
    <div class="sdtimessubscribe row">
        <div class="col-xs-5">
            <a href="https://sdtimes.com/sd-times-may-2020/" target="_blank"><img width="200" height="271" src="https://sdtimes.com/wp-content/uploads/2020/05/May035cover-200px.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://sdtimes.com/wp-content/uploads/2020/05/May035cover-200px.jpg 200w, https://sdtimes.com/wp-content/uploads/2020/05/May035cover-200px-111x150.jpg 111w, https://sdtimes.com/wp-content/uploads/2020/05/May035cover-200px-150x203.jpg 150w, https://sdtimes.com/wp-content/uploads/2020/05/May035cover-200px-59x80.jpg 59w, https://sdtimes.com/wp-content/uploads/2020/05/May035cover-200px-133x180.jpg 133w, https://sdtimes.com/wp-content/uploads/2020/05/May035cover-200px-37x50.jpg 37w" sizes="(max-width: 200px) 100vw, 200px" /></a>        </div>
        <div class="col-xs-7">
            <div class="smallertext"><p>Ready for your SD Times magazine? It's just a click away!</p></div>
            <p><a class="button" href="https://sdtimes.com/subscribe-to-sd-times-magazine/">Subscribe</a></p>            <ul class="links">
                <li><a href="https://sdtimes.com/sd-times-may-2020/" target="_blank">Read Current Issue</a></li>
                <li><a href="https://sdtimes.com/back-issues/" target="_blank">Read Back Issues</a></li>
            </ul>
        </div>
    </div>

</div></aside>        </div>
    </div>
    <div class="col-xs-12 col-md-4">
        <div class="footer-interior">
            <aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a class="twitter-timeline" href="https://twitter.com/sdtimes" data-widget-id="472430906574004224" data-height="450" data-chrome="transparent">Tweets by @sdtimes</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div></aside>        </div>
    </div>
    </div>

    <div class="row footer-credit">
        <div class="col-xs-12 col-md-2 copyright">&copy; 2020 D2 Emerge LLC.</div>
        <div class="col-xs-12 col-md-8 min-footer-menu">
            <aside id="nav_menu-2" class="widget widget_nav_menu"><div class="menu-footer-mini-menu-container"><ul id="menu-footer-mini-menu" class="menu"><li id="menu-item-6911" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6911"><a href="https://sdtimes.com/subscribe-to-sd-times-magazine/">Subscribe</a></li>
<li id="menu-item-26413" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26413"><a href="https://d2emerge.com/about/">Contact Us</a></li>
<li id="menu-item-5065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5065"><a href="https://sdtimes.com/site-map/">Site Map</a></li>
<li id="menu-item-5066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5066"><a href="https://sdtimes.com/privacy-policy/">Privacy Policy</a></li>
</ul></div></aside>        </div>
        <div class="col-xs-12 col-md-2"><div class="social">
	<ul>
		<li><a class="fa fa-facebook" href="https://www.facebook.com/SDTimesD2"></a></li>
		<li><a class="fa fa-twitter" href="http://www.twitter.com/sdtimes"></a></li>
	</ul>
</div></div>
    </div>

</div>
<!-- end main container -->
<div class="adWrap">
    <div class="adWrapCenter">
        <div class="innerAdWrapCenter">
            <div class="fl">
                			<div class="banner_ad gutter_ad_left">
				<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/Gutter_left', [300, 1050], 'div-gpt-ad-1529072259969-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/Gutter_left -->
<div id='div-gpt-ad-1529072259969-0' style='height:1050px;width:300px;justify-content:flex-end;align-items;flex-start;margin:0;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1529072259969-0'); });
</script>
</div>			</div>
			            </div>
            <div class="fr">
                			<div class="banner_ad gutter_ad_right">
				<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/Gutter_Right', [ 300.0 ,  1050.0 ], 'div-gpt-ad-1528279934873-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/Gutter_Right -->
<div id='div-gpt-ad-1528279934873-0' style='height:1050px;width:300px;justify-content:flex-start;align-items;flex-start;margin:0;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1528279934873-0'); });
</script>
</div>			</div>
			            </div>
        </div>
    </div>
</div>

<script type="text/javascript">
	jQuery('a[title="_blank"]').each(
			function(i) {
				jQuery(this).attr('target', '_blank');
				jQuery(this).attr('title', jQuery(this).text());
			}
		);
</script> <div style="width:100%;text-align:center; font-size:11px; clear:both"><a target="_blank" title="Insert HTML Snippet Wordpress Plugin" href="http://xyzscripts.com/wordpress-plugins/insert-html-snippet/">HTML Snippets</a> Powered By : <a target="_blank" title="PHP Scripts & Wordpress Plugins" href="http://www.xyzscripts.com" >XYZScripts.com</a></div><link rel="stylesheet" type="text/css" href="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.0/cookieconsent.min.css" />
<script src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.0/cookieconsent.min.js"></script>
<script>
window.addEventListener("load", function(){
window.cookieconsent.initialise({
  "palette": {
    "popup": {
      "background": "#000",
      "opacity": "0.7"
    },
    "button": {
      "background": "#fd4239",
      "color": "#fff"
    }
  },
  "theme": "edgeless",
  "position": "top",
  "onInitialise": function() {
  	// clear the Hubspot opt out since we are using cookie consent instead
  	document.cookie = "__hs_opt_out=no;expires=Thu, 01 Jan 1970 00:00:00 GMT;path=/;domain=.sdtimes.com";
  	if( _hsq ) {
  		//_hsq.push(['revokeCookieConsent']);
  	}
  }
})});
</script>
	<link rel='stylesheet' id='barracuda-fe-style-css'  href='https://sdtimes.com/wp-content/plugins/ff-help/css/barracuda-fe-admin-bar-styles.css?ver=5.2.6' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var php_data = {"ac_settings":{"tracking_actid":252377639,"site_tracking_default":1,"site_tracking":1},"user_email":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/plugins/activecampaign-subscription-forms/site_tracking.js?ver=5.2.6'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/themes/sdtimes2014/js/fusionfarm-bootstrap-responsive.js?ver=1.0'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/lity/2.3.1/lity.min.js?ver=2.3.1'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/iframe-resizer/3.6.1/iframeResizer.min.js?ver=3.6.1'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/themes/devdmbootstrap3/js/bootstrap.js?ver=1.40'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.3'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-includes/js/wp-embed.min.js?ver=5.2.6'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/plugins/ff-help/js/barracuda-fe-script.js?ver=5.2.6'></script>
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M8DVS3N"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) --><!-- START Fusionfarm/Hubspot API -- subscription popup -->
<!-- PLACE THIS IN THE <head> OF EVERY PAGE THAT YOU WANT THE POPUP -->
<script type="text/javascript" src="/hubspot-api/Fusionfarm/sdtimes-settings.js.php"></script>
<script type="text/javascript" src="/hubspot-api/Fusionfarm/sdtimes-offer-popup.js"></script>
<script type="text/javascript">
jQuery(
    function(){
        Fusionfarm.setup_events();
    }
);
</script>


<div id="sd-premium-inline" class="col-xs-12">
    <div class="sd-premium-out">
        <div class="sd-premium-int">
            <div class="sd-premium-head">
                <img class="sd-premium-sd-logo" src="https://sdtimes.com/wp-content/uploads/2014/05/LOGO_SDTimes.png">
                <img class="sd-premium-logo" src="/images/sd-premium.png">
            </div>
            <div class="sd-premium-body">
                <p><strong>Get access to this and other exclusive articles for <span class="free">FREE!</span></strong></p>
                <p>There's no charge and it only takes a few seconds.</p>
                <a class="sd-premium-cta" href="#" data-sd-premium-modal>Sign up now!</a>
            </div>
        </div>
    </div>
</div>
<!-- END Fusionfarm/Hubspot API -- subscription popup --><script>
ga(function(){
  var gaName = ga.getAll()[0].get('name');
  ga(gaName + '.require', 'Clearbit', {"mapping":{"companyName":"dimension1","companyDomain":"dimension2","companyTags":"dimension3","companySector":"dimension4","companyIndustryGroup":"dimension5","companyIndustry":"dimension6","companySubIndustry":"dimension7","companyType":"dimension8","companyEmployeesRange":"dimension9","companyAlexaRank":"dimension10","companyCity":"dimension11","companyState":"dimension12","companyCountry":"dimension13","companyFunding":"dimension14","companyTech":"dimension15"}});
});
</script>
<script async src="https://ga.clearbit.com/v1/ga.js?authorization=pk_6c0d4a85db57d64ddbe53597246f9578"></script>
</body>
</html>