<!DOCTYPE html>
<html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" >
<head>
    <meta http-equiv="content-type" content="text/html; charset=UTF-8" />
    <meta name="description" content="Software Development News" />
    <title>Report: JavaScript remains the most popular language among developers - SD Times</title>
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <link rel="pingback" href="https://sdtimes.com/xmlrpc.php" />
    
	<!-- This site is optimized with the Yoast SEO plugin v15.4 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="JetBrains conducted the fifth annual State of Developer Ecosystem Survey. The study revealed trends in the tech industry." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://sdtimes.com/softwaredev/report-javascript-remains-the-most-popular-language-among-developers/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Report: JavaScript remains the most popular language among developers - SD Times" />
	<meta property="og:description" content="JetBrains conducted the fifth annual State of Developer Ecosystem Survey. The study revealed trends in the tech industry." />
	<meta property="og:url" content="https://sdtimes.com/softwaredev/report-javascript-remains-the-most-popular-language-among-developers/" />
	<meta property="og:site_name" content="SD Times" />
	<meta property="article:publisher" content="https://www.facebook.com/SDTimesD2" />
	<meta property="article:published_time" content="2021-07-16T16:00:05+00:00" />
	<meta property="article:modified_time" content="2021-07-16T15:51:14+00:00" />
	<meta property="og:image" content="https://sdtimes.com/wp-content/uploads/2021/07/9d45a8983030529ed674da1b4de076c8.png" />
	<meta property="og:image:width" content="777" />
	<meta property="og:image:height" content="623" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@sdtimes" />
	<meta name="twitter:site" content="@sdtimes" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Katie Dee">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="1 minute">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://sdtimes.com/#organization","name":"SD Times","url":"https://sdtimes.com/","sameAs":["https://www.facebook.com/SDTimesD2","https://twitter.com/sdtimes"],"logo":{"@type":"ImageObject","@id":"https://sdtimes.com/#logo","inLanguage":"en-US","url":"https://sdtimes.com/wp-content/uploads/2014/05/deafaultlogo.png","width":225,"height":90,"caption":"SD Times"},"image":{"@id":"https://sdtimes.com/#logo"}},{"@type":"WebSite","@id":"https://sdtimes.com/#website","url":"https://sdtimes.com/","name":"SD Times","description":"Software Development News","publisher":{"@id":"https://sdtimes.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://sdtimes.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://sdtimes.com/softwaredev/report-javascript-remains-the-most-popular-language-among-developers/#primaryimage","inLanguage":"en-US","url":"https://sdtimes.com/wp-content/uploads/2021/07/9d45a8983030529ed674da1b4de076c8.png","width":777,"height":623},{"@type":"WebPage","@id":"https://sdtimes.com/softwaredev/report-javascript-remains-the-most-popular-language-among-developers/#webpage","url":"https://sdtimes.com/softwaredev/report-javascript-remains-the-most-popular-language-among-developers/","name":"Report: JavaScript remains the most popular language among developers - SD Times","isPartOf":{"@id":"https://sdtimes.com/#website"},"primaryImageOfPage":{"@id":"https://sdtimes.com/softwaredev/report-javascript-remains-the-most-popular-language-among-developers/#primaryimage"},"datePublished":"2021-07-16T16:00:05+00:00","dateModified":"2021-07-16T15:51:14+00:00","description":"JetBrains conducted the fifth annual State of Developer Ecosystem Survey. The study revealed trends in the tech industry.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://sdtimes.com/softwaredev/report-javascript-remains-the-most-popular-language-among-developers/"]}]},{"@type":"Article","@id":"https://sdtimes.com/softwaredev/report-javascript-remains-the-most-popular-language-among-developers/#article","isPartOf":{"@id":"https://sdtimes.com/softwaredev/report-javascript-remains-the-most-popular-language-among-developers/#webpage"},"author":{"@id":"https://sdtimes.com/#/schema/person/ea0ca27d004580626cee8234cb6d2b9b"},"headline":"Report: JavaScript remains the most popular language among developers","datePublished":"2021-07-16T16:00:05+00:00","dateModified":"2021-07-16T15:51:14+00:00","mainEntityOfPage":{"@id":"https://sdtimes.com/softwaredev/report-javascript-remains-the-most-popular-language-among-developers/#webpage"},"publisher":{"@id":"https://sdtimes.com/#organization"},"image":{"@id":"https://sdtimes.com/softwaredev/report-javascript-remains-the-most-popular-language-among-developers/#primaryimage"},"keywords":"Java,JavaScript,JetBrains,Python","articleSection":"Latest News","inLanguage":"en-US"},{"@type":"Person","@id":"https://sdtimes.com/#/schema/person/ea0ca27d004580626cee8234cb6d2b9b","name":"Katie Dee","image":{"@type":"ImageObject","@id":"https://sdtimes.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/b6c11fb1ca12229eebcec7d91e91876f?s=96&d=mm&r=g","caption":"Katie Dee"},"description":"Katie Dee is a graduate of SUNY Oneonta where she studied english with a heavy focus on writing and editing. Her passion for writing and interest in tech led her to become an Online and Social Media Editor for SD Times. She is also a lifelong dancer and was a member of the Oneonta State Kickline Team while in school."}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SD Times &raquo; Feed" href="https://sdtimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="SD Times &raquo; Comments Feed" href="https://sdtimes.com/comments/feed/" />
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-M8DVS3N');</script>
<!-- End Google Tag Manager -->		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/sdtimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.6"}};
			/*! This file is auto-generated */
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://sdtimes.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='activecampaign-form-block-css'  href='https://sdtimes.com/wp-content/plugins/activecampaign-subscription-forms/activecampaign-form-block/build/style-index.css?ver=1620201611' type='text/css' media='all' />
<link rel='stylesheet' id='ff_interstitial_css-css'  href='https://sdtimes.com/wp-content/mu-plugins/sdtimes/interstitial-ads/css/style.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='sdtimes-lesscss-css'  href='https://sdtimes.com/wp-content/themes/sdtimes2014/css/sdtimes.css?20201201&#038;ver=5.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Source+Sans+Pro%3A300%2C400%2C600%2C700%2C600italic%7CLato%3A400%2C700%7CBitter%3A400%2C700&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-fonts-css'  href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css?ver=5.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='lity-css-css'  href='//cdnjs.cloudflare.com/ajax/libs/lity/2.3.1/lity.min.css?ver=2.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://sdtimes.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=5.4.6' type='text/css' media='all' />
<script type='text/javascript' src='https://sdtimes.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/mu-plugins/sdtimes/interstitial-ads/js/kkcountdown.dev.js?ver=3.0'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/mu-plugins/sdtimes/interstitial-ads/js/interstitial-ads.js?ver=3.0'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/themes/sdtimes2014/js/sd-jq-onload.js?20180625b&#038;ver=5.4.6'></script>
<script type='text/javascript' src='https://s7.addthis.com/js/300/addthis_widget.js?ver=5.4.6#pubid=wp-4417f7f776d9c2ffd08ba9868d73e669'></script>
<link rel='https://api.w.org/' href='https://sdtimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://sdtimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://sdtimes.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.6" />
<link rel='shortlink' href='https://sdtimes.com/?p=44737' />
<link rel="alternate" type="application/json+oembed" href="https://sdtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsdtimes.com%2Fsoftwaredev%2Freport-javascript-remains-the-most-popular-language-among-developers%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://sdtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsdtimes.com%2Fsoftwaredev%2Freport-javascript-remains-the-most-popular-language-among-developers%2F&#038;format=xml" />
<script async src="https://js.convertflow.co/production/websites/7166.js"></script><!-- Start of HubSpot Embed Code -->
<script type="text/javascript" id="hs-script-loader" async defer src="//js.hs-scripts.com/3475429.js"></script>
<!-- End of HubSpot Embed Code --><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-846073-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-846073-1');
</script><meta http-equiv="refresh" content="500" /><script type="text/javascript" src="//www.queryly.com/js/queryly.js"></script>
<script type="text/javascript">
	queryly.QuerylyKey = "af2d91c2c83847f8";
	//queryly.layout.topMargin = -8;
	//queryly.layout.rightMargin = -74;
	queryly.layout.opacity = 1;

	queryly.QuerylyCallback = function (a, b) {
		queryly.jquery("#s").css('opacity', 1);
		queryly.jquery('#queryly_suggest').css('opacity', 1);
	}
</script>
	<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"ui_atversion":300}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = [{"responsiveshare":{"numPreferredServices":3,"counts":"none","size":"20px","style":"responsive","shareCountThreshold":0,"services":"twitter,email,addthis","elements":".addthis_inline_share_toolbox_xdry","id":"responsiveshare"}}]; } else { window.addthis_layers_tools.push({"responsiveshare":{"numPreferredServices":3,"counts":"none","size":"20px","style":"responsive","shareCountThreshold":0,"services":"twitter,email,addthis","elements":".addthis_inline_share_toolbox_xdry","id":"responsiveshare"}});  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"WordPress","anonymous_profile_id":"wp-4417f7f776d9c2ffd08ba9868d73e669","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script><!-- Clicky Web Analytics - https://clicky.com, WordPress Plugin by Yoast - https://yoast.com/wordpress/plugins/clicky/ --><script type='text/javascript'>
	function clicky_gc(name) {
		var ca = document.cookie.split(';');
		for (var i in ca) {
			if (ca[i].indexOf(name + '=') != -1) {
				return decodeURIComponent(ca[i].split('=')[1]);
			}
		}
		return '';
	}
	var username_check = clicky_gc('"comment_author_1ea0be0111e3c4a55d44c1d0fc560697"');
	if (username_check) var clicky_custom_session = {username: username_check};
</script>
<script>
	
	var clicky_site_ids = clicky_site_ids || [];
	clicky_site_ids.push("100754890");
</script>
<script async src="//static.getclicky.com/js"></script><link rel="icon" href="https://sdtimes.com/wp-content/uploads/2019/06/bnGl7Am3_400x400-50x50.jpeg" sizes="32x32" />
<link rel="icon" href="https://sdtimes.com/wp-content/uploads/2019/06/bnGl7Am3_400x400-300x300.jpeg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://sdtimes.com/wp-content/uploads/2019/06/bnGl7Am3_400x400-180x180.jpeg" />
<meta name="msapplication-TileImage" content="https://sdtimes.com/wp-content/uploads/2019/06/bnGl7Am3_400x400-300x300.jpeg" />
		<style type="text/css" id="wp-custom-css">
			.adWrap .adWrapCenter .innerAdWrapCenter .fl, 
.adWrap .adWrapCenter .innerAdWrapCenter .fr{ display: none;
}

@media screen and (min-width: 1600px) {
	.adWrap .adWrapCenter .innerAdWrapCenter .fl, 
.adWrap .adWrapCenter .innerAdWrapCenter .fr{ display: block;
}
}		</style>
		</head>
<body class="post-template-default single single-post postid-44737 single-format-standard">

<div class="visible-sm visible-md" id="sm-top-banner-wrapper"></div>
<div class="container dmbs-mobile-menu">
<div class="row hidden-md hidden-lg">
    <nav class="navbar" role="navigation">
        <div class="-container-">
            <div class="navbar-header navbar-inverse">
                <div class="navbar-logo">
                    <a href="https://sdtimes.com/"><img src="/images/sdtimes-logo-mobile.png"></a>
                </div>
                <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-1-collapse">
                    <span class="sr-only">Toggle navigation</span>
                    <span class="icon-bar"></span>
                    <span class="icon-bar"></span>
                    <span class="icon-bar"></span>
                </button>
            </div>
            <div class="collapse navbar-collapse navbar-1-collapse"><ul id="menu-main-desktop" class="nav navbar-nav"><li id="menu-item-29495" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29495"><a title="ITOps Times" href="https://www.itopstimes.com/">ITOps Times</a></li>
<li id="menu-item-5222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5222 dropdown"><a title="Features" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Features <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5789" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5789"><a title="In-Depth" href="https://sdtimes.com/category/in-depth/">In-Depth</a></li>
	<li id="menu-item-5371" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5371"><a title="Buyer&#039;s Guide" href="https://sdtimes.com/category/buyers-guide/">Buyer&#8217;s Guide</a></li>
	<li id="menu-item-5372" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5372"><a title="Special Report" href="https://sdtimes.com/category/special-report/">Special Report</a></li>
	<li id="menu-item-44268" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44268"><a title="SD Times 100" href="https://sdtimes.com/sd-times-100/sd-times-100-2021-theyre-ready-for-their-close-ups/">SD Times 100</a></li>
	<li id="menu-item-35005" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35005"><a title="Deeper Look" href="https://sdtimes.com/category/deeper-look/">Deeper Look</a></li>
	<li id="menu-item-9652" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9652"><a title="Industry Spotlight" href="https://sdtimes.com/category/industry-spotlight/">Industry Spotlight</a></li>
</ul>
</li>
<li id="menu-item-5039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5039 dropdown"><a title="Subscribe" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Subscribe <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5392" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5392"><a title="Read The Latest Issue" href="https://sdtimes.com/sd-times-july-2021/">Read The Latest Issue</a></li>
	<li id="menu-item-5161" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5161"><a title="Subscribe to SD Times" href="https://sdtimes.com/subscribe-to-sd-times-magazine/">Subscribe to SD Times</a></li>
	<li id="menu-item-7272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7272"><a title="Back Issues" href="https://sdtimes.com/back-issues/">Back Issues</a></li>
	<li id="menu-item-5430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5430"><a title="SD Times 100 Guide" href="https://sdtimes.com/sd-times-100/">SD Times 100 Guide</a></li>
	<li id="menu-item-5397" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5397"><a title="Working with the Editors" href="https://sdtimes.com/sd-times-magazine/working-with-the-editors/">Working with the Editors</a></li>
	<li id="menu-item-5415" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5415"><a title="Advertise" target="_blank" href="https://d2emerge.convertflowpages.com/advertisesdtimes#new_tab">Advertise</a></li>
	<li id="menu-item-5414" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5414"><a title="Guest View Guidelines" href="https://sdtimes.com/sd-times-magazine/guest-view-guidelines/">Guest View Guidelines</a></li>
	<li id="menu-item-31167" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31167"><a title="Cancel My Subscription" href="https://sdtimes.com/subscriptionupdate/">Cancel My Subscription</a></li>
</ul>
</li>
<li id="menu-item-5389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5389 dropdown"><a title="Learning Center" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Learning Center <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5701" class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5701"><a title="White Papers" href="https://sdtimes.com/sections/white-papers/">White Papers</a></li>
	<li id="menu-item-5704" class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5704"><a title="Webinars" href="https://sdtimes.com/sections/webinars/">Webinars</a></li>
	<li id="menu-item-42397" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42397"><a title="Data Quality" href="https://sdtimes.com/category/data-quality/">Data Quality</a></li>
	<li id="menu-item-35006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35006"><a title="Continuous Testing" href="https://sdtimes.com/category/deeper-look/">Continuous Testing</a></li>
</ul>
</li>
<li id="menu-item-37635" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37635"><a title="Podcasts" href="http://whatthedev.buzzsprout.com/673192">Podcasts</a></li>
<li id="menu-item-40030" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-40030 dropdown"><a title="Events" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Events <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-40029" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40029"><a title="Value Stream DevCon" href="https://events.sdtimes.com/valuestreamdevcon">Value Stream DevCon</a></li>
</ul>
</li>
</ul></div><div class="mobile-topic-nav"><ul id="menu-topic-navigation" class=""><li id="menu-item-28529" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28529"><a title="API" href="/tag/apis/">API</a></li>
<li id="menu-item-28531" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28531"><a title="Agile" href="/tag/agile/">Agile</a></li>
<li id="menu-item-28532" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28532"><a title="Containers" href="/tag/containers/">Containers</a></li>
<li id="menu-item-28534" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28534"><a title="Data" href="/tag/data/">Data</a></li>
<li id="menu-item-28535" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28535"><a title="DevOps" href="/tag/devops/">DevOps</a></li>
<li id="menu-item-28536" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28536"><a title="DevSecOps" href="/tag/devsecops/">DevSecOps</a></li>
<li id="menu-item-28538" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28538"><a title="Low Code" href="/tag/low-code/">Low Code</a></li>
<li id="menu-item-33219" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33219"><a title="Microservices" href="/tag/microservices">Microservices</a></li>
<li id="menu-item-28530" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28530"><a title="Monitor" href="/tag/apm/">Monitor</a></li>
<li id="menu-item-28541" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28541"><a title="Security" href="/tag/security/">Security</a></li>
<li id="menu-item-33221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33221"><a title="Serverless" href="/tag/serverless">Serverless</a></li>
<li id="menu-item-28542" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28542"><a title="Test" href="/tag/test/">Test</a></li>
<li id="menu-item-33220" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33220"><a title="Value Stream" href="/tag/value-stream-management">Value Stream</a></li>
</ul></div>        </div>
    </nav>
</div>
</div><div class="container dmbs-container">
    <div class="row sd-top-ad">
        <div class="col-xs-12">
            			<div class="banner_ad top_mobile_leaderboard">
							</div>
			            			<div class="banner_ad top_leaderboard">
				<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
 googletag.cmd.push(function() {
  googletag.defineSlot('/67541884/Leaderboard_Top_1', [[970,250],[970,90],[728, 90]], 'div-gpt-ad-1466026021929-0').addService(googletag.pubads());
  googletag.pubads().enableSingleRequest();
  googletag.enableServices();
 });
</script>

<!-- /67541884/Leaderboard_Top_1 -->
<div id='div-gpt-ad-1466026021929-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026021929-0'); });
</script>
</div>			</div>
			        </div>
    </div>

    <div class="row sd-header">
        <div class="col-md-12">
            <div class="row dmbs-header hidden-xs hidden-sm">

                <div class="dmbs-header-img">
                    <a href="https://sdtimes.com/"><img src="https://sdtimes.com/wp-content/uploads/2014/05/LOGO_SDTimes.png" height="59" width="180" alt="" /></a>
                </div>

                <div class="dmbs-header-text">
                    <div class="row">
                        <div id="nav-grouping-1" class="col-md-8">
                            

    <div class="row dmbs-top-menu">
        <nav class="navbar" role="navigation">
            <div class="-container-">
                <div class="collapse navbar-collapse navbar-1-collapse"><ul id="menu-main-desktop-1" class="nav navbar-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29495"><a title="ITOps Times" href="https://www.itopstimes.com/">ITOps Times</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5222 dropdown"><a title="Features" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Features <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5789"><a title="In-Depth" href="https://sdtimes.com/category/in-depth/">In-Depth</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5371"><a title="Buyer&#039;s Guide" href="https://sdtimes.com/category/buyers-guide/">Buyer&#8217;s Guide</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5372"><a title="Special Report" href="https://sdtimes.com/category/special-report/">Special Report</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44268"><a title="SD Times 100" href="https://sdtimes.com/sd-times-100/sd-times-100-2021-theyre-ready-for-their-close-ups/">SD Times 100</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35005"><a title="Deeper Look" href="https://sdtimes.com/category/deeper-look/">Deeper Look</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9652"><a title="Industry Spotlight" href="https://sdtimes.com/category/industry-spotlight/">Industry Spotlight</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5039 dropdown"><a title="Subscribe" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Subscribe <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5392"><a title="Read The Latest Issue" href="https://sdtimes.com/sd-times-july-2021/">Read The Latest Issue</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5161"><a title="Subscribe to SD Times" href="https://sdtimes.com/subscribe-to-sd-times-magazine/">Subscribe to SD Times</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7272"><a title="Back Issues" href="https://sdtimes.com/back-issues/">Back Issues</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5430"><a title="SD Times 100 Guide" href="https://sdtimes.com/sd-times-100/">SD Times 100 Guide</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5397"><a title="Working with the Editors" href="https://sdtimes.com/sd-times-magazine/working-with-the-editors/">Working with the Editors</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5415"><a title="Advertise" target="_blank" href="https://d2emerge.convertflowpages.com/advertisesdtimes#new_tab">Advertise</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5414"><a title="Guest View Guidelines" href="https://sdtimes.com/sd-times-magazine/guest-view-guidelines/">Guest View Guidelines</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31167"><a title="Cancel My Subscription" href="https://sdtimes.com/subscriptionupdate/">Cancel My Subscription</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5389 dropdown"><a title="Learning Center" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Learning Center <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5701"><a title="White Papers" href="https://sdtimes.com/sections/white-papers/">White Papers</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5704"><a title="Webinars" href="https://sdtimes.com/sections/webinars/">Webinars</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42397"><a title="Data Quality" href="https://sdtimes.com/category/data-quality/">Data Quality</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35006"><a title="Continuous Testing" href="https://sdtimes.com/category/deeper-look/">Continuous Testing</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37635"><a title="Podcasts" href="http://whatthedev.buzzsprout.com/673192">Podcasts</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-40030 dropdown"><a title="Events" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Events <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40029"><a title="Value Stream DevCon" href="https://events.sdtimes.com/valuestreamdevcon">Value Stream DevCon</a></li>
</ul>
</li>
</ul></div>            </div>
        </nav>
    </div>

                        </div>
                        <div id="nav-grouping-2" class="col-md-4 hidden-xs">
                            <div class="social">
	<ul>
                <li><a class="fa fa-podcast" href="https://whatthedev.buzzsprout.com/"></a></li>
        		<li><a class="fa fa-facebook" href="https://www.facebook.com/SDTimesD2"></a></li>
		<li><a class="fa fa-twitter" href="http://www.twitter.com/sdtimes"></a></li>
	</ul>
</div>                            <div id="top-search-form">
	<form role="search" method="get" id="searchform" class="searchform" action="https://sdtimes.com/">
		<input type="text" class="queryly" value="" name="s" id="s"><script type="text/javascript">queryly.QuerylyBind();</script>
		<button type="submit" id="searchsubmit">
            <i class="fa fa-search" aria-hidden="true"></i>
            Search
        </button>
	</form>
</div>                        </div>
                    </div>
                </div>

            </div>

            <div class="row topic-nav hidden-xs hidden-sm">
                <div class="col-xs-12">
                    <div class="collapse navbar-collapse navbar-1-collapse"><ul id="menu-topic-navigation-1" class="nav navbar-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28529"><a title="API" href="/tag/apis/">API</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28531"><a title="Agile" href="/tag/agile/">Agile</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28532"><a title="Containers" href="/tag/containers/">Containers</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28534"><a title="Data" href="/tag/data/">Data</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28535"><a title="DevOps" href="/tag/devops/">DevOps</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28536"><a title="DevSecOps" href="/tag/devsecops/">DevSecOps</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28538"><a title="Low Code" href="/tag/low-code/">Low Code</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33219"><a title="Microservices" href="/tag/microservices">Microservices</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28530"><a title="Monitor" href="/tag/apm/">Monitor</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28541"><a title="Security" href="/tag/security/">Security</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33221"><a title="Serverless" href="/tag/serverless">Serverless</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28542"><a title="Test" href="/tag/test/">Test</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33220"><a title="Value Stream" href="/tag/value-stream-management">Value Stream</a></li>
</ul></div>                </div>
            </div>
        </div>
    </div>

<!-- start content container -->
<div class="row dmbs-content">

    
    <article class="col-md-8 col-sm-6 col-xs-12 hnews hentry item dmbs-main post-44737 post type-post status-publish format-standard has-post-thumbnail category-latest-news tag-java tag-javascript tag-jetbrains tag-python">

      <div>

          <div class="row">
              <h1 class="col-xs-12 page-header">Report: JavaScript remains the most popular language among developers</h1>
          </div>

          <div class="row">
              <div class="postmeta">
    <span class="categories"><a href="https://sdtimes.com/category/latest-news/" rel="category tag">Latest News</a></span>
    <div class="published">Published: <span class="updated">July 16th, 2021</span></div>
        - <span class="author-bio"><a href="https://sdtimes.com/author/katie-dee/" title="Posts by Katie Dee" class="author url fn" rel="author">Katie Dee</a></span>
    </div>
              <div class="postsocial">
    <!-- Created with a shortcode from an AddThis plugin --><div class="addthis_inline_share_toolbox_xdry addthis_tool"></div><!-- End of short code snippet --></div>
          </div>

          <div class="row">
              <div class="col-xs-12 postContent">
                  <div class="sd-post-top-html"></div><img width="490" height="393" src="https://sdtimes.com/wp-content/uploads/2021/07/9d45a8983030529ed674da1b4de076c8-490x393.png" class="alignright size-medium wp-post-image" alt="" srcset="https://sdtimes.com/wp-content/uploads/2021/07/9d45a8983030529ed674da1b4de076c8-490x393.png 490w, https://sdtimes.com/wp-content/uploads/2021/07/9d45a8983030529ed674da1b4de076c8-300x241.png 300w, https://sdtimes.com/wp-content/uploads/2021/07/9d45a8983030529ed674da1b4de076c8-150x120.png 150w, https://sdtimes.com/wp-content/uploads/2021/07/9d45a8983030529ed674da1b4de076c8-768x616.png 768w, https://sdtimes.com/wp-content/uploads/2021/07/9d45a8983030529ed674da1b4de076c8-100x80.png 100w, https://sdtimes.com/wp-content/uploads/2021/07/9d45a8983030529ed674da1b4de076c8-400x321.png 400w, https://sdtimes.com/wp-content/uploads/2021/07/9d45a8983030529ed674da1b4de076c8-224x180.png 224w, https://sdtimes.com/wp-content/uploads/2021/07/9d45a8983030529ed674da1b4de076c8-62x50.png 62w, https://sdtimes.com/wp-content/uploads/2021/07/9d45a8983030529ed674da1b4de076c8.png 777w" sizes="(max-width: 490px) 100vw, 490px" /><div class="at-above-post addthis_tool" data-url="https://sdtimes.com/softwaredev/report-javascript-remains-the-most-popular-language-among-developers/"></div><p><span style="font-weight: 400;">JavaScript is the most popular language among developers. This is according to the fifth annual </span><a href="https://www.jetbrains.com/lp/devecosystem-2021/"><span style="font-weight: 400;">Developer Ecosystem Survey</span></a><span style="font-weight: 400;"> conducted by JetBrains with responses from 31,743 developers from 183 different countries. This finding is consistent with last year’s </span><a href="https://blog.jetbrains.com/blog/2020/06/11/the-state-of-developer-ecosystem-2020/"><span style="font-weight: 400;">report</span></a><span style="font-weight: 400;">, which found JavaScript to be the most widely used language.</span></p>
<p><span style="font-weight: 400;">The purpose of the survey is to show recent trends in the developer community and help to map the landscape of the tech industry.</span></p>
<p><span style="font-weight: 400;">The survey also showed that while Python is more popular than Java in terms of overall use, Java is more popular as a main language. Thirty-two percent of developers use Java as their main language, and 29% use Python as their main language. </span></p>
<p><span style="font-weight: 400;">It was also revealed that the top five languages developers are planning to migrate to are Go, Kotlin, TypeScript, Python, and Rust, while the top five languages developers were actively learning throughout 2021 were JavaScript, Python, TypeScript, Java, and Go. This aligns closely with the finding that the top five fastest growing languages over the last five years are Python, TypeScript, Kotlin, SQL, and Go.</span></p>
<p><span style="font-weight: 400;">The survey also studied the languages that have had decreased usage over the last five years. These languages are Ruby, Objective-C, and Scala. </span></p>
<p><span style="font-weight: 400;">The survey also revealed statistics about gender, namely, women are more likely than men to be involved in data analysis, machine learning, and UX/UI design. However, women are less likely to be involved in infrastructure development and DevOps, system administration, or deployment. The survey also showed that gender diversity in the tech industry is increasing among younger developers.</span></p>
<p>&nbsp;</p>
<!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://sdtimes.com/softwaredev/report-javascript-remains-the-most-popular-language-among-developers/"></div><!-- AddThis Share Buttons generic via filter on the_content --><div class="sd-post-bottom-html"></div>              </div>
          </div>

          <div class="row wp-link-pages">
                        </div>

          <div class="row">
              <div class="col-xs-12 tags">
                                        <h3>Article Tags</h3>
                      <p>
                      <a href="https://sdtimes.com/tag/java/" rel="tag">Java</a>, <a href="https://sdtimes.com/tag/javascript/" rel="tag">JavaScript</a>, <a href="https://sdtimes.com/tag/jetbrains/" rel="tag">JetBrains</a>, <a href="https://sdtimes.com/tag/python/" rel="tag">Python</a>                      </p>
                                </div>
          </div>

          <div class="row share-after-content">
              <div class="postsubscribe">
    <h4><a href="http://resources.sdtimes.com/sdtimes-subscription?__hstc=54983092.b1c3fc9f788d79895403cd04467299f2.1402689135055.1402689135055.1404158676313.2&__hssc=54983092.2.1404218565731&__hsfp=2368551689">Subscribe to SDTimes</a></h4>
</div>              <div class="postsocial">
    <!-- Created with a shortcode from an AddThis plugin --><div class="addthis_inline_share_toolbox_xdry addthis_tool"></div><!-- End of short code snippet --></div>
          </div>

          <div class="row">
              <div class="col-xs-12">
                                  <div class="authorarea">
                    <div class="authorimg">
                    <img src="https://sdtimes.com/wp-content/uploads/2021/06/D2-Emerge-Headshot-150x150.jpg">                    </div>
                    <div class="authortext">
                        <h3>About Katie Dee</h3>
                        <p class="authorinfo">
                            Katie Dee is a graduate of SUNY Oneonta where she studied english with a heavy focus on writing and editing. Her passion for writing and interest in tech led her to become an Online and Social Media Editor for SD Times. She is also a lifelong dancer and was a member of the Oneonta State Kickline Team while in school.                        </p>
                        <a class="author-link" href="https://sdtimes.com/author/katie-dee/" rel="author">View all posts by Katie Dee</a>
                    </div>
                </div>
                              </div>
          </div>

          <div class="row">
              <div class="col-xs-12">
                  <div id="custom-post-smart-cta">
                      <script>
if (window.convertflow == undefined) {
var script = document.createElement('script'); 
script.async = true;
script.src = "https://js.convertflow.co/production/websites/7166.js"; 
document.body.appendChild(script); 
};
</script>
<div class="cf-cta-snippet cta43230" website-id="7166" cta-id="43230"></div>                  </div>
              </div>
          </div>
      </div>
    </article>

    <div class="col-md-4 col-sm-6 col-xs-12 hidden-xs dmbs-right">
    <aside id="trending-stories-widget-2" class="widget trending-stories-widget"><!-- From cache --><div id="trending">
    <div class="trendinghead">
        <h2>Trending Stories</h2>
    </div>
    <div class="feeds">
        <ul>
                                <li>
                        <span>1</span>
                        <div>
                            <a href="http://sdtimes.com/apis/securing-microservices-the-api-gateway-authentication-and-authorization/">Securing Microservices: The API gateway, authentication and authorization</a>
                        </div>
                    </li>
                                                    <li>
                        <span>2</span>
                        <div>
                            <a href="http://sdtimes.com/data/mongodb-5-0-adds-new-future-proofing-capabilities/">MongoDB 5.0 adds new future-proofing capabilities</a>
                        </div>
                    </li>
                                                    <li>
                        <span>3</span>
                        <div>
                            <a href="http://sdtimes.com/devops/a-developers-guide-to-key-storage-providers/">A developer’s guide to key storage providers</a>
                        </div>
                    </li>
                                                    <li>
                        <span>4</span>
                        <div>
                            <a href="http://sdtimes.com/ca-technologies/test-driven-development-alive-well/">Test Driven Development is alive and well</a>
                        </div>
                    </li>
                                        </ul>
    </div>
</div>
</aside>			<div class="banner_ad medrec_1_ad">
				<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/med_rec_1', [[300,600],[300, 250]], 'div-gpt-ad-1466026216582-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/med_rec_1 -->
<div id='div-gpt-ad-1466026216582-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026216582-0'); }); 
</script>
</div>			</div>
			<aside id="foo_widget-2" class="widget widget_foo_widget"></aside>			<div class="banner_ad medrec_2_ad">
				<script>
if (window.convertflow == undefined) {
var script = document.createElement('script'); 
script.async = true;
script.src = "https://js.convertflow.co/production/websites/7166.js"; 
document.body.appendChild(script); 
};
</script>
<div class="cf-cta-snippet cta92516" data-website-id="7166" data-cta-id="92516"></div>			</div>
						<div class="banner_ad medrec_3_ad">
							</div>
						<div class="banner_ad medrec_4_ad">
							</div>
						<div class="banner_ad medrec_5_ad">
				<script type='text/javascript'>
  googletag.cmd.push(function() {
  googletag.defineSlot('/67541884/med_rec_5', [300, 250], 'div-gpt-ad-1466026594130-0').addService(googletag.pubads());
  googletag.pubads().enableSingleRequest();
  googletag.enableServices();
 });
</script>

<!-- /67541884/med_rec_5 -->
<div id='div-gpt-ad-1466026594130-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026594130-0'); }); 
</script>
</div>			</div>
						<div class="banner_ad medrec_6_ad">
				<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/med_rec_6', [300, 250], 'div-gpt-ad-1466026679557-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/med_rec_6 -->
<div id='div-gpt-ad-1466026679557-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026679557-0'); });
</script>
</div>			</div>
			</div>

          	<div class="col-xs-12 related-posts">
		<div class="row headerbox">
			<h2 class="col-md-12">Related Articles</h2>
		</div>

		<div class="row">
							<div class="col-md-6 col-xs-12 related-post-item">
					<div class="row">
						<div class="col-xs-6">
															<img width="150" height="84" src="https://sdtimes.com/wp-content/uploads/2021/07/roadmapenglish-1536x859-1-150x84.png" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="Roadmap of Java in Visual Studio Code" srcset="https://sdtimes.com/wp-content/uploads/2021/07/roadmapenglish-1536x859-1-150x84.png 150w, https://sdtimes.com/wp-content/uploads/2021/07/roadmapenglish-1536x859-1-300x168.png 300w, https://sdtimes.com/wp-content/uploads/2021/07/roadmapenglish-1536x859-1-1024x573.png 1024w, https://sdtimes.com/wp-content/uploads/2021/07/roadmapenglish-1536x859-1-768x430.png 768w, https://sdtimes.com/wp-content/uploads/2021/07/roadmapenglish-1536x859-1-490x274.png 490w, https://sdtimes.com/wp-content/uploads/2021/07/roadmapenglish-1536x859-1-143x80.png 143w, https://sdtimes.com/wp-content/uploads/2021/07/roadmapenglish-1536x859-1-400x224.png 400w, https://sdtimes.com/wp-content/uploads/2021/07/roadmapenglish-1536x859-1-320x180.png 320w, https://sdtimes.com/wp-content/uploads/2021/07/roadmapenglish-1536x859-1-89x50.png 89w, https://sdtimes.com/wp-content/uploads/2021/07/roadmapenglish-1536x859-1.png 1536w" sizes="(max-width: 150px) 100vw, 150px" />													</div>
						<div class="col-xs-6">
							<h3 class="title">
								<a href="https://sdtimes.com/java/roadmap-released-for-java-in-visual-studio-code-up-through-december-2021/" title="Permalink to Roadmap released for Java in Visual Studio Code up through December 2021" rel="bookmark">Roadmap released for Java in Visual Studio Code up through December 2021</a>
							</h3>
						</div>
					</div>
				</div>
							<div class="col-md-6 col-xs-12 related-post-item">
					<div class="row">
						<div class="col-xs-6">
															<img width="150" height="75" src="https://sdtimes.com/wp-content/uploads/2021/07/goland-150x75.png" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" srcset="https://sdtimes.com/wp-content/uploads/2021/07/goland-150x75.png 150w, https://sdtimes.com/wp-content/uploads/2021/07/goland-300x150.png 300w, https://sdtimes.com/wp-content/uploads/2021/07/goland-768x384.png 768w, https://sdtimes.com/wp-content/uploads/2021/07/goland-490x245.png 490w, https://sdtimes.com/wp-content/uploads/2021/07/goland-400x200.png 400w, https://sdtimes.com/wp-content/uploads/2021/07/goland-320x160.png 320w, https://sdtimes.com/wp-content/uploads/2021/07/goland-160x80.png 160w, https://sdtimes.com/wp-content/uploads/2021/07/goland-100x50.png 100w, https://sdtimes.com/wp-content/uploads/2021/07/goland.png 800w" sizes="(max-width: 150px) 100vw, 150px" />													</div>
						<div class="col-xs-6">
							<h3 class="title">
								<a href="https://sdtimes.com/antitrust/sd-times-news-digest-goland-2021-2-reaches-beta-pluralsight-completes-acquisition-of-a-cloud-guru-contrast-security-partners-with-secure-code-warrior/" title="Permalink to SD Times news digest: GoLand 2021.2 reaches beta, Pluralsight completes acquisition of A Cloud Guru, Contrast Security partners with Secure Code Warrior" rel="bookmark">SD Times news digest: GoLand 2021.2 reaches beta, Pluralsight completes acquisition of A Cloud Guru, Contrast Security partners with Secure Code Warrior</a>
							</h3>
						</div>
					</div>
				</div>
							<div class="col-md-6 col-xs-12 related-post-item">
					<div class="row">
						<div class="col-xs-6">
															<img width="150" height="78" src="https://sdtimes.com/wp-content/uploads/2021/07/928dab0ddc7ddbc1d9741e13378bda80-150x78.png" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" srcset="https://sdtimes.com/wp-content/uploads/2021/07/928dab0ddc7ddbc1d9741e13378bda80-150x78.png 150w, https://sdtimes.com/wp-content/uploads/2021/07/928dab0ddc7ddbc1d9741e13378bda80-300x156.png 300w, https://sdtimes.com/wp-content/uploads/2021/07/928dab0ddc7ddbc1d9741e13378bda80-1024x534.png 1024w, https://sdtimes.com/wp-content/uploads/2021/07/928dab0ddc7ddbc1d9741e13378bda80-768x400.png 768w, https://sdtimes.com/wp-content/uploads/2021/07/928dab0ddc7ddbc1d9741e13378bda80-490x255.png 490w, https://sdtimes.com/wp-content/uploads/2021/07/928dab0ddc7ddbc1d9741e13378bda80-400x209.png 400w, https://sdtimes.com/wp-content/uploads/2021/07/928dab0ddc7ddbc1d9741e13378bda80-320x167.png 320w, https://sdtimes.com/wp-content/uploads/2021/07/928dab0ddc7ddbc1d9741e13378bda80-153x80.png 153w, https://sdtimes.com/wp-content/uploads/2021/07/928dab0ddc7ddbc1d9741e13378bda80-96x50.png 96w, https://sdtimes.com/wp-content/uploads/2021/07/928dab0ddc7ddbc1d9741e13378bda80.png 1195w" sizes="(max-width: 150px) 100vw, 150px" />													</div>
						<div class="col-xs-6">
							<h3 class="title">
								<a href="https://sdtimes.com/java/report-developers-are-moving-from-away-from-java-8-to-java-11/" title="Permalink to Report: Developers are moving away from Java 8 to Java 11" rel="bookmark">Report: Developers are moving away from Java 8 to Java 11</a>
							</h3>
						</div>
					</div>
				</div>
							<div class="col-md-6 col-xs-12 related-post-item">
					<div class="row">
						<div class="col-xs-6">
															<img width="150" height="107" src="https://sdtimes.com/wp-content/uploads/2021/07/Collected-150x107.png" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" srcset="https://sdtimes.com/wp-content/uploads/2021/07/Collected-150x107.png 150w, https://sdtimes.com/wp-content/uploads/2021/07/Collected-300x214.png 300w, https://sdtimes.com/wp-content/uploads/2021/07/Collected-1024x730.png 1024w, https://sdtimes.com/wp-content/uploads/2021/07/Collected-768x547.png 768w, https://sdtimes.com/wp-content/uploads/2021/07/Collected-490x349.png 490w, https://sdtimes.com/wp-content/uploads/2021/07/Collected-112x80.png 112w, https://sdtimes.com/wp-content/uploads/2021/07/Collected-400x285.png 400w, https://sdtimes.com/wp-content/uploads/2021/07/Collected-253x180.png 253w, https://sdtimes.com/wp-content/uploads/2021/07/Collected-70x50.png 70w, https://sdtimes.com/wp-content/uploads/2021/07/Collected.png 1054w" sizes="(max-width: 150px) 100vw, 150px" />													</div>
						<div class="col-xs-6">
							<h3 class="title">
								<a href="https://sdtimes.com/msft/sd-times-news-digest-net-object-allocation-tool-updates-kyndryl-announces-new-global-leadership-model-brown-develops-new-big-data-processing-framework-for-python/" title="Permalink to SD Times news digest: .NET Object Allocation Tool updates, Kyndryl announces new global leadership model, Brown develops new big data processing framework for Python" rel="bookmark">SD Times news digest: .NET Object Allocation Tool updates, Kyndryl announces new global leadership model, Brown develops new big data processing framework for Python</a>
							</h3>
						</div>
					</div>
				</div>
					</div>
	</div>

      
            


    <div class="col-xs-12">
        			<div class="banner_ad bottom_leaderboard">
				<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/leader_1_bottom', [728, 90], 'div-gpt-ad-1466028372866-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/leader_1_bottom -->
<div id='div-gpt-ad-1466028372866-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466028372866-0'); });
</script>
</div>			</div>
			    </div>

    <div class="col-xs-12">
        			<div class="banner_ad bottom_leaderboard_2">
				<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/leader_2_bottom', [728, 90], 'div-gpt-ad-1466028474085-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/leader_2_bottom -->
<div id='div-gpt-ad-1466028474085-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466028474085-0'); });
</script>
</div>			</div>
			    </div>

</div>

<!-- end content container -->

    <div class="row sd-footer">
            <div class="col-xs-12 col-md-4">
        <div class="footer-interior">
            <aside id="nav_menu-3" class="widget widget_nav_menu"><h3>SD Times</h3><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-5041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5041"><a title="_blank" href="https://d2emerge.com/">About Us</a></li>
<li id="menu-item-5418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5418"><a title="_blank" href="https://d2emerge.com/about/">Contact Us</a></li>
<li id="menu-item-5419" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5419"><a href="https://sdtimes.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-5045" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5045"><a href="https://sdtimes.com/site-map/">Site Map</a></li>
<li id="menu-item-5047" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5047"><a target="_blank" rel="noopener noreferrer" href="https://d2emerge.convertflowpages.com/advertisesdtimes#new_tab">Advertise</a></li>
<li id="menu-item-5160" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5160"><a href="https://sdtimes.com/subscribe-to-sd-times-magazine/">Subscribe</a></li>
<li id="menu-item-31166" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31166"><a href="https://sdtimes.com/subscriptionupdate/">Manage My Preferences</a></li>
</ul></div></aside>        </div>
    </div>
    <div class="col-xs-12 col-md-4">
        <div class="footer-interior">
            <aside id="sdtimes-subscribe-widget-2" class="widget sdtimes-subscribe-widget"><div id="subscribe">

    
    <h3 class="title">Subscribe to SD Times</h3>
    <div class="sdtimessubscribe row">
        <div class="col-xs-5">
            <a href="https://sdtimes.com/sd-times-july-2021/" target="_blank"><img width="200" height="270" src="https://sdtimes.com/wp-content/uploads/2021/06/July2021-cov-200px.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://sdtimes.com/wp-content/uploads/2021/06/July2021-cov-200px.png 200w, https://sdtimes.com/wp-content/uploads/2021/06/July2021-cov-200px-111x150.png 111w, https://sdtimes.com/wp-content/uploads/2021/06/July2021-cov-200px-150x203.png 150w, https://sdtimes.com/wp-content/uploads/2021/06/July2021-cov-200px-59x80.png 59w, https://sdtimes.com/wp-content/uploads/2021/06/July2021-cov-200px-133x180.png 133w, https://sdtimes.com/wp-content/uploads/2021/06/July2021-cov-200px-37x50.png 37w" sizes="(max-width: 200px) 100vw, 200px" /></a>        </div>
        <div class="col-xs-7">
            <div class="smallertext"><p>Ready for your SD Times magazine? It's just a click away!</p></div>
            <p><a class="button" href="https://sdtimes.com/subscribe-to-sd-times-magazine/">Subscribe</a></p>            <ul class="links">
                <li><a href="https://sdtimes.com/sd-times-july-2021/" target="_blank">Read Current Issue</a></li>
                <li><a href="https://sdtimes.com/back-issues/" target="_blank">Read Back Issues</a></li>
            </ul>
        </div>
    </div>

</div></aside>        </div>
    </div>
    <div class="col-xs-12 col-md-4">
        <div class="footer-interior">
            <aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a class="twitter-timeline" href="https://twitter.com/sdtimes" data-widget-id="472430906574004224" data-height="450" data-chrome="transparent">Tweets by @sdtimes</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div></aside>        </div>
    </div>
    </div>

    <div class="row footer-credit">
        <div class="col-xs-12 col-md-2 copyright">&copy; 2021 D2 Emerge LLC.</div>
        <div class="col-xs-12 col-md-8 min-footer-menu">
            <aside id="nav_menu-2" class="widget widget_nav_menu"><div class="menu-footer-mini-menu-container"><ul id="menu-footer-mini-menu" class="menu"><li id="menu-item-6911" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6911"><a href="https://sdtimes.com/subscribe-to-sd-times-magazine/">Subscribe</a></li>
<li id="menu-item-26413" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26413"><a href="https://d2emerge.com/about/">Contact Us</a></li>
<li id="menu-item-5065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5065"><a href="https://sdtimes.com/site-map/">Site Map</a></li>
<li id="menu-item-5066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5066"><a href="https://sdtimes.com/privacy-policy/">Privacy Policy</a></li>
</ul></div></aside>        </div>
        <div class="col-xs-12 col-md-2"><div class="social">
	<ul>
                <li><a class="fa fa-podcast" href="https://whatthedev.buzzsprout.com/"></a></li>
        		<li><a class="fa fa-facebook" href="https://www.facebook.com/SDTimesD2"></a></li>
		<li><a class="fa fa-twitter" href="http://www.twitter.com/sdtimes"></a></li>
	</ul>
</div></div>
    </div>

</div>
<!-- end main container -->
<div class="adWrap">
    <div class="adWrapCenter">
        <div class="innerAdWrapCenter">
            <div class="fl">
                			<div class="banner_ad gutter_ad_left">
				<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/Gutter_left', [200, 1050], 'div-gpt-ad-1620753161826-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/Gutter_left -->
<div id='div-gpt-ad-1620753161826-0' style='width: 200px; height: 1050px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1620753161826-0'); });
  </script>
</div>			</div>
			            </div>
            <div class="fr">
                			<div class="banner_ad gutter_ad_right">
				<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/Gutter_Right', [[300, 1050], [200, 1050]], 'div-gpt-ad-1621258503965-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/Gutter_Right -->
<div id='div-gpt-ad-1621258503965-0' style='min-width: 200px; min-height: 1050px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1621258503965-0'); });
  </script>
</div>			</div>
			            </div>
        </div>
    </div>
</div>

<script type="text/javascript">
	jQuery('a[title="_blank"]').each(
			function(i) {
				jQuery(this).attr('target', '_blank');
				jQuery(this).attr('title', jQuery(this).text());
			}
		);
</script> <div id="interads"><div id="interads-bar" style="background:#ffffff;color:#000000;"><div id="interads-tit" class="interads"></div><div id="interads-close"><span data-per-session="1" class="interstitial-ads-per-session"></span><span data-session-length="24" class="interstitial-ads-session-length-hours"></span><div id="inter-mess"><span> Ad will close in </span><span data-seconds="8" class="interads-kkcount-down"></span><span> seconds </span></div><a href="javascript:return false" onclick="interstitialBox.closeit()" style="color:#000000;"> Continue to site <i class="fa fa-caret-right"></i></a></div></div><div id="interads-cnt"><style type="text/css" media="screen">
#interads-cnt > div { margin: 0 auto; }
</style>
<script>
  (function() {
    var useSSL = 'https:' == document.location.protocol;
    var src = (useSSL ? 'https:' : 'http:') +
        '//www.googletagservices.com/tag/js/gpt.js';
    document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
  })();
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/640x480', [640, 480], 'div-gpt-ad-1475861105995-0').addService(googletag.pubads());
    googletag.pubads().enableSyncRendering();
    googletag.enableServices();
  });
</script>
<!-- /67541884/640x480 -->
<div id='div-gpt-ad-1475861105995-0' style='height:480px; width:640px; margin:0px auto;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1475861105995-0'); });
</script>
</div></div></div><div id="interVeil"></div><div style="width:100%;text-align:center; font-size:11px; clear:both"><a target="_blank" title="Insert HTML Snippet Wordpress Plugin" href="http://xyzscripts.com/wordpress-plugins/insert-html-snippet/">HTML Snippets</a> Powered By : <a target="_blank" title="PHP Scripts & Wordpress Plugins" href="http://www.xyzscripts.com" >XYZScripts.com</a></div><link rel="stylesheet" type="text/css" href="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.0/cookieconsent.min.css" />
<script src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.0/cookieconsent.min.js"></script>
<script>
window.addEventListener("load", function(){
window.cookieconsent.initialise({
  "palette": {
    "popup": {
      "background": "#000",
      "opacity": "0.7"
    },
    "button": {
      "background": "#fd4239",
      "color": "#fff"
    }
  },
  "theme": "edgeless",
  "position": "top",
  "onInitialise": function() {
  	// clear the Hubspot opt out since we are using cookie consent instead
  	document.cookie = "__hs_opt_out=no;expires=Thu, 01 Jan 1970 00:00:00 GMT;path=/;domain=.sdtimes.com";
  	if( _hsq ) {
  		//_hsq.push(['revokeCookieConsent']);
  	}
  }
})});
</script>
	<link rel='stylesheet' id='barracuda-fe-style-css'  href='https://sdtimes.com/wp-content/plugins/ff-help/css/barracuda-fe-admin-bar-styles.css?ver=5.4.6' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var php_data = {"ac_settings":{"tracking_actid":252377639,"site_tracking_default":1,"site_tracking":1},"user_email":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/plugins/activecampaign-subscription-forms/site_tracking.js?ver=5.4.6'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/themes/sdtimes2014/js/fusionfarm-bootstrap-responsive.js?ver=1.0'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/lity/2.3.1/lity.min.js?ver=2.3.1'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/iframe-resizer/3.6.1/iframeResizer.min.js?ver=3.6.1'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/themes/devdmbootstrap3/js/bootstrap.js?ver=1.40'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.5'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-includes/js/wp-embed.min.js?ver=5.4.6'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/plugins/ff-help/js/barracuda-fe-script.js?ver=5.4.6'></script>
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M8DVS3N"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) --><!-- START Fusionfarm/Hubspot API -- subscription popup -->
<!-- PLACE THIS IN THE <head> OF EVERY PAGE THAT YOU WANT THE POPUP -->
<script type="text/javascript" src="/hubspot-api/Fusionfarm/sdtimes-settings.js.php"></script>
<script type="text/javascript" src="/hubspot-api/Fusionfarm/sdtimes-offer-popup.js"></script>
<script type="text/javascript">
jQuery(
    function(){
        Fusionfarm.setup_events();
    }
);
</script>


<div id="sd-premium-inline" class="col-xs-12">
    <div class="sd-premium-out">
        <div class="sd-premium-int">
            <div class="sd-premium-head">
                <img class="sd-premium-sd-logo" src="https://sdtimes.com/wp-content/uploads/2014/05/LOGO_SDTimes.png">
                <img class="sd-premium-logo" src="/images/sd-premium.png">
            </div>
            <div class="sd-premium-body">
                <p><strong>Get access to this and other exclusive articles for <span class="free">FREE!</span></strong></p>
                <p>There's no charge and it only takes a few seconds.</p>
                <a class="sd-premium-cta" href="#" data-sd-premium-modal>Sign up now!</a>
            </div>
        </div>
    </div>
</div>
<!-- END Fusionfarm/Hubspot API -- subscription popup --><script>
ga(function(){
  var gaName = ga.getAll()[0].get('name');
  ga(gaName + '.require', 'Clearbit', {"mapping":{"companyName":"dimension1","companyDomain":"dimension2","companyTags":"dimension3","companySector":"dimension4","companyIndustryGroup":"dimension5","companyIndustry":"dimension6","companySubIndustry":"dimension7","companyType":"dimension8","companyEmployeesRange":"dimension9","companyAlexaRank":"dimension10","companyCity":"dimension11","companyState":"dimension12","companyCountry":"dimension13","companyFunding":"dimension14","companyTech":"dimension15"}});
});
</script>
<script async src="https://ga.clearbit.com/v1/ga.js?authorization=pk_6c0d4a85db57d64ddbe53597246f9578"></script>
</body>
</html>