<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
    <meta http-equiv="content-type" content="text/html; charset=UTF-8" />
    <meta name="description" content="Software Development News" />
    <title>Oracle proposes changes to Java release cycle - SD Times</title>
    <meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">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</script>
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <link rel="pingback" href="http://sdtimes.com/xmlrpc.php" />
    
<!-- This site is optimized with the Yoast SEO plugin v5.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Oracle wants to go to a more agile, time-based release train rather than stay with the feature-driven release cycle for Java SE and the JDK."/>
<meta name="news_keywords" content="java, openjdk, oracle, software development, software, developers, programming, programmers, coders" />
<meta name="original-source" content="http://sdtimes.com/oracle-proposes-changes-java-release-cycle/" />
<link rel="canonical" href="http://sdtimes.com/oracle-proposes-changes-java-release-cycle/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Oracle proposes changes to Java release cycle - SD Times" />
<meta property="og:description" content="Oracle wants to go to a more agile, time-based release train rather than stay with the feature-driven release cycle for Java SE and the JDK." />
<meta property="og:url" content="http://sdtimes.com/oracle-proposes-changes-java-release-cycle/" />
<meta property="og:site_name" content="SD Times" />
<meta property="article:publisher" content="https://www.facebook.com/SDTimesD2" />
<meta property="article:tag" content="Java" />
<meta property="article:tag" content="OpenJDK" />
<meta property="article:tag" content="Oracle" />
<meta property="article:section" content="Latest News" />
<meta property="article:published_time" content="2017-09-06T11:00:31-04:00" />
<meta property="article:modified_time" content="2017-09-06T10:48:56-04:00" />
<meta property="og:updated_time" content="2017-09-06T10:48:56-04:00" />
<meta property="og:image" content="http://sdtimes.com/wp-content/uploads/2017/09/romain-peli-266995.jpg" />
<meta property="og:image:width" content="3000" />
<meta property="og:image:height" content="2000" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Oracle wants to go to a more agile, time-based release train rather than stay with the feature-driven release cycle for Java SE and the JDK." />
<meta name="twitter:title" content="Oracle proposes changes to Java release cycle - SD Times" />
<meta name="twitter:site" content="@sdtimes" />
<meta name="twitter:image" content="http://sdtimes.com/wp-content/uploads/2017/09/romain-peli-266995.jpg" />
<meta name="twitter:creator" content="@sdtimes" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SD Times &raquo; Feed" href="http://sdtimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="SD Times &raquo; Comments Feed" href="http://sdtimes.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="SD Times &raquo; Oracle proposes changes to Java release cycle Comments Feed" href="http://sdtimes.com/oracle-proposes-changes-java-release-cycle/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/sdtimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ff_interstitial_css-css'  href='http://sdtimes.com/wp-content/mu-plugins/sdtimes/interstitial-ads/css/style.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='sdtimes-lesscss-css'  href='http://sdtimes.com/wp-content/themes/sdtimes2014/css/bootstrap.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='http://fonts.googleapis.com/css?family=Source+Sans+Pro%3A300%2C400%2C600%2C700%2C600italic%7CLato%3A400%2C700%7CBitter%3A400%2C700&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-fonts-css'  href='http://sdtimes.com/wp-content/themes/sdtimes2014/fonts/font-awesome-4.0.3/css/font-awesome.min.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='mr_social_sharing-css'  href='http://sdtimes.com/wp-content/plugins/social-sharing-toolkit/style_2.1.2.css?ver=4.7.5' type='text/css' media='all' />
<script type='text/javascript' src='http://sdtimes.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-content/mu-plugins/sdtimes/interstitial-ads/js/kkcountdown.dev.js?ver=3.0'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-content/mu-plugins/sdtimes/interstitial-ads/js/interstitial-ads.js?ver=3.0'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-content/themes/sdtimes2014/js/menu-hover.js?ver=4.7.5'></script>
<link rel='https://api.w.org/' href='http://sdtimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://sdtimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://sdtimes.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.5" />
<link rel='shortlink' href='http://sdtimes.com/?p=26948' />
<link rel="alternate" type="application/json+oembed" href="http://sdtimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fsdtimes.com%2Foracle-proposes-changes-java-release-cycle%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://sdtimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fsdtimes.com%2Foracle-proposes-changes-java-release-cycle%2F&#038;format=xml" />
<!-- Start of Async HubSpot Analytics Code -->
    <script type="text/javascript">
        (function(d,s,i,r) {
            if (d.getElementById(i)){return;}
            var n=d.createElement(s),e=d.getElementsByTagName(s)[0];
            n.id=i;n.src='//js.hs-analytics.net/analytics/'+(Math.ceil(new Date()/r)*r)+'/369936.js';
            e.parentNode.insertBefore(n, e);
        })(document,"script","hs-analytics",300000);
    </script>
<!-- End of Async HubSpot Analytics Code --><!-- Begin Google Analytics -->
    <script type="text/javascript">

        var _gaq = _gaq || [];
        _gaq.push(['_setAccount', 'UA-846073-1']);
        _gaq.push(['_trackPageview']);

        (function () {
            var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
            ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
            var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
        })();

	</script>
	<!-- END Google Analytics --><meta http-equiv="refresh" content="900" /><script type="text/javascript" src="http://www.queryly.com/js/queryly.js"></script>
<script type="text/javascript">
   queryly.QuerylyKey = 'af2d91c2c83847f8';
   queryly.layout.topMargin = -8;
   queryly.layout.rightMargin = -74;

   queryly.QuerylyCallback = function (a, b) {
       queryly.jquery('#queryly_suggest').css('opacity', '0.3');
   }
</script>
	</head>
<body class="post-template-default single single-post postid-26948 single-format-standard">

<div class="visible-sm visible-md" id="sm-top-banner-wrapper"></div>
<div class="row dmbs-top-menu visible-xs">
        <nav class="navbar" role="navigation">
            <div class="-container-">
				<div class="navbar-header navbar-inverse">
				    <div class="navbar-logo">
                        <a href="http://sdtimes.com/"><img src="/wp-content/uploads/2014/06/Logo_SDTimes_Mobile.png"></a>
                    </div>
                    <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-1-collapse">
				        <span class="sr-only">Toggle navigation</span>
				        <span class="icon-bar"></span>
				        <span class="icon-bar"></span>
				        <span class="icon-bar"></span>
				    </button>
				</div>
				<div class="collapse navbar-collapse navbar-1-collapse"><ul id="menu-main-desktop" class="nav navbar-nav"><li id="menu-item-5222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5222 dropdown"><a title="Features" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Features <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5789" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5789"><a title="In-Depth" href="http://sdtimes.com/category/in-depth/">In-Depth</a></li>
	<li id="menu-item-5371" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5371"><a title="Buyer&#039;s Guide" href="http://sdtimes.com/category/buyers-guide/">Buyer&#8217;s Guide</a></li>
	<li id="menu-item-5372" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5372"><a title="Special Report" href="http://sdtimes.com/category/special-report/">Special Report</a></li>
	<li id="menu-item-25475" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25475"><a title="SD Times 100" href="http://sdtimes.com/sd-times-100/sd-times-100-2017-youve-arrived/">SD Times 100</a></li>
	<li id="menu-item-9652" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9652"><a title="Industry Spotlight" href="http://sdtimes.com/category/industry-spotlight/">Industry Spotlight</a></li>
</ul>
</li>
<li id="menu-item-5039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5039 dropdown"><a title="SD Times Magazine" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">SD Times Magazine <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5161" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5161"><a title="Subscribe" href="http://assets.sdtimes.com/sdtimes-subscription">Subscribe</a></li>
	<li id="menu-item-5392" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5392"><a title="Download Issue" href="http://assets.sdtimes.com/download-latest-issue">Download Issue</a></li>
	<li id="menu-item-7272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7272"><a title="Back Issues" href="http://sdtimes.com/back-issues/">Back Issues</a></li>
	<li id="menu-item-5397" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5397"><a title="Working with the Editors" href="http://sdtimes.com/sd-times-magazine/working-with-the-editors/">Working with the Editors</a></li>
	<li id="menu-item-5414" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5414"><a title="Guest View Guidelines" href="http://sdtimes.com/sd-times-magazine/guest-view-guidelines/">Guest View Guidelines</a></li>
	<li id="menu-item-5430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5430"><a title="SD Times 100 Guide" href="http://sdtimes.com/sd-times-100/">SD Times 100 Guide</a></li>
	<li id="menu-item-5415" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5415"><a title="Advertise" href="http://sdtimes.com/sd-times-magazine/advertise/">Advertise</a></li>
</ul>
</li>
<li id="menu-item-5389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5389 dropdown"><a title="Learning Center" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Learning Center <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5701" class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5701"><a title="White Papers" href="http://sdtimes.com/sections/white-papers/">White Papers</a></li>
	<li id="menu-item-5704" class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5704"><a title="Webinars" href="http://sdtimes.com/sections/webinars/">Webinars</a></li>
	<li id="menu-item-5703" class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5703"><a title="Industry Profiles" href="http://sdtimes.com/sections/industry-profiles/">Industry Profiles</a></li>
</ul>
</li>
<li id="menu-item-5387" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5387 dropdown"><a title="Events" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Events <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5223" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5223"><a title="AnDevCon" target="_blank" href="http://www.andevcon.com/"><span class="glyphicon _blank"></span>&nbsp;AnDevCon</a></li>
	<li id="menu-item-11999" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11999"><a title="InterDrone" target="_blank" href="http://www.interdrone.com/"><span class="glyphicon _blank"></span>&nbsp;InterDrone</a></li>
	<li id="menu-item-5227" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5227"><a title="SPTechCon" target="_blank" href="http://www.sptechcon.com/"><span class="glyphicon _blank"></span>&nbsp;SPTechCon</a></li>
</ul>
</li>
<li id="menu-item-24360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24360"><a title="DevOps" href="/tag/devops/">DevOps</a></li>
</ul></div>			</div>
        </nav>
    </div>

<div class="container dmbs-container">
    <div class="adWrap">
        <div class="adWrapCenter">
            <div class="innerAdWrapCenter">
                <div class="fl">
                    			<div class="banner_ad gutter_ad_left">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/Gutter_left', [300, 1050], 'div-gpt-ad-1455057831195-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/Gutter_left -->
<div id='div-gpt-ad-1455057831195-0' style='height:1050px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1455057831195-0'); });
</script>
</div>				</div>
			</div>
			                </div>
                <div class="fr">
                    			<div class="banner_ad gutter_ad_right">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/Gutter_Right', [300, 1050], 'div-gpt-ad-1455057942067-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/Gutter_Right -->
<div id='div-gpt-ad-1455057942067-0' style='height:1050px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1455057942067-0'); });
</script>
</div>				</div>
			</div>
			                </div>
            </div>
        </div>
    </div>
    <div class="row dmbs-header hidden-xs">

        <div class="col-md-3 col-sm-4 dmbs-header-img">
            <a href="http://sdtimes.com/"><img src="http://sdtimes.com/wp-content/uploads/2014/05/LOGO_SDTimes.png" height="76" width="233" alt="" /></a>
        </div>

        <div class="col-md-9 col-sm-8 dmbs-header-text">
            <div class="top-ad leader-board">
				<div class="banner_ad top_leaderboard">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
 googletag.cmd.push(function() {
  googletag.defineSlot('/67541884/Leaderboard_Top_1', [728, 90], 'div-gpt-ad-1466026021929-0').addService(googletag.pubads());
  googletag.pubads().enableSingleRequest();
  googletag.enableServices();
 });
</script>

<!-- /67541884/Leaderboard_Top_1 -->
<div id='div-gpt-ad-1466026021929-0' style='height:90px; width:728px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026021929-0'); });
</script>
</div>				</div>
			</div>
			</div>        </div>

    </div>

    <div class="row nav-content hidden-xs">
        <div class="trending-box">
    <img src="/wp-content/themes/sdtimes2014/img/7-trending.png" />
    <!-- From cache --><ul><li><a href="http://sdtimes.com/smartbear-state-of-testing-2017/">SmartBear report: The future of software testing for developers, QA</a></li><li><a href="http://sdtimes.com/dev-oops-devops-efforts-fail/">Dev-Oops: Why DevOps efforts fail</a></li><li><a href="http://sdtimes.com/nginx-application-platform-app-development/">NGINX releases its new NGINX Application Platform</a></li><li><a href="http://sdtimes.com/evolving-state-middleware/">The evolving state of enterprise middleware</a></li><li><a href="http://sdtimes.com/scaling-agile/">Scaling Agile</a></li><li><a href="http://sdtimes.com/open-source-commercial-software-development-handle-care/">Open source for commercial software development: Handle with care</a></li><li><a href="http://sdtimes.com/impact-virtual-augmented-reality-corporate-developers/">The impact of virtual and augmented reality on corporate developers</a></li></ul></div>        <div id="nav-grouping-1" class="col-sm-10 padless">
            

    <div class="row dmbs-top-menu hidden-xs">
        <nav class="navbar" role="navigation">
            <div class="-container-">
                <div class="collapse navbar-collapse navbar-1-collapse"><ul id="menu-main-desktop-1" class="nav navbar-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5222 dropdown"><a title="Features" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Features <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5789"><a title="In-Depth" href="http://sdtimes.com/category/in-depth/">In-Depth</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5371"><a title="Buyer&#039;s Guide" href="http://sdtimes.com/category/buyers-guide/">Buyer&#8217;s Guide</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5372"><a title="Special Report" href="http://sdtimes.com/category/special-report/">Special Report</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25475"><a title="SD Times 100" href="http://sdtimes.com/sd-times-100/sd-times-100-2017-youve-arrived/">SD Times 100</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9652"><a title="Industry Spotlight" href="http://sdtimes.com/category/industry-spotlight/">Industry Spotlight</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5039 dropdown"><a title="SD Times Magazine" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">SD Times Magazine <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5161"><a title="Subscribe" href="http://assets.sdtimes.com/sdtimes-subscription">Subscribe</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5392"><a title="Download Issue" href="http://assets.sdtimes.com/download-latest-issue">Download Issue</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7272"><a title="Back Issues" href="http://sdtimes.com/back-issues/">Back Issues</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5397"><a title="Working with the Editors" href="http://sdtimes.com/sd-times-magazine/working-with-the-editors/">Working with the Editors</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5414"><a title="Guest View Guidelines" href="http://sdtimes.com/sd-times-magazine/guest-view-guidelines/">Guest View Guidelines</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5430"><a title="SD Times 100 Guide" href="http://sdtimes.com/sd-times-100/">SD Times 100 Guide</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5415"><a title="Advertise" href="http://sdtimes.com/sd-times-magazine/advertise/">Advertise</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5389 dropdown"><a title="Learning Center" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Learning Center <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5701"><a title="White Papers" href="http://sdtimes.com/sections/white-papers/">White Papers</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5704"><a title="Webinars" href="http://sdtimes.com/sections/webinars/">Webinars</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5703"><a title="Industry Profiles" href="http://sdtimes.com/sections/industry-profiles/">Industry Profiles</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5387 dropdown"><a title="Events" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Events <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5223"><a title="AnDevCon" target="_blank" href="http://www.andevcon.com/"><span class="glyphicon _blank"></span>&nbsp;AnDevCon</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11999"><a title="InterDrone" target="_blank" href="http://www.interdrone.com/"><span class="glyphicon _blank"></span>&nbsp;InterDrone</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5227"><a title="SPTechCon" target="_blank" href="http://www.sptechcon.com/"><span class="glyphicon _blank"></span>&nbsp;SPTechCon</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24360"><a title="DevOps" href="/tag/devops/">DevOps</a></li>
</ul></div>            </div>
        </nav>
    </div>

            <div class="ticker">
	<div>
		<span>Thu. Sep 07</span> - &nbsp;
	</div>
	<div class="news">
		<div><a href="http://sdtimes.com/linux-typescript-oma-ocf-news-sdtimes/" rel="bookmark" title="Permalink to SD Times news digest: Linux kernel 4.13, OCF and OMA team up for IoT, and TypeScript 2.5">SD Times news digest: Linux kernel 4.13, OCF and OMA&hellip;</a></div><div><a href="http://sdtimes.com/nginx-application-platform-app-development/" rel="bookmark" title="Permalink to NGINX releases application platform with new application server, centralized management tools">NGINX releases application platform with new application server, centralized management&hellip;</a></div><div><a href="http://sdtimes.com/oracle-proposes-changes-java-release-cycle/" rel="bookmark" title="Permalink to Oracle proposes changes to Java release cycle">Oracle proposes changes to Java release cycle</a></div><div><a href="http://sdtimes.com/smartbear-state-of-testing-2017/" rel="bookmark" title="Permalink to SmartBear State of Testing 2017: The future of software testing for developers, QA">SmartBear State of Testing 2017: The future of software testing&hellip;</a></div>	</div>
</div>
<script type="text/javascript">
(function ($) {

	var fade = 1000;
	var restart_pause = 2000;
	var pause = 6000;
	function fadingScroller($el) {
		$el.animate({'opacity': 0}, fade);
		$el.hide('slow', function () {
			$el.parent().append($el);
			$el.show();
			$el.animate({'opacity': 1}, restart_pause);
			setTimeout(function ($el) {
				return function () {
					fadingScroller($($el.selector));
				};
			}($el), pause);
		});
	}
	fadingScroller($('.ticker div div:first'));
})(jQuery);
</script>        </div>
        <div id="nav-grouping-2" class="col-sm-10 hidden-xs padless">
            <div class="social">
	<ul>
		<li><a class="fa fa-facebook" href="https://www.facebook.com/SDTimesD2"></a></li>
		<li><a class="fa fa-twitter" href="http://www.twitter.com/sdtimes"></a></li>
	</ul>
</div>            <div id="top-search-form">
	<form role="search" method="get" id="searchform" class="searchform" action="http://sdtimes.com/">
		<div>
			<div class="col-md-9 col-sm-10 padless"><input type="text" class="queryly" value="" name="s" id="s"><script type="text/javascript">queryly.QuerylyBind();</script></div>
			<div class="col-md-3 col-sm-2 padless search-point"><input type="submit" id="searchsubmit" value="Search"></div>
			<div class="clearfix"></div>
		</div>
	</form>
</div>        </div>
    </div>


<!-- start content container -->
<div class="row dmbs-content">

		
	<div class="col-md-8 dmbs-main col-xs-12 col-sm-7 hnews hentry item">

			
						<div class="post-26948 post type-post status-publish format-standard has-post-thumbnail hentry category-latest-news tag-java tag-openjdk tag-oracle">

							<h1 class="page-header">Oracle proposes changes to Java release cycle</h1>

								<div class="postmeta">
			<span class="categories"><a href="http://sdtimes.com/category/latest-news/" rel="category tag">Latest News</a></span>
			<div class="published">Published: <span class="updated">September 6th, 2017</span></div>
			- <span class="author-bio"><a href="http://sdtimes.com/author/david-rubinstein/" title="Posts by David Rubinstein" rel="author">David Rubinstein</a></span>
				</div>

							<div>
								<div class="row">
									<div class="col-md-3">
										<div class="social"><!-- filled dynamically --></div>
										<div class="tags">
																							<h3>Article Tags</h3>
												<p>
												<a href="http://sdtimes.com/tag/java/" rel="tag">Java</a>, <a href="http://sdtimes.com/tag/openjdk/" rel="tag">OpenJDK</a>, <a href="http://sdtimes.com/tag/oracle/" rel="tag">Oracle</a>												</p>
																					</div>

										<div>
																					</div>
									</div>
									<div class="col-md-9 postContent">
																					<img width="490" height="327" src="http://sdtimes.com/wp-content/uploads/2017/09/romain-peli-266995.jpg" class="attachment-post-content-thumb size-post-content-thumb wp-post-image" alt="Photo by Romain Peli on Unsplash" /><div class="caption"></div>																				<p><span style="font-weight: 400;">Oracle is proposing to move to an every-six-months release cycle for Java SE and the JDK, beginning with the release of Java 9, the company announced today. Java is currently on a less agile, feature-driven release model.</span></p>
<p><span style="font-weight: 400;">The plan would be to have a time-based major release every six months, starting in March 2018, according to a blog post by Mark Reinhold, chief architect of the Java Platform Group at Oracle. Major releases could include any type of new feature; however, he indicated the new feature would not be merged until it’s nearly complete, ensuring that the release in development is feature-complete at all times. “In this type of model the development process is a continuous pipeline of innovation that’s only loosely couple to the actual release process, which itself has a constant cadence,” Reinhold wrote. “Any particular feature, large or small, is merged only when it’s nearly finished. If a feature misses the current train then that’s unfortunate but it’s not the end of the world, since the next train will already be waiting and will also leave on schedule.”</span></p>
<p>Reinhold further explained that the main development line will be forked into a release-stabilization branch three months before the GA of the next major release</p>
<p><span style="font-weight: 400;">Update releases will occur every quarter, and a long-term support release will be made every three years, beginning in September 2018. The versions of major releases will be numbered by year and month, so the release next March will be 18.3 and September’s will be 18.9, he explained.</p>
<p><strong>(RELATED: <a href="http://sdtimes.com/oracle-opens-java-ee/" target="_blank" rel="noopener noreferrer">Oracle opens up Java EE</a>)</strong><br />
</span></p>
<p><span style="font-weight: 400;">Reinhold acknowledged the change in release cycles will necessitate changes in how the OpenJDK community works, and he called for a reduction in the overhead of the Java Community Process.</span></p>
<p><span style="font-weight: 400;">In an email to OpenJDK contributors, Reinhold proposed two long-running JDK projects – one for releases, and one for updates – which he said would cut down on administrative overhead and eliminate confusion for contributors. </span></p>
<p><span style="font-weight: 400;">To facilitate these changes, Reinhold said Oracle will ship OpenJDK builds under the GPL, so developers can more easily deploy their applications in the cloud. This will begin with the JDK 9 release. Oracle JDK builds will continue to ship and include features such as Java Flight recorder and Mission Control, and Oracle will continue to offer paid support. After JDK 9, Oracle will release those proprietary features to open source, with the purpose of reducing differences between the OpenJDK and Oracle JDK builds and ultimately making them interchangeable.</span></p>
<p><span style="font-weight: 400;">Oracle also will work with OpenJDK contributors to create an open infrastructure for build and test, enabling early access to builds for new features. And, the company is making its build, test and distribution binaries available under the GPL v2+classpath; previously they were only available under a commercial license. </span></p>
<p><span style="font-weight: 400;">The move from feature-based to time-based releases is a response to how people consume technology today – in many short, iterative releases. “Twenty years ago, when Java was originally created, people were used to platforms moving slowly, and it took a long time for people to move onto them when they came out,” Georges Saab, vice president of software development in Oracle’s Java Platform Group, told SD Times. “Today, people want to know they’re running on a platform that’s evolving and responding to new challenges they need help on.”</span></p>
<p><span style="font-weight: 400;">Innovation has happened more quickly in Java than it appears. Saab said, “With both [JDK] 8 and 9, we had major features we wanted to get right, but the flip side is that other innovations within those releases were help up. They were ready for 9, some for more than a year, but couldn’t be released until [modularity Project] Jigsaw was done.”</span></p>
<p><span style="font-weight: 400;">Jigsaw, Saab explained, provides the JDK with encapsulation, which can help developers ensure changes made to the code are forward-compatible, and that is what Oracle saw as the driver to accelerated release cycles.</span></p>
<p><span style="font-weight: 400;">For some who might speculate that Oracle is loosening its grip over the future and direction of Java, Saab pointed out that “Java SE was open-sourced many years ago by Sun. The implementation in OpenJDK is one we’ve been collaborating on with companies and individuals for a decade.”</span></p>
<p><span style="font-weight: 400;">Saab acknowledged that some people wonder what Oracle’s strategy is regarding OracleJDK. “We want to make OpenJDK just like any other open-source project you see. We want to see the rapid innovation in the latest builds. But if you have something you want to put into production and know it’s stable and has support from Oracle … you look at Oracle JDK  as a potential offering.”</span></p>

				<div class="mr_social_sharing_wrapper">
				<!-- Social Sharing Toolkit v2.2 --></div>
										
										<div class="row padless share-after-content">
	<div class="col-md-6 col-sm-12">
				<div class="">
			<div class="col-md-12 col-sm-6 padless" style="height:9px">
				<span style="display: inline-block; width: 90px; height: 21px; overflow: hidden;"><div class="fb-like" data-href="http://sdtimes.com/oracle-proposes-changes-java-release-cycle/" data-send="false" data-layout="button_count" data-width="90" data-show-faces="false"></div></span>			</div>
			<div class="col-md-12 col-sm-6 padless" style="white-space:nowrap">
				<span><a class="mr_social_share_facebook" href="//www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fsdtimes.com%2Foracle-proposes-changes-java-release-cycle%2F&amp;t=Oracle+proposes+changes+to+Java+release+cycle" class="mr_social_sharing_popup_link"><img src="/images/social-icons/facebook-button.png" class="nopin" alt="Share on Facebook" title="Share on Facebook"/></a></span> <span><a class="mr_social_share_twitter" href="https://twitter.com/share?url=http%3A%2F%2Fsdtimes.com%2Foracle-proposes-changes-java-release-cycle%2F&amp;text=Oracle+proposes+changes+to+Java+release+cycle" class="mr_social_sharing_popup_link"><img src="/images/social-icons/tweet-button.png" class="nopin" alt="Share on Twitter" title="Share on Twitter"/></a></span> <span><a class="mr_social_share_email" href="mailto:?subject=Oracle proposes changes to Java release cycle&amp;body=http://sdtimes.com/oracle-proposes-changes-java-release-cycle/" target="_blank"><img src="/images/social-icons/email-button.png" class="nopin" alt="Share via email" title="Share via email"/></a></span>
			</div>
		</div>
			</div>
	<div class="col-md-6 col-sm-12 subscribe-form">
		<h4 class="col-md-12 col-sm-6 padless"><a href="http://resources.sdtimes.com/sdtimes-subscription?__hstc=54983092.b1c3fc9f788d79895403cd04467299f2.1402689135055.1402689135055.1404158676313.2&__hssc=54983092.2.1404218565731&__hsfp=2368551689">Subscribe to SDTimes</a></h4>
		<!--<div id="subscribe-hubspot-form-wrapper" class="col-sm-6">
			<form role="search" method="get" id="subscribe-hubspot-form" class="subscribeform" action="">
				<div>
					<div class="col-md-7 col-sm-7 padless"><input type="text" value="" name="email" id="email"></div>
					<div class="col-md-5 col-sm-3 padless search-point"><input type="submit" id="subscribesubmit" value="Subscribe"></div>
					<div class="clearfix"></div>
				</div>
			</form>
		</div>-->
	</div>
	<div class="clearfix"></div>
</div><div class="authorarea">
	<img src="http://sdtimes.com/wp-content/uploads/2014/12/RUBINSTEINDAVE.jpg" />	<h3>About David Rubinstein</h3>
	<div class="authorinfo">
		David Rubinstein is editor-in-chief of <a href="/">SD Times</a>.	</div>
	<a class="author-link" href="http://sdtimes.com/author/david-rubinstein/" rel="author">View all posts by David Rubinstein</a>
	<div class="clearfix"></div>
</div>									</div>									<script type="text/javascript">

jQuery('#slider-header img').attr('width', '100%').attr('height', 'auto');



jQuery('.postContent img').each(function () {
	var img = jQuery(this).attr('src');

	if(checkForImage(img) == true) {
		jQuery(this).removeAttr('width').removeAttr('height');
	}
});

function checkForImage(url) {
    return(url.match(/\.(jpeg|jpg|gif|png)$/) != null);
}
</script>										<div class="padless related-posts">
		<h2>Related Articles</h2>
	
		<div class="col-md-3">
							<img width="150" height="78" src="http://sdtimes.com/wp-content/uploads/2017/08/java9-meta.png" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="http://www.java9countdown.xyz/" />						<h3 class="title">
				<a href="http://sdtimes.com/jdk-9-almost/" title="Permalink to JDK 9 is almost here. Again." rel="bookmark">JDK 9 is almost here. Again.</a>
			</h3>
		</div>

		<div class="col-md-3">
							<img width="150" height="64" src="http://sdtimes.com/wp-content/uploads/2017/08/javaee1.png" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="Java EE" />						<h3 class="title">
				<a href="http://sdtimes.com/oracle-opens-java-ee/" title="Permalink to Oracle opens up Java EE" rel="bookmark">Oracle opens up Java EE</a>
			</h3>
		</div>

		<div class="col-md-3">
							<img width="150" height="73" src="http://sdtimes.com/wp-content/uploads/2017/08/Screen-Shot-2017-08-15-at-1.35.54-PM.png" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" />						<h3 class="title">
				<a href="http://sdtimes.com/oracle-open-source-library-sdtimes/" title="Permalink to Oracle Open Source Library now available to C and C++ developers" rel="bookmark">Oracle Open Source Library now available to C and C++ developers</a>
			</h3>
		</div>

		<div class="col-md-3">
							<img width="150" height="73" src="http://sdtimes.com/wp-content/uploads/2017/07/CodePush-joins-VSMC-Imgae-for-video.png" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" />						<h3 class="title">
				<a href="http://sdtimes.com/codepush-comes-microsofts-visual-studio-mobile-center/" title="Permalink to CodePush comes to Microsoft&#8217;s Visual Studio Mobile Center" rel="bookmark">CodePush comes to Microsoft&#8217;s Visual Studio Mobile Center</a>
			</h3>
		</div>
	</div>
								</div>
							</div>

							    <div class="clear"></div>
    <div class="dmbs-comments">
    <a name="comments"></a>
                    <div class="well">	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/oracle-proposes-changes-java-release-cycle/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://sdtimes.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='26948' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><input type='hidden' id='ct_checkjs_85fc37b18c57097425b52fc7afbb6969' name='ct_checkjs' value='0' /><script type='text/javascript'>setTimeout(function(){var ct_input_name = 'ct_checkjs_85fc37b18c57097425b52fc7afbb6969';if (document.getElementById(ct_input_name) !== null) {var ct_input_value = document.getElementById(ct_input_name).value;document.getElementById(ct_input_name).value = document.getElementById(ct_input_name).value.replace(ct_input_value, '74390621');}}, 1000);</script>			</form>
			</div><!-- #respond -->
	</div>
               </div>

						</div>

												
   </div>

          <div class="col-md-4 dmbs-right col-xs-12 hidden-xs col-sm-5 padless">
        			<div class="banner_ad medrec_1_ad">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/med_rec_1', [300, 250], 'div-gpt-ad-1466026216582-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/med_rec_1 -->
<div id='div-gpt-ad-1466026216582-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026216582-0'); }); 
</script>
</div>				</div>
			</div>
			<aside id="foo_widget-2" class="widget widget_foo_widget"></aside>			<div class="banner_ad medrec_2_ad">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/med_rec_2', [300, 250], 'div-gpt-ad-1466026338843-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/med_rec_2 -->
<div id='div-gpt-ad-1466026338843-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026338843-0'); });
</script>
</div>				</div>
			</div>
			<aside id="trending-stories-widget-2" class="widget trending-stories-widget"><h3></h3><div style="text-align:center; margin: 0 auto;">
<div style="width:300px; text-align:center; margin: 0 auto;">

	<div id="trending">

		<div class="trendinghead">
			<h2><strong>The 7</strong> Trending Stories</h2>
		</div>
		<!-- From cache -->		<div class="feeds">
			<ul>
												<div class="thm">
					<a href="http://sdtimes.com/smartbear-state-of-testing-2017/"><img width="300" height="112" src="http://sdtimes.com/wp-content/uploads/2017/09/Screen-Shot-2017-09-05-at-1.28.41-PM.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" /></a>
				</div>
				<li class="trend-first">
					<span>1</span>
					<div style="min-height:25px;">
						<a href="http://sdtimes.com/smartbear-state-of-testing-2017/">
							SmartBear report: The future of software testing for developers, QA						</a>
					</div>
				</li>
												<li>
					<span>2</span>
						<img width="67" height="50" src="http://sdtimes.com/wp-content/uploads/2017/08/oops-1444975_1920.jpg" class="attachment-trending-small size-trending-small wp-post-image" alt="" />					<div style="min-height:25px;">
						<a href="http://sdtimes.com/dev-oops-devops-efforts-fail/">
							Dev-Oops: Why DevOps efforts fail						</a>
					</div>
				</li>
												<li>
					<span>3</span>
						<img width="89" height="50" src="http://sdtimes.com/wp-content/uploads/2017/09/NGINX.png" class="attachment-trending-small size-trending-small wp-post-image" alt="NGINX" />					<div style="min-height:25px;">
						<a href="http://sdtimes.com/nginx-application-platform-app-development/">
							NGINX releases its new NGINX Application Platform						</a>
					</div>
				</li>
												<li>
					<span>4</span>
						<img width="75" height="50" src="http://sdtimes.com/wp-content/uploads/2017/08/pexels-photo-37728.jpeg" class="attachment-trending-small size-trending-small wp-post-image" alt="" />					<div style="min-height:25px;">
						<a href="http://sdtimes.com/evolving-state-middleware/">
							The evolving state of enterprise middleware						</a>
					</div>
				</li>
												<li>
					<span>5</span>
						<img width="75" height="50" src="http://sdtimes.com/wp-content/uploads/2017/08/pexels-photo-357891.jpeg" class="attachment-trending-small size-trending-small wp-post-image" alt="" />					<div style="min-height:25px;">
						<a href="http://sdtimes.com/scaling-agile/">
							Scaling Agile						</a>
					</div>
				</li>
												<li>
					<span>6</span>
						<img width="75" height="50" src="http://sdtimes.com/wp-content/uploads/2017/08/pexels-photo-14303.jpeg" class="attachment-trending-small size-trending-small wp-post-image" alt="" />					<div style="min-height:25px;">
						<a href="http://sdtimes.com/open-source-commercial-software-development-handle-care/">
							Open source for commercial software development: Handle with care						</a>
					</div>
				</li>
												<li>
					<span>7</span>
						<img width="75" height="50" src="http://sdtimes.com/wp-content/uploads/2017/08/pexels-photo-123335.jpeg" class="attachment-trending-small size-trending-small wp-post-image" alt="" />					<div style="min-height:25px;">
						<a href="http://sdtimes.com/impact-virtual-augmented-reality-corporate-developers/">
							The impact of virtual and augmented reality on corporate developers						</a>
					</div>
				</li>
							</ul>
		</div>

	</div>

</div>
</div></aside>			<div class="banner_ad medrec_3_ad">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/Med_Rec_3', [300, 250], 'div-gpt-ad-1466026398056-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/Med_Rec_3 -->
<div id='div-gpt-ad-1466026398056-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026398056-0'); });
</script>
</div>				</div>
			</div>
						<div class="banner_ad medrec_4_ad">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/Med_Rec_4', [300, 250], 'div-gpt-ad-1466026534122-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/Med_Rec_4 -->
<div id='div-gpt-ad-1466026534122-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026534122-0'); });
</script>
</div>				</div>
			</div>
						<div class="banner_ad medrec_5_ad">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
  googletag.defineSlot('/67541884/med_rec_5', [300, 250], 'div-gpt-ad-1466026594130-0').addService(googletag.pubads());
  googletag.pubads().enableSingleRequest();
  googletag.enableServices();
 });
</script>

<!-- /67541884/med_rec_5 -->
<div id='div-gpt-ad-1466026594130-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026594130-0'); }); 
</script>
</div>				</div>
			</div>
						<div class="banner_ad medrec_6_ad">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/med_rec_6', [300, 250], 'div-gpt-ad-1466026679557-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/med_rec_6 -->
<div id='div-gpt-ad-1466026679557-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026679557-0'); });
</script>
</div>				</div>
			</div>
			    </div>

   <div class="col-md-12 col-sm-12 padless">
   		<div class="col-md-12 padless banner_ad bottom-leaderboard">
   						<div class="banner_ad bottom_leaderboard">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/leader_1_bottom', [728, 90], 'div-gpt-ad-1466028372866-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/leader_1_bottom -->
<div id='div-gpt-ad-1466028372866-0' style='height:90px; width:728px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466028372866-0'); });
</script>
</div>				</div>
			</div>
			   		</div>
   </div>

   <div class="col-md-12 col-sm-12 padless">
      <div class="col-md-12 padless banner_ad bottom-leaderboard">
        			<div class="banner_ad bottom_leaderboard_2">
				<div class="banner_ad_wrapper">
					<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/leader_2_bottom', [728, 90], 'div-gpt-ad-1466028474085-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/leader_2_bottom -->
<div id='div-gpt-ad-1466028474085-0' style='height:90px; width:728px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466028474085-0'); });
</script>
</div>				</div>
			</div>
			      </div>
   </div>

</div>
<!-- end content container -->

    <div class="dmbs-footer">
        
        	<div class="dmbs-footer-menu">
			<nav class="navbar navbar-inverse full-footer" role="navigation">
				<div class="container">
					<div class="navbar-header">
						<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-2-collapse">
							<span class="sr-only">Toggle navigation</span>
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
						</button>
					</div>
					<div class="row padless">
						<div class="col-md-4 col-sm-4">
							<aside id="nav_menu-3" class="widget widget_nav_menu"><h3>SD Times</h3><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-5041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5041"><a title="_blank" href="https://d2emerge.com/">About Us</a></li>
<li id="menu-item-5418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5418"><a title="_blank" href="https://d2emerge.com/about/">Contact Us</a></li>
<li id="menu-item-5419" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5419"><a href="http://sdtimes.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-5045" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5045"><a href="http://sdtimes.com/site-map/">Site Map</a></li>
<li id="menu-item-5047" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5047"><a href="http://sdtimes.com/sd-times-magazine/advertise/">Advertise</a></li>
<li id="menu-item-5160" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5160"><a href="http://assets.sdtimes.com/sdtimes-subscription">Subscribe</a></li>
</ul></div></aside>						</div>
						<div class="col-md-4">
							<aside id="text-2" class="widget widget_text"><h3>Follow @SDTimes</h3>			<div class="textwidget"><a class="twitter-timeline" href="https://twitter.com/sdtimes" data-widget-id="472430906574004224">Tweets by @sdtimes</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div>
		</aside>						</div>
						<div class="col-md-4">
							<aside id="sdtimes-subscribe-widget-2" class="widget sdtimes-subscribe-widget"><h3></h3><div style="text-align:center; margin: 0 auto;">
	<div style="text-align:center; margin: 0 auto;">

		<div id="subscribe">

			
			<div class="title">Subscribe to SD Times</div>
			<div class="sdtimessubscribe">
				<div class="left">
					<a href="http://assets.sdtimes.com/download-latest-issue" target="_blank"><img width="120" height="162" src="http://sdtimes.com/wp-content/uploads/2017/08/get_image-1.jpeg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" /></a>				</div>
				<div class="left links">
					<a href="http://assets.sdtimes.com/download-latest-issue" target="_blank">Download Current Issue <span>&#x25b6;</span></a>					<br />
					<a href="http://sdtimes.com/back-issues/" target="_blank">Download Back Issues <span>&#x25b6;</span></a>				</div>
				<div class="clear"></div>
				<div class="smallertext">
					<span>Subscribe to SD Times print magazine</span>
					<br />
					<p>Ready for your SD Times magazine? It's just a few clicks away!</p>				</div>

				<p><a class="button" href="http://assets.sdtimes.com/sdtimes-subscription">Subscribe</a></p>
			</div>

		</div>

	</div>
</div></aside>						</div>
					</div>
				</div>
			</nav>
			<div class="footer-credit">
				<div class="col-md-2 copyright">&copy; 2017 D2 Emerge LLC.</div>
				<div class="col-md-8 min-footer-menu">
					<aside id="nav_menu-2" class="widget widget_nav_menu"><div class="menu-footer-mini-menu-container"><ul id="menu-footer-mini-menu" class="menu"><li id="menu-item-6911" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6911"><a href="http://assets.sdtimes.com/sdtimes-subscription">Subscribe</a></li>
<li id="menu-item-26413" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26413"><a href="https://d2emerge.com/about/">Contact Us</a></li>
<li id="menu-item-5065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5065"><a href="http://sdtimes.com/site-map/">Site Map</a></li>
<li id="menu-item-5066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5066"><a href="http://sdtimes.com/privacy-policy/">Privacy Policy</a></li>
</ul></div></aside>				</div>
				<div class="col-md-2"><div class="social">
	<ul>
		<li><a class="fa fa-facebook" href="https://www.facebook.com/SDTimesD2"></a></li>
		<li><a class="fa fa-twitter" href="http://www.twitter.com/sdtimes"></a></li>
	</ul>
</div></div>
				<div class="clearfix"></div>
			</div>
	</div>
    </div>

</div>
<!-- end main container -->

<script type='text/javascript'>function ctSetCookie(c_name, value, def_value){document.cookie = c_name + '=' + escape(value) + '; path=/';}ctSetCookie('ct_checkjs', '74390621', '0');</script><script type="text/javascript">
	jQuery('a[title="_blank"]').each(
			function(i) {
				jQuery(this).attr('target', '_blank');
				jQuery(this).attr('title', jQuery(this).text());
			}
		);
</script> <div style="width:100%;text-align:center; font-size:11px; clear:both"><a target="_blank" title="Insert HTML Snippet Wordpress Plugin" href="http://xyzscripts.com/wordpress-plugins/insert-html-snippet/">HTML Snippets</a> Powered By : <a target="_blank" title="PHP Scripts & Wordpress Plugins" href="http://www.xyzscripts.com" >XYZScripts.com</a></div>	<script type="text/javascript">var switchTo5x=true;</script>
	<script type="text/javascript" src="http://w.sharethis.com/button/buttons.js"></script>
	<script type="text/javascript">stLight.options({publisher: "ur-84fe4080-bc54-11f3-8dd8-4c4036217b0c", doNotHash: false, doNotCopy: false, hashAddressBar: false});</script><script type='text/javascript'>
/* <![CDATA[ */
var ctNocache = {"ajaxurl":"http:\/\/sdtimes.com\/wp-admin\/admin-ajax.php","info_flag":"","set_cookies_flag":"1","blog_home":"http:\/\/sdtimes.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://sdtimes.com/wp-content/plugins/cleantalk-spam-protect/inc/cleantalk_nocache.js?ver=5.72'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-content/themes/sdtimes2014/js/fusionfarm-bootstrap-responsive.js?ver=1.0'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-content/themes/devdmbootstrap3/js/bootstrap.js?ver=1.40'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=2.9.8'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-content/plugins/social-sharing-toolkit/script_2.1.2.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://sdtimes.com/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>
<!-- Clicky Web Analytics - https://clicky.com, WordPress Plugin by Yoast - https://yoast.com/wordpress/plugins/clicky/ --><script type='text/javascript'>
	function clicky_gc(name) {
		var ca = document.cookie.split(';');
		for (var i in ca) {
			if (ca[i].indexOf(name + '=') != -1) {
				return decodeURIComponent(ca[i].split('=')[1]);
			}
		}
		return '';
	}
	var username_check = clicky_gc('comment_author_6c445563c161f4fa086dd6ff78194eb2');
	if (username_check) var clicky_custom_session = {username: username_check};
</script>
<script type="text/javascript">
		var clicky = { log : function () { return true;	}, goal: function () { return true;	} };
	var clicky_site_id = 100754890;
	(function () {
		var s = document.createElement('script');s.type = 'text/javascript';s.async = true;s.src = '//static.getclicky.com/js';
		( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild(s);
	})();
</script>
<noscript><p><img alt="Clicky" width="1" height="1" src="//in.getclicky.com/100754890ns.gif" /></p></noscript>

				<div class="mr_social_sharing_wrapper">
				<!-- Social Sharing Toolkit v2.2 --><div class="mr_social_sharing_top"><a class="mr_social_share_facebook" href="//www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fsdtimes.com%2Foracle-proposes-changes-java-release-cycle%2F&amp;t=Oracle+proposes+changes+to+Java+release+cycle" class="mr_social_sharing_popup_link"><img src="/images/social-icons/facebook.png" class="nopin" alt="Share on Facebook" title="Share on Facebook"/></a></div><div class="mr_social_sharing_top"><a class="mr_social_share_twitter" href="https://twitter.com/share?url=http%3A%2F%2Fsdtimes.com%2Foracle-proposes-changes-java-release-cycle%2F&amp;text=Oracle+proposes+changes+to+Java+release+cycle" class="mr_social_sharing_popup_link"><img src="/images/social-icons/twitter.png" class="nopin" alt="Share on Twitter" title="Share on Twitter"/></a></div><div class="mr_social_sharing_top"><a class="mr_social_share_googleplus" href="//plusone.google.com/_/+1/confirm?hl=en&amp;url=http%3A%2F%2Fsdtimes.com%2Foracle-proposes-changes-java-release-cycle%2F&amp;title=Oracle+proposes+changes+to+Java+release+cycle" class="mr_social_sharing_popup_link"><img src="/images/social-icons/googleplus.png" class="nopin" alt="+1" title="+1"/></a></div><div class="mr_social_sharing_top"><a class="mr_social_share_linkedin" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fsdtimes.com%2Foracle-proposes-changes-java-release-cycle%2F&amp;title=Oracle+proposes+changes+to+Java+release+cycle" class="mr_social_sharing_popup_link"><img src="/images/social-icons/linkedin.png" class="nopin" alt="Share on LinkedIn" title="Share on LinkedIn"/></a></div><div class="mr_social_sharing_top"><a class="mr_social_share_email" href="mailto:?subject=Oracle proposes changes to Java release cycle&amp;body=http://sdtimes.com/oracle-proposes-changes-java-release-cycle/" target="_blank"><img src="/images/social-icons/email.png" class="nopin" alt="Share via email" title="Share via email"/></a></div><span class="mr_social_sharing"><a rel="nofollow" class="linksalpha_button linksalpha_link" href="//www.linksalpha.com/social/mobile" data-url="http://sdtimes.com/oracle-proposes-changes-java-release-cycle/" data-text="Oracle proposes changes to Java release cycle" data-desc="Oracle is proposing to move to an every-six-months release cycle for Java SE and the JDK, beginning with the release of Java 9, the company announced today. Java is currently on a less agile, feature-driven release model. The plan would be to have a time-based major release every six months," data-image="http://sdtimes.com/wp-content/uploads/2017/09/romain-peli-266995.jpg" data-button="icon_medium">
					<img src="//www.linksalpha.com/images/social_share_icon_medium.png" alt="Share" class="linksalpha_image" />
					</a><script type="text/javascript" src="//www.linksalpha.com/scripts/loader_iconbox.js?v=2.3"></script></span></div>		<script type="text/javascript">
			jQuery(window).ready(function() {
				jQuery('span.mr_social_sharing > a > img').attr('src', '/images/social-icons/share.png');
				social_sidebar = jQuery('.hentry .social');
				social_elem = jQuery('.mr_social_sharing');
				social_share_wrapper = jQuery('.mr_social_sharing_wrapper');
				social_sidebar.append(social_share_wrapper);
				social_sidebar.prepend(social_elem);
			});
		</script>
	<!-- START Fusionfarm/Hubspot API -- subscription popup -->
<!-- PLACE THIS IN THE <head> OF EVERY PAGE THAT YOU WANT THE POPUP -->
<link rel="stylesheet" href="/hubspot-api/Fusionfarm/colorbox/example1/colorbox.css">
<script type="text/javascript" src="/hubspot-api/Fusionfarm/sdtimes-offer-popup.js.php"></script>
<script type="text/javascript">

(function($) {
    $(document).ready(function(){

        var base_url = 'http://sdtimes.com';  // without trailing /

        //Fusionfarm.test.init('xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'); // Test by adding cookie value of hubspotutk
        /* SET THE FULL URL TO THE MAIN SERVERSIDE SCRIPT /hubspot-api/Fusionfarm/get-subscription.php */
        Fusionfarm.base_url = base_url;
        Fusionfarm.Hubspot.API.get_subscript_url = base_url + '/hubspot-api/Fusionfarm/get-subscription.php';
        Fusionfarm.Hubspot.API.get_offerdeclined_url = base_url + '/hubspot-api/Fusionfarm/declined-offer.php';
        Fusionfarm.setup_events();
    });
})(jQuery);



function downloadJSAtOnload() {
var element = document.createElement("script");
element.src = "/hubspot-api/Fusionfarm/colorbox/jquery.colorbox.js";
document.body.appendChild(element);
}
if (window.addEventListener)
window.addEventListener("load", downloadJSAtOnload, false);
else if (window.attachEvent)
window.attachEvent("onload", downloadJSAtOnload);
else window.onload = downloadJSAtOnload;


</script>
<!-- END Fusionfarm/Hubspot API -- subscription popup --><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"237c3e91d7","applicationID":"12810909","transactionName":"YlJQMhQDWkEDBxcPXFsYcwUSC1tcTRcKCFRZUg==","queueTime":0,"applicationTime":436,"atts":"ThVTRFwZSU8=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>