<!DOCTYPE html>
<html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"  prefix="og: http://ogp.me/ns#">
<head>
    <meta http-equiv="content-type" content="text/html; charset=UTF-8" />
    <meta name="description" content="Software Development News" />
    <title>Google unveils the next version of Android - SD Times</title>
    <meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">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</script>
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <link rel="pingback" href="https://sdtimes.com/xmlrpc.php" />
    <script type='text/javascript'>function ctSetCookie(c_name, value, def_value){document.cookie = c_name + '=' + escape(value) + '; path=/';}ctSetCookie('ct_checkjs', '1711638926', '0');</script>
<!-- This site is optimized with the Yoast SEO plugin v9.7 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Android Q now available for early adopters on Pixel devices and developers through a preview SDK"/>
<link rel="canonical" href="https://sdtimes.com/goog/google-unveils-the-next-version-of-android/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Google unveils the next version of Android - SD Times" />
<meta property="og:description" content="Android Q now available for early adopters on Pixel devices and developers through a preview SDK" />
<meta property="og:url" content="https://sdtimes.com/goog/google-unveils-the-next-version-of-android/" />
<meta property="og:site_name" content="SD Times" />
<meta property="article:publisher" content="https://www.facebook.com/SDTimesD2" />
<meta property="article:tag" content="Android" />
<meta property="article:tag" content="Android Q" />
<meta property="article:tag" content="Google" />
<meta property="article:section" content="Latest News" />
<meta property="article:published_time" content="2019-03-13T20:52:08+00:00" />
<meta property="og:image" content="https://sdtimes.com/wp-content/uploads/2019/03/image5.png" />
<meta property="og:image:secure_url" content="https://sdtimes.com/wp-content/uploads/2019/03/image5.png" />
<meta property="og:image:width" content="1139" />
<meta property="og:image:height" content="1600" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Android Q now available for early adopters on Pixel devices and developers through a preview SDK" />
<meta name="twitter:title" content="Google unveils the next version of Android - SD Times" />
<meta name="twitter:site" content="@sdtimes" />
<meta name="twitter:image" content="https://sdtimes.com/wp-content/uploads/2019/03/image5.png" />
<meta name="twitter:creator" content="@chriscatdoza" />
<script type='application/ld+json'>{"@context":"https://schema.org","@type":"Organization","url":"https://sdtimes.com/","sameAs":["https://www.facebook.com/SDTimesD2","https://twitter.com/sdtimes"],"@id":"https://sdtimes.com/#organization","name":"SD Times","logo":"https://sdtimes.com/wp-content/uploads/2014/05/deafaultlogo.png"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SD Times &raquo; Feed" href="https://sdtimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="SD Times &raquo; Comments Feed" href="https://sdtimes.com/comments/feed/" />
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-M8DVS3N');</script>
<!-- End Google Tag Manager -->		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/sdtimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.9"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='sdtimes-lesscss-css'  href='https://sdtimes.com/wp-content/themes/sdtimes2014/css/sdtimes.css?20180611&#038;ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Source+Sans+Pro%3A300%2C400%2C600%2C700%2C600italic%7CLato%3A400%2C700%7CBitter%3A400%2C700&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-fonts-css'  href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='lity-css-css'  href='//cdnjs.cloudflare.com/ajax/libs/lity/2.3.1/lity.min.css?ver=2.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://sdtimes.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=4.9.9' type='text/css' media='all' />
<script type='text/javascript' src='https://s7.addthis.com/js/300/addthis_widget.js?ver=4.9.9#pubid=wp-4417f7f776d9c2ffd08ba9868d73e669'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctPublic = {"_ajax_nonce":"c451f195e7","_ajax_url":"https:\/\/sdtimes.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/plugins/cleantalk-spam-protect/js/apbct-public.js?ver=5.116.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctNocache = {"ajaxurl":"https:\/\/sdtimes.com\/wp-admin\/admin-ajax.php","info_flag":"","set_cookies_flag":"","blog_home":"https:\/\/sdtimes.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/plugins/cleantalk-spam-protect/inc/cleantalk_nocache.js?ver=5.116.2'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/themes/sdtimes2014/js/sd-jq-onload.js?20180110&#038;ver=4.9.9'></script>
<link rel='https://api.w.org/' href='https://sdtimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://sdtimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://sdtimes.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.9" />
<link rel='shortlink' href='https://sdtimes.com/?p=34696' />
<link rel="alternate" type="application/json+oembed" href="https://sdtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsdtimes.com%2Fgoog%2Fgoogle-unveils-the-next-version-of-android%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://sdtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsdtimes.com%2Fgoog%2Fgoogle-unveils-the-next-version-of-android%2F&#038;format=xml" />
<!-- Start of HubSpot Embed Code -->
<script type="text/javascript" id="hs-script-loader" async defer src="//js.hs-scripts.com/3475429.js"></script>
<!-- End of HubSpot Embed Code --><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-846073-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-846073-1');
</script><meta http-equiv="refresh" content="2000" /><script type="text/javascript" src="//www.queryly.com/js/queryly.js"></script>
<script type="text/javascript">
	queryly.QuerylyKey = "af2d91c2c83847f8";
	//queryly.layout.topMargin = -8;
	//queryly.layout.rightMargin = -74;
	queryly.layout.opacity = 1;

	queryly.QuerylyCallback = function (a, b) {
		queryly.jquery("#s").css('opacity', 1);
		queryly.jquery('#queryly_suggest').css('opacity', 1);
	}
</script>
	<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.1.8"; } if (window.wp_blog_version === undefined) { window.wp_blog_version = "4.9.9"; } if (window.addthis_share === undefined) { window.addthis_share = {}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"ui_atversion":300}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = [{"responsiveshare":{"numPreferredServices":3,"counts":"none","size":"20px","style":"responsive","shareCountThreshold":0,"services":"twitter,email,addthis","elements":".addthis_inline_share_toolbox_xdry","id":"responsiveshare"}}]; } else { window.addthis_layers_tools.push({"responsiveshare":{"numPreferredServices":3,"counts":"none","size":"20px","style":"responsive","shareCountThreshold":0,"services":"twitter,email,addthis","elements":".addthis_inline_share_toolbox_xdry","id":"responsiveshare"}});  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.1.8","plugin_mode":"WordPress","anonymous_profile_id":"wp-4417f7f776d9c2ffd08ba9868d73e669","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script><!-- Clicky Web Analytics - https://clicky.com, WordPress Plugin by Yoast - https://yoast.com/wordpress/plugins/clicky/ --><script type='text/javascript'>
	function clicky_gc(name) {
		var ca = document.cookie.split(';');
		for (var i in ca) {
			if (ca[i].indexOf(name + '=') != -1) {
				return decodeURIComponent(ca[i].split('=')[1]);
			}
		}
		return '';
	}
	var username_check = clicky_gc('comment_author_1ea0be0111e3c4a55d44c1d0fc560697');
	if (username_check) var clicky_custom_session = {username: username_check};
</script>
<script>
	
    var clicky_site_ids = clicky_site_ids || [];
    clicky_site_ids.push(100754890);
</script>
<script async src="//static.getclicky.com/js"></script>
</head>
<body class="post-template-default single single-post postid-34696 single-format-standard">

<div class="visible-sm visible-md" id="sm-top-banner-wrapper"></div>
<div class="container dmbs-mobile-menu">
<div class="row hidden-md hidden-lg">
    <nav class="navbar" role="navigation">
        <div class="-container-">
            <div class="navbar-header navbar-inverse">
                <div class="navbar-logo">
                    <a href="https://sdtimes.com/"><img src="/images/sdtimes-logo-mobile.png"></a>
                </div>
                <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-1-collapse">
                    <span class="sr-only">Toggle navigation</span>
                    <span class="icon-bar"></span>
                    <span class="icon-bar"></span>
                    <span class="icon-bar"></span>
                </button>
            </div>
            <div class="collapse navbar-collapse navbar-1-collapse"><ul id="menu-main-desktop" class="nav navbar-nav"><li id="menu-item-29495" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29495"><a title="ITOps Times" href="https://www.itopstimes.com/">ITOps Times</a></li>
<li id="menu-item-5222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5222 dropdown"><a title="Features" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Features <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5789" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5789"><a title="In-Depth" href="https://sdtimes.com/category/in-depth/">In-Depth</a></li>
	<li id="menu-item-5371" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5371"><a title="Buyer&#039;s Guide" href="https://sdtimes.com/category/buyers-guide/">Buyer&#8217;s Guide</a></li>
	<li id="menu-item-5372" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5372"><a title="Special Report" href="https://sdtimes.com/category/special-report/">Special Report</a></li>
	<li id="menu-item-30932" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30932"><a title="SD Times 100" href="https://sdtimes.com/sd-times-100/sd-times-100-2018-its-a-celebration/">SD Times 100</a></li>
	<li id="menu-item-9652" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9652"><a title="Industry Spotlight" href="https://sdtimes.com/category/industry-spotlight/">Industry Spotlight</a></li>
</ul>
</li>
<li id="menu-item-5039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5039 dropdown"><a title="SD Times Magazine" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">SD Times Magazine <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5161" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5161"><a title="Subscribe" href="http://assets.sdtimes.com/sdtimes-subscription">Subscribe</a></li>
	<li id="menu-item-31167" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31167"><a title="Cancel My Subscription" href="https://assets.sdtimes.com/sdtimes-cancel-my-print-subscription">Cancel My Subscription</a></li>
	<li id="menu-item-5392" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5392"><a title="Read The Latest Issue" href="https://assets.sdtimes.com/download-latest-issue-0">Read The Latest Issue</a></li>
	<li id="menu-item-7272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7272"><a title="Back Issues" href="https://sdtimes.com/back-issues/">Back Issues</a></li>
	<li id="menu-item-5397" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5397"><a title="Working with the Editors" href="https://sdtimes.com/sd-times-magazine/working-with-the-editors/">Working with the Editors</a></li>
	<li id="menu-item-5414" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5414"><a title="Guest View Guidelines" href="https://sdtimes.com/sd-times-magazine/guest-view-guidelines/">Guest View Guidelines</a></li>
	<li id="menu-item-5430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5430"><a title="SD Times 100 Guide" href="https://sdtimes.com/sd-times-100/">SD Times 100 Guide</a></li>
	<li id="menu-item-5415" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5415"><a title="Advertise" target="_blank" href="http://assets.sdtimes.com/advertise-with-sd-times#new_tab">Advertise</a></li>
</ul>
</li>
<li id="menu-item-5389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5389 dropdown"><a title="Learning Center" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Learning Center <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-5701" class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5701"><a title="White Papers" href="https://sdtimes.com/sections/white-papers/">White Papers</a></li>
	<li id="menu-item-5704" class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5704"><a title="Webinars" href="https://sdtimes.com/sections/webinars/">Webinars</a></li>
</ul>
</li>
<li id="menu-item-24360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24360"><a title="DevOps" href="/tag/devops/">DevOps</a></li>
</ul></div><div class="mobile-topic-nav"><ul id="menu-topic-navigation" class=""><li id="menu-item-28529" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28529"><a title="API" href="/tag/apis/">API</a></li>
<li id="menu-item-28531" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28531"><a title="Agile" href="/tag/agile/">Agile</a></li>
<li id="menu-item-28532" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28532"><a title="Containers" href="/tag/containers/">Containers</a></li>
<li id="menu-item-28534" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28534"><a title="Data" href="/tag/data/">Data</a></li>
<li id="menu-item-28535" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28535"><a title="DevOps" href="/tag/devops/">DevOps</a></li>
<li id="menu-item-28536" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28536"><a title="DevSecOps" href="/tag/devsecops/">DevSecOps</a></li>
<li id="menu-item-28537" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28537"><a title="Java" href="/tag/java/">Java</a></li>
<li id="menu-item-28538" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28538"><a title="Low Code" href="/tag/low-code/">Low Code</a></li>
<li id="menu-item-33219" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33219"><a title="Microservices" href="/tag/microservices">Microservices</a></li>
<li id="menu-item-28530" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28530"><a title="Monitor" href="/tag/apm/">Monitor</a></li>
<li id="menu-item-28541" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28541"><a title="Security" href="/tag/security/">Security</a></li>
<li id="menu-item-33221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33221"><a title="Serverless" href="/tag/serverless">Serverless</a></li>
<li id="menu-item-28542" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28542"><a title="Test" href="/tag/automated-testing/">Test</a></li>
<li id="menu-item-33220" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33220"><a title="WebDev" href="/tag/webdev">WebDev</a></li>
</ul></div>        </div>
    </nav>
</div>
</div><div class="container dmbs-container">
    <div class="row sd-top-ad">
        <div class="col-xs-12">
            			<div class="banner_ad top_mobile_leaderboard">
							</div>
			            			<div class="banner_ad top_leaderboard">
				<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
 googletag.cmd.push(function() {
  googletag.defineSlot('/67541884/Leaderboard_Top_1', [[970,250],[970,90],[728, 90]], 'div-gpt-ad-1466026021929-0').addService(googletag.pubads());
  googletag.pubads().enableSingleRequest();
  googletag.enableServices();
 });
</script>

<!-- /67541884/Leaderboard_Top_1 -->
<div id='div-gpt-ad-1466026021929-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026021929-0'); });
</script>
</div>			</div>
			        </div>
    </div>

<div class="container dmbs-container">
    <div class="row sd-header">
        <div class="col-md-12">
            <div class="row dmbs-header hidden-xs hidden-sm">

                <div class="dmbs-header-img">
                    <a href="https://sdtimes.com/"><img src="https://sdtimes.com/wp-content/uploads/2014/05/LOGO_SDTimes.png" height="59" width="180" alt="" /></a>
                </div>

                <div class="dmbs-header-text">
                    <div class="row">
                        <div id="nav-grouping-1" class="col-md-8">
                            

    <div class="row dmbs-top-menu">
        <nav class="navbar" role="navigation">
            <div class="-container-">
                <div class="collapse navbar-collapse navbar-1-collapse"><ul id="menu-main-desktop-1" class="nav navbar-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29495"><a title="ITOps Times" href="https://www.itopstimes.com/">ITOps Times</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5222 dropdown"><a title="Features" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Features <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5789"><a title="In-Depth" href="https://sdtimes.com/category/in-depth/">In-Depth</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5371"><a title="Buyer&#039;s Guide" href="https://sdtimes.com/category/buyers-guide/">Buyer&#8217;s Guide</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5372"><a title="Special Report" href="https://sdtimes.com/category/special-report/">Special Report</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30932"><a title="SD Times 100" href="https://sdtimes.com/sd-times-100/sd-times-100-2018-its-a-celebration/">SD Times 100</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9652"><a title="Industry Spotlight" href="https://sdtimes.com/category/industry-spotlight/">Industry Spotlight</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5039 dropdown"><a title="SD Times Magazine" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">SD Times Magazine <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5161"><a title="Subscribe" href="http://assets.sdtimes.com/sdtimes-subscription">Subscribe</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31167"><a title="Cancel My Subscription" href="https://assets.sdtimes.com/sdtimes-cancel-my-print-subscription">Cancel My Subscription</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5392"><a title="Read The Latest Issue" href="https://assets.sdtimes.com/download-latest-issue-0">Read The Latest Issue</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7272"><a title="Back Issues" href="https://sdtimes.com/back-issues/">Back Issues</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5397"><a title="Working with the Editors" href="https://sdtimes.com/sd-times-magazine/working-with-the-editors/">Working with the Editors</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5414"><a title="Guest View Guidelines" href="https://sdtimes.com/sd-times-magazine/guest-view-guidelines/">Guest View Guidelines</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5430"><a title="SD Times 100 Guide" href="https://sdtimes.com/sd-times-100/">SD Times 100 Guide</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5415"><a title="Advertise" target="_blank" href="http://assets.sdtimes.com/advertise-with-sd-times#new_tab">Advertise</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5389 dropdown"><a title="Learning Center" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Learning Center <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5701"><a title="White Papers" href="https://sdtimes.com/sections/white-papers/">White Papers</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-sections menu-item-5704"><a title="Webinars" href="https://sdtimes.com/sections/webinars/">Webinars</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24360"><a title="DevOps" href="/tag/devops/">DevOps</a></li>
</ul></div>            </div>
        </nav>
    </div>

                        </div>
                        <div id="nav-grouping-2" class="col-md-4 hidden-xs">
                            <div class="social">
	<ul>
		<li><a class="fa fa-facebook" href="https://www.facebook.com/SDTimesD2"></a></li>
		<li><a class="fa fa-twitter" href="http://www.twitter.com/sdtimes"></a></li>
	</ul>
</div>                            <div id="top-search-form">
	<form role="search" method="get" id="searchform" class="searchform" action="https://sdtimes.com/">
		<input type="text" class="queryly" value="" name="s" id="s"><script type="text/javascript">queryly.QuerylyBind();</script>
		<button type="submit" id="searchsubmit">
            <i class="fa fa-search" aria-hidden="true"></i>
            Search
        </button>
	</form>
</div>                        </div>
                    </div>
                </div>

            </div>

            <div class="row topic-nav hidden-xs hidden-sm">
                <div class="col-xs-12">
                    <div class="collapse navbar-collapse navbar-1-collapse"><ul id="menu-topic-navigation-1" class="nav navbar-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28529"><a title="API" href="/tag/apis/">API</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28531"><a title="Agile" href="/tag/agile/">Agile</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28532"><a title="Containers" href="/tag/containers/">Containers</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28534"><a title="Data" href="/tag/data/">Data</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28535"><a title="DevOps" href="/tag/devops/">DevOps</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28536"><a title="DevSecOps" href="/tag/devsecops/">DevSecOps</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28537"><a title="Java" href="/tag/java/">Java</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28538"><a title="Low Code" href="/tag/low-code/">Low Code</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33219"><a title="Microservices" href="/tag/microservices">Microservices</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28530"><a title="Monitor" href="/tag/apm/">Monitor</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28541"><a title="Security" href="/tag/security/">Security</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33221"><a title="Serverless" href="/tag/serverless">Serverless</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28542"><a title="Test" href="/tag/automated-testing/">Test</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33220"><a title="WebDev" href="/tag/webdev">WebDev</a></li>
</ul></div>                </div>
            </div>
        </div>
    </div>

<!-- start content container -->
<div class="row dmbs-content">

    
    <div class="col-md-8 col-sm-6 col-xs-12 hnews hentry item dmbs-main post-34696 post type-post status-publish format-standard has-post-thumbnail category-latest-news tag-android tag-android-q tag-google">

      <div>

          <div class="row">
              <h1 class="col-xs-12 page-header">Google unveils the next version of Android</h1>
          </div>

          <div class="row">
              <div class="postmeta">
    <span class="categories"><a href="https://sdtimes.com/category/latest-news/" rel="category tag">Latest News</a></span>
    <div class="published">Published: <span class="updated">March 13th, 2019</span></div>
        - <span class="author-bio"><a href="https://sdtimes.com/author/christina-mulligan/" title="Posts by Christina Cardoza" class="author url fn" rel="author">Christina Cardoza</a></span>
    </div>
              <div class="postsocial">
    <!-- Created with a shortcode from an AddThis plugin --><div class="addthis_inline_share_toolbox_xdry addthis_tool"></div><!-- End of short code snippet --></div>
          </div>

          <div class="row">
              <div class="col-xs-12 postContent">
                  <img width="490" height="688" src="https://sdtimes.com/wp-content/uploads/2019/03/image5-490x688.png" class="alignright size-medium wp-post-image" alt="" srcset="https://sdtimes.com/wp-content/uploads/2019/03/image5-490x688.png 490w, https://sdtimes.com/wp-content/uploads/2019/03/image5-107x150.png 107w, https://sdtimes.com/wp-content/uploads/2019/03/image5-214x300.png 214w, https://sdtimes.com/wp-content/uploads/2019/03/image5-768x1079.png 768w, https://sdtimes.com/wp-content/uploads/2019/03/image5-729x1024.png 729w, https://sdtimes.com/wp-content/uploads/2019/03/image5-150x211.png 150w, https://sdtimes.com/wp-content/uploads/2019/03/image5-57x80.png 57w, https://sdtimes.com/wp-content/uploads/2019/03/image5-400x562.png 400w, https://sdtimes.com/wp-content/uploads/2019/03/image5-128x180.png 128w, https://sdtimes.com/wp-content/uploads/2019/03/image5-36x50.png 36w, https://sdtimes.com/wp-content/uploads/2019/03/image5.png 1139w" sizes="(max-width: 490px) 100vw, 490px" /><div class="at-above-post addthis_tool" data-url="https://sdtimes.com/goog/google-unveils-the-next-version-of-android/"></div><p>The upcoming version of Google’s mobile operating system Android is now available for early adopters and developers. Early adopters can access Beta 1 of Android Q by enrolling any Pixel device and developers will have access through a preview SDK.</p>
<p>According to Google, the release continues to focus on security and privacy by including work from Google Play Protect and runtime permissions as well as new privacy and security features, new APIs, camera capabilities, faster app startup, and enhancements for innovations like foldable phones.</p>
<p>“In 2019, mobile innovation is stronger than ever, with new technologies from 5G to edge to edge displays and even foldable screens. Android is right at the center of this innovation cycle, and thanks to the broad ecosystem of partners across billions of devices, Android&#8217;s helping push the boundaries of hardware and software bringing new experiences and capabilities to users,” David Burke, VP of engineering, wrote in a <a href="https://android-developers.googleblog.com/2019/03/introducing-android-q-beta.html">post</a>.</p>
<p>Other features for the new Android will include more control over location for users; more updates to transparency and personal data; limited access to non-resettable device identifiers; new ways to engage users such as foldables and new screens; ability to share shortcuts; and improved peer-to-peer and Internet connectivity.</p>
<p>Additionally, the team is focused on “modern Android” with requiring targetSDKVersion to 28 in new apps and 64-bit support. Developers looking to take advantage of the SDK and tools will need Android Studio 3.3 or higher, but if they want to leverage the latest fixes for Android Q Burke suggests moving to Android 3.5 or higher.</p>
<p>“We are bringing these changes to you early, so you can have as much time as possible to prepare,” Burke wrote.</p>
<p>&nbsp;</p>
<!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://sdtimes.com/goog/google-unveils-the-next-version-of-android/"></div><!-- AddThis Share Buttons generic via filter on the_content -->              </div>
          </div>

          <div class="row wp-link-pages">
                        </div>

          <div class="row">
              <div class="col-xs-12 tags">
                                        <h3>Article Tags</h3>
                      <p>
                      <a href="https://sdtimes.com/tag/android/" rel="tag">Android</a>, <a href="https://sdtimes.com/tag/android-q/" rel="tag">Android Q</a>, <a href="https://sdtimes.com/tag/google/" rel="tag">Google</a>                      </p>
                                </div>
          </div>

          <div class="row share-after-content">
              <div class="postsubscribe">
    <h4><a href="http://resources.sdtimes.com/sdtimes-subscription?__hstc=54983092.b1c3fc9f788d79895403cd04467299f2.1402689135055.1402689135055.1404158676313.2&__hssc=54983092.2.1404218565731&__hsfp=2368551689">Subscribe to SDTimes</a></h4>
</div>              <div class="postsocial">
    <!-- Created with a shortcode from an AddThis plugin --><div class="addthis_inline_share_toolbox_xdry addthis_tool"></div><!-- End of short code snippet --></div>
          </div>

          <div class="row">
              <div class="col-xs-12">
                                  <div class="authorarea">
                    <div class="authorimg">
                    <img src="https://sdtimes.com/wp-content/uploads/2014/07/MULLIGANChristina_blog-copy.jpg">                    </div>
                    <div class="authortext">
                        <h3>About Christina Cardoza</h3>
                        <p class="authorinfo">
                            Christina Cardoza is the News Editor of SD Times. She is responsible for the oversight of the daily news published to the website as well as the company's weekly newsletter, News on Monday. She covers agile, DevOps, AI, machine learning, mixed reality and software security. She is an undeniable nerd who loves Marvel comics and Star Wars. On Follow her on Twitter at <a href="https://twitter.com/chriscatdoza">@chriscatdoza</a>!                        </p>
                        <a class="author-link" href="https://sdtimes.com/author/christina-mulligan/" rel="author">View all posts by Christina Cardoza</a>
                    </div>
                </div>
                              </div>
          </div>

          <div class="row">
              <div class="col-xs-12">
                  <div id="custom-post-smart-cta">
                      <!--HubSpot Call-to-Action Code --><span class="hs-cta-wrapper" id="hs-cta-wrapper-e3d6f80f-d8d9-48ea-89d0-0a359346ee0b"><span class="hs-cta-node hs-cta-e3d6f80f-d8d9-48ea-89d0-0a359346ee0b" id="hs-cta-e3d6f80f-d8d9-48ea-89d0-0a359346ee0b"><!--[if lte IE 8]><div id="hs-cta-ie-element"></div><![endif]--><a href="https://cta-redirect.hubspot.com/cta/redirect/3475429/e3d6f80f-d8d9-48ea-89d0-0a359346ee0b"  target="_blank" ><img class="hs-cta-img" id="hs-cta-img-e3d6f80f-d8d9-48ea-89d0-0a359346ee0b" style="border-width:0px;" height="118" width="707" src="https://no-cache.hubspot.com/cta/default/3475429/e3d6f80f-d8d9-48ea-89d0-0a359346ee0b.png"  alt="New call-to-action"/></a></span><script charset="utf-8" src="https://js.hscta.net/cta/current.js"></script><script type="text/javascript"> hbspt.cta.load(3475429, 'e3d6f80f-d8d9-48ea-89d0-0a359346ee0b', {}); </script></span><!-- end HubSpot Call-to-Action Code -->                  </div>
              </div>
          </div>
      </div>
    </div>

    <div class="col-md-4 col-sm-6 col-xs-12 hidden-xs dmbs-right">
    <aside id="trending-stories-widget-2" class="widget trending-stories-widget"><!-- From cache --><div id="trending">
    <div class="trendinghead">
        <h2>Trending Stories</h2>
    </div>
    <div class="feeds">
        <ul>
                                <li>
                        <span>1</span>
                        <div>
                            <a href="http://sdtimes.com/webdev/the-openjs-foundation-officially-formed-for-the-javascript-community/">The OpenJS Foundation officially formed for the JavaScript community</a>
                        </div>
                    </li>
                                                    <li>
                        <span>2</span>
                        <div>
                            <a href="http://sdtimes.com/softwaredev/for-development-teams-its-time-to-throw-out-the-open-office-plan/">For development teams, it's time to throw out the open-office plan</a>
                        </div>
                    </li>
                                                    <li>
                        <span>3</span>
                        <div>
                            <a href="http://sdtimes.com/softwaredev/analyst-watch-the-ubiquity-of-developers/">Analyst Watch: The ubiquity of developers</a>
                        </div>
                    </li>
                                                    <li>
                        <span>4</span>
                        <div>
                            <a href="http://sdtimes.com/agile/how-to-get-started-with-safe/">How to get started with SAFe</a>
                        </div>
                    </li>
                                        </ul>
    </div>
</div>
</aside>			<div class="banner_ad medrec_1_ad">
				<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/med_rec_1', [[300,600],[300, 250]], 'div-gpt-ad-1466026216582-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/med_rec_1 -->
<div id='div-gpt-ad-1466026216582-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026216582-0'); }); 
</script>
</div>			</div>
			<aside id="foo_widget-2" class="widget widget_foo_widget"></aside>			<div class="banner_ad medrec_2_ad">
				<div data-configid="37024874/68168901" style="width:300px; height:204px;" class="issuuembed"></div>
<script type="text/javascript" src="//e.issuu.com/embed.js" async="true"></script>			</div>
						<div class="banner_ad medrec_3_ad">
				<div data-configid="37024874/68111923" style="width:300px; height:204px;" class="issuuembed"></div>
<script type="text/javascript" src="//e.issuu.com/embed.js" async="true"></script>			</div>
						<div class="banner_ad medrec_4_ad">
				<script type='text/javascript'>
 googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/SDTimes', [300, 250], 'div-gpt-ad-1552331323208-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
<script>
  
<!-- /67541884/SDTimes -->
<div id='div-gpt-ad-1552331323208-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1552331323208-0'); });
</script>
</div>			</div>
						<div class="banner_ad medrec_5_ad">
				<script type='text/javascript'>
  googletag.cmd.push(function() {
  googletag.defineSlot('/67541884/med_rec_5', [300, 250], 'div-gpt-ad-1466026594130-0').addService(googletag.pubads());
  googletag.pubads().enableSingleRequest();
  googletag.enableServices();
 });
</script>

<!-- /67541884/med_rec_5 -->
<div id='div-gpt-ad-1466026594130-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026594130-0'); }); 
</script>
</div>			</div>
						<div class="banner_ad medrec_6_ad">
				<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/med_rec_6', [300, 250], 'div-gpt-ad-1466026679557-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/med_rec_6 -->
<div id='div-gpt-ad-1466026679557-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466026679557-0'); });
</script>
</div>			</div>
			</div>

          	<div class="col-xs-12 related-posts">
		<div class="row headerbox">
			<h2 class="col-md-12">Related Articles</h2>
		</div>

		<div class="row">
							<div class="col-md-6 col-xs-12 related-post-item">
					<div class="row">
						<div class="col-xs-6">
															<img width="150" height="70" src="https://sdtimes.com/wp-content/uploads/2019/03/3ce0d3d4ce3eb4ccdca19626246dfd26-150x70.png" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" srcset="https://sdtimes.com/wp-content/uploads/2019/03/3ce0d3d4ce3eb4ccdca19626246dfd26-150x70.png 150w, https://sdtimes.com/wp-content/uploads/2019/03/3ce0d3d4ce3eb4ccdca19626246dfd26-300x141.png 300w, https://sdtimes.com/wp-content/uploads/2019/03/3ce0d3d4ce3eb4ccdca19626246dfd26-768x360.png 768w, https://sdtimes.com/wp-content/uploads/2019/03/3ce0d3d4ce3eb4ccdca19626246dfd26-1024x480.png 1024w, https://sdtimes.com/wp-content/uploads/2019/03/3ce0d3d4ce3eb4ccdca19626246dfd26-490x230.png 490w, https://sdtimes.com/wp-content/uploads/2019/03/3ce0d3d4ce3eb4ccdca19626246dfd26-400x188.png 400w, https://sdtimes.com/wp-content/uploads/2019/03/3ce0d3d4ce3eb4ccdca19626246dfd26-320x150.png 320w, https://sdtimes.com/wp-content/uploads/2019/03/3ce0d3d4ce3eb4ccdca19626246dfd26-171x80.png 171w, https://sdtimes.com/wp-content/uploads/2019/03/3ce0d3d4ce3eb4ccdca19626246dfd26-100x47.png 100w, https://sdtimes.com/wp-content/uploads/2019/03/3ce0d3d4ce3eb4ccdca19626246dfd26.png 1045w" sizes="(max-width: 150px) 100vw, 150px" />													</div>
						<div class="col-xs-6">
							<h3 class="title">
								<a href="https://sdtimes.com/goog/google-makes-strides-with-promoting-data-openness/" title="Permalink to Google makes strides with promoting data openness" rel="bookmark">Google makes strides with promoting data openness</a>
							</h3>
						</div>
					</div>
				</div>
							<div class="col-md-6 col-xs-12 related-post-item">
					<div class="row">
						<div class="col-xs-6">
															<img width="150" height="84" src="https://sdtimes.com/wp-content/uploads/2019/03/hero_720-150x84.png" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" srcset="https://sdtimes.com/wp-content/uploads/2019/03/hero_720-150x84.png 150w, https://sdtimes.com/wp-content/uploads/2019/03/hero_720-300x169.png 300w, https://sdtimes.com/wp-content/uploads/2019/03/hero_720-490x276.png 490w, https://sdtimes.com/wp-content/uploads/2019/03/hero_720-142x80.png 142w, https://sdtimes.com/wp-content/uploads/2019/03/hero_720-400x225.png 400w, https://sdtimes.com/wp-content/uploads/2019/03/hero_720-320x180.png 320w, https://sdtimes.com/wp-content/uploads/2019/03/hero_720-89x50.png 89w, https://sdtimes.com/wp-content/uploads/2019/03/hero_720.png 720w" sizes="(max-width: 150px) 100vw, 150px" />													</div>
						<div class="col-xs-6">
							<h3 class="title">
								<a href="https://sdtimes.com/ai/tensorflow-to-expand-ai-capabilities-into-mobile-iot-javascript/" title="Permalink to TensorFlow to expand AI capabilities into mobile, IoT, JavaScript" rel="bookmark">TensorFlow to expand AI capabilities into mobile, IoT, JavaScript</a>
							</h3>
						</div>
					</div>
				</div>
							<div class="col-md-6 col-xs-12 related-post-item">
					<div class="row">
						<div class="col-xs-6">
															<img width="150" height="208" src="https://sdtimes.com/wp-content/uploads/2019/03/6a28a934d3ee817a6da19ca1db264340-150x208.png" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" srcset="https://sdtimes.com/wp-content/uploads/2019/03/6a28a934d3ee817a6da19ca1db264340-150x208.png 150w, https://sdtimes.com/wp-content/uploads/2019/03/6a28a934d3ee817a6da19ca1db264340-108x150.png 108w, https://sdtimes.com/wp-content/uploads/2019/03/6a28a934d3ee817a6da19ca1db264340-217x300.png 217w, https://sdtimes.com/wp-content/uploads/2019/03/6a28a934d3ee817a6da19ca1db264340-58x80.png 58w, https://sdtimes.com/wp-content/uploads/2019/03/6a28a934d3ee817a6da19ca1db264340-130x180.png 130w, https://sdtimes.com/wp-content/uploads/2019/03/6a28a934d3ee817a6da19ca1db264340-36x50.png 36w, https://sdtimes.com/wp-content/uploads/2019/03/6a28a934d3ee817a6da19ca1db264340.png 289w" sizes="(max-width: 150px) 100vw, 150px" />													</div>
						<div class="col-xs-6">
							<h3 class="title">
								<a href="https://sdtimes.com/softwaredev/sd-times-news-digest-windows-calculator-now-open-source-waymo-releases-laser-beam-honeycomb-sensor-and-android-rewarded-products-in-beta/" title="Permalink to SD Times news digest: Windows Calculator now open source, Waymo releases Laser Beam Honeycomb sensor, and Android rewarded products in beta" rel="bookmark">SD Times news digest: Windows Calculator now open source, Waymo releases Laser Beam Honeycomb sensor, and Android rewarded products in beta</a>
							</h3>
						</div>
					</div>
				</div>
							<div class="col-md-6 col-xs-12 related-post-item">
					<div class="row">
						<div class="col-xs-6">
															<img width="150" height="93" src="https://sdtimes.com/wp-content/uploads/2019/03/D0ftzaLX4AA5iL5-150x93.jpg" class="attachment-post-related-thumb size-post-related-thumb wp-post-image" alt="" srcset="https://sdtimes.com/wp-content/uploads/2019/03/D0ftzaLX4AA5iL5-150x93.jpg 150w, https://sdtimes.com/wp-content/uploads/2019/03/D0ftzaLX4AA5iL5-300x185.jpg 300w, https://sdtimes.com/wp-content/uploads/2019/03/D0ftzaLX4AA5iL5-768x475.jpg 768w, https://sdtimes.com/wp-content/uploads/2019/03/D0ftzaLX4AA5iL5-1024x633.jpg 1024w, https://sdtimes.com/wp-content/uploads/2019/03/D0ftzaLX4AA5iL5-490x303.jpg 490w, https://sdtimes.com/wp-content/uploads/2019/03/D0ftzaLX4AA5iL5-129x80.jpg 129w, https://sdtimes.com/wp-content/uploads/2019/03/D0ftzaLX4AA5iL5-400x247.jpg 400w, https://sdtimes.com/wp-content/uploads/2019/03/D0ftzaLX4AA5iL5-291x180.jpg 291w, https://sdtimes.com/wp-content/uploads/2019/03/D0ftzaLX4AA5iL5-81x50.jpg 81w, https://sdtimes.com/wp-content/uploads/2019/03/D0ftzaLX4AA5iL5.jpg 1199w" sizes="(max-width: 150px) 100vw, 150px" />													</div>
						<div class="col-xs-6">
							<h3 class="title">
								<a href="https://sdtimes.com/webdev/report-react-is-gaining-in-popularity-but-angular-remains-in-the-lead/" title="Permalink to Report: React is gaining in popularity, but Angular remains in the lead" rel="bookmark">Report: React is gaining in popularity, but Angular remains in the lead</a>
							</h3>
						</div>
					</div>
				</div>
					</div>
	</div>

      
            


    <div class="col-xs-12">
        			<div class="banner_ad bottom_leaderboard">
				<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/leader_1_bottom', [728, 90], 'div-gpt-ad-1466028372866-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/leader_1_bottom -->
<div id='div-gpt-ad-1466028372866-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466028372866-0'); });
</script>
</div>			</div>
			    </div>

    <div class="col-xs-12">
        			<div class="banner_ad bottom_leaderboard_2">
				<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/leader_2_bottom', [728, 90], 'div-gpt-ad-1466028474085-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/leader_2_bottom -->
<div id='div-gpt-ad-1466028474085-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466028474085-0'); });
</script>
</div>			</div>
			    </div>

</div>

<!-- end content container -->

    <div class="row sd-footer">
            <div class="col-xs-12 col-md-4">
        <div class="footer-interior">
            <aside id="nav_menu-3" class="widget widget_nav_menu"><h3>SD Times</h3><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-5041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5041"><a title="_blank" href="https://d2emerge.com/">About Us</a></li>
<li id="menu-item-5418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5418"><a title="_blank" href="https://d2emerge.com/about/">Contact Us</a></li>
<li id="menu-item-5419" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5419"><a href="https://sdtimes.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-5045" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5045"><a href="https://sdtimes.com/site-map/">Site Map</a></li>
<li id="menu-item-5047" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5047"><a target="_blank" href="http://assets.sdtimes.com/advertise-with-sd-times#new_tab">Advertise</a></li>
<li id="menu-item-5160" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5160"><a href="http://assets.sdtimes.com/sdtimes-subscription">Subscribe</a></li>
<li id="menu-item-31166" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31166"><a href="https://assets.sdtimes.com/sdtimes-manage-my-preferences">Manage My Preferences</a></li>
</ul></div></aside>        </div>
    </div>
    <div class="col-xs-12 col-md-4">
        <div class="footer-interior">
            <aside id="sdtimes-subscribe-widget-2" class="widget sdtimes-subscribe-widget"><div id="subscribe">

    
    <h3 class="title">Subscribe to SD Times</h3>
    <div class="sdtimessubscribe row">
        <div class="col-xs-5">
            <a href="http://assets.sdtimes.com/download-latest-issue" target="_blank"><img width="180" height="245" src="https://sdtimes.com/wp-content/uploads/2019/02/Mach021cov_180pixels.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://sdtimes.com/wp-content/uploads/2019/02/Mach021cov_180pixels.png 180w, https://sdtimes.com/wp-content/uploads/2019/02/Mach021cov_180pixels-110x150.png 110w, https://sdtimes.com/wp-content/uploads/2019/02/Mach021cov_180pixels-150x204.png 150w, https://sdtimes.com/wp-content/uploads/2019/02/Mach021cov_180pixels-59x80.png 59w, https://sdtimes.com/wp-content/uploads/2019/02/Mach021cov_180pixels-132x180.png 132w, https://sdtimes.com/wp-content/uploads/2019/02/Mach021cov_180pixels-37x50.png 37w" sizes="(max-width: 180px) 100vw, 180px" /></a>        </div>
        <div class="col-xs-7">
            <div class="smallertext"><p>Ready for your SD Times magazine? It's just a click away!</p></div>
            <p><a class="button" href="http://assets.sdtimes.com/sdtimes-subscription">Subscribe</a></p>            <ul class="links">
                <li><a href="http://assets.sdtimes.com/download-latest-issue" target="_blank">Read Current Issue</a></li>
                <li><a href="https://sdtimes.com/back-issues/" target="_blank">Read Back Issues</a></li>
            </ul>
        </div>
    </div>

</div></aside>        </div>
    </div>
    <div class="col-xs-12 col-md-4">
        <div class="footer-interior">
            <aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a class="twitter-timeline" href="https://twitter.com/sdtimes" data-widget-id="472430906574004224" data-height="450" data-chrome="transparent">Tweets by @sdtimes</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div></aside>        </div>
    </div>
    </div>

    <div class="row footer-credit">
        <div class="col-xs-12 col-md-2 copyright">&copy; 2019 D2 Emerge LLC.</div>
        <div class="col-xs-12 col-md-8 min-footer-menu">
            <aside id="nav_menu-2" class="widget widget_nav_menu"><div class="menu-footer-mini-menu-container"><ul id="menu-footer-mini-menu" class="menu"><li id="menu-item-6911" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6911"><a href="http://assets.sdtimes.com/sdtimes-subscription">Subscribe</a></li>
<li id="menu-item-26413" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26413"><a href="https://d2emerge.com/about/">Contact Us</a></li>
<li id="menu-item-5065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5065"><a href="https://sdtimes.com/site-map/">Site Map</a></li>
<li id="menu-item-5066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5066"><a href="https://sdtimes.com/privacy-policy/">Privacy Policy</a></li>
</ul></div></aside>        </div>
        <div class="col-xs-12 col-md-2"><div class="social">
	<ul>
		<li><a class="fa fa-facebook" href="https://www.facebook.com/SDTimesD2"></a></li>
		<li><a class="fa fa-twitter" href="http://www.twitter.com/sdtimes"></a></li>
	</ul>
</div></div>
    </div>

</div>
<!-- end main container -->
<div class="adWrap">
    <div class="adWrapCenter">
        <div class="innerAdWrapCenter">
            <div class="fl">
                			<div class="banner_ad gutter_ad_left">
				<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/Gutter_left', [300, 1050], 'div-gpt-ad-1529072259969-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/Gutter_left -->
<div id='div-gpt-ad-1529072259969-0' style='height:1050px;width:300px;justify-content:flex-end;align-items;flex-start;margin:0;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1529072259969-0'); });
</script>
</div>			</div>
			            </div>
            <div class="fr">
                			<div class="banner_ad gutter_ad_right">
				<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/67541884/Gutter_Right', [ 300.0 ,  1050.0 ], 'div-gpt-ad-1528279934873-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /67541884/Gutter_Right -->
<div id='div-gpt-ad-1528279934873-0' style='height:1050px;width:300px;justify-content:flex-start;align-items;flex-start;margin:0;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1528279934873-0'); });
</script>
</div>			</div>
			            </div>
        </div>
    </div>
</div>

<script type="text/javascript">
	jQuery('a[title="_blank"]').each(
			function(i) {
				jQuery(this).attr('target', '_blank');
				jQuery(this).attr('title', jQuery(this).text());
			}
		);
</script> <div style="width:100%;text-align:center; font-size:11px; clear:both"><a target="_blank" title="Insert HTML Snippet Wordpress Plugin" href="http://xyzscripts.com/wordpress-plugins/insert-html-snippet/">HTML Snippets</a> Powered By : <a target="_blank" title="PHP Scripts & Wordpress Plugins" href="http://www.xyzscripts.com" >XYZScripts.com</a></div><link rel="stylesheet" type="text/css" href="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.0/cookieconsent.min.css" />
<script src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.0/cookieconsent.min.js"></script>
<script>
window.addEventListener("load", function(){
window.cookieconsent.initialise({
  "palette": {
    "popup": {
      "background": "#000",
      "opacity": "0.7"
    },
    "button": {
      "background": "#fd4239",
      "color": "#fff"
    }
  },
  "theme": "edgeless",
  "position": "top",
  "onInitialise": function() {
  	// clear the Hubspot opt out since we are using cookie consent instead
  	document.cookie = "__hs_opt_out=no;expires=Thu, 01 Jan 1970 00:00:00 GMT;path=/;domain=.sdtimes.com";
  	if( _hsq ) {
  		//_hsq.push(['revokeCookieConsent']);
  	}
  }
})});
</script>
	<link rel='stylesheet' id='barracuda-fe-style-css'  href='https://sdtimes.com/wp-content/plugins/ff-help/css/barracuda-fe-admin-bar-styles.css?ver=4.9.9' type='text/css' media='all' />
<script type='text/javascript' src='https://sdtimes.com/wp-content/themes/sdtimes2014/js/fusionfarm-bootstrap-responsive.js?ver=1.0'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/lity/2.3.1/lity.min.js?ver=2.3.1'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/iframe-resizer/3.6.1/iframeResizer.min.js?ver=3.6.1'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/themes/devdmbootstrap3/js/bootstrap.js?ver=1.40'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=3.0.0-beta.1'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-includes/js/wp-embed.min.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://sdtimes.com/wp-content/plugins/ff-help/js/barracuda-fe-script.js?ver=4.9.9'></script>
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M8DVS3N"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) --><!-- START Fusionfarm/Hubspot API -- subscription popup -->
<!-- PLACE THIS IN THE <head> OF EVERY PAGE THAT YOU WANT THE POPUP -->
<script type="text/javascript" src="/hubspot-api/Fusionfarm/sdtimes-settings.js.php"></script>
<script type="text/javascript" src="/hubspot-api/Fusionfarm/sdtimes-offer-popup.js"></script>
<script type="text/javascript">
jQuery(
    function(){
        Fusionfarm.setup_events();
    }
);
</script>


<div id="sd-premium-inline" class="col-xs-12">
    <div class="sd-premium-out">
        <div class="sd-premium-int">
            <div class="sd-premium-head">
                <img class="sd-premium-sd-logo" src="https://sdtimes.com/wp-content/uploads/2014/05/LOGO_SDTimes.png">
                <img class="sd-premium-logo" src="/images/sd-premium.png">
            </div>
            <div class="sd-premium-body">
                <p><strong>Get access to this and other exclusive articles for <span class="free">FREE!</span></strong></p>
                <p>There's no charge and it only takes a few seconds.</p>
                <a class="sd-premium-cta" href="#" data-sd-premium-modal>Sign up now!</a>
            </div>
        </div>
    </div>
</div>
<!-- END Fusionfarm/Hubspot API -- subscription popup --><script>
ga(function(){
  var gaName = ga.getAll()[0].get('name');
  ga(gaName + '.require', 'Clearbit', {"mapping":{"companyName":"dimension1","companyDomain":"dimension2","companyTags":"dimension3","companySector":"dimension4","companyIndustryGroup":"dimension5","companyIndustry":"dimension6","companySubIndustry":"dimension7","companyType":"dimension8","companyEmployeesRange":"dimension9","companyAlexaRank":"dimension10","companyCity":"dimension11","companyState":"dimension12","companyCountry":"dimension13","companyFunding":"dimension14","companyTech":"dimension15"}});
});
</script>
<script async src="https://ga.clearbit.com/v1/ga.js?authorization=pk_6c0d4a85db57d64ddbe53597246f9578"></script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"237c3e91d7","applicationID":"12810909","transactionName":"YlJQMhQDWkEDBxcPXFsYcwUSC1tcTRcKCFRZUg==","queueTime":0,"applicationTime":294,"atts":"ThVTRFwZSU8=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>